Orbi WiFi 7 RBE973
Reply

Re: R9000 AD7200 x10 Firmware Ver 1.0.5.24 kills WiFi

user12a
Star

R9000 AD7200 x10 Firmware Ver 1.0.5.24 kills WiFi

It seems frustrating upgrading firmware on the Netgear x10 R9000 . I recently upgraded to current version 1.0.5.24 and all the Wifi (2.4, 5, 60) cannot be enabled, all come in off state after power on. The router status showed the Wireless AP is off on all 3 of them. The white LEDs for the 2.4 and 5 are off, but the 60 is on. Not sure if the 60 is really on as I don’t have a receiver to test that. The Wireless and WPS button LEDs are both on. I cannot turn on the 2.5 and 5 by any means as none of my wireless devices detect their SSID. So I read on the Netgear forum and noticed many people had this same WiFi problem in earlier FW builds in 2019 but no real solution offered other than returning the unit. I have tried all previously offered suggestions like testing with the Wireless button, resetting the router NVRAM through the reset button and admin GUI reset, hard 30-30-30 reset, downgrading firmware versions. None of the methods worked to restore my WiFi. I tried the Voxel firmware which is based on the Netgear FW and still no go. I flashed it with the dd-wrt FW and bang, all the Wifi come back on! All LEDs are on, SSID’s are detected by my devices! This verifies that there is no problem with the router Hardware!!! The only thing must be to do with the latest Netgear Firmware which somehow triggered some values in the NVRAM and disabled the WiFi. I needed to go back to the Netgear FW as I want the Plex router support on the X10. I re-flashed back to an earlier version of Netgear FW and the same disabled WiFi condition came right back. Flashing to dd-wrt did not clear whatever the Netgear FW set. I am still hosed. I have spent quite a bit of time troubleshooting this and can only set this expensive piece of brick aside. The previous build was stable but I thought there is some upgrade for Plex in this FW release, I was dead wrong. In the mean time I have reverted back to my Linksys WRT1900ACS which is almost as fast but no built in Plex. I really hope I can get the Netgear X10 fixed. So is there any Netgear expert who can help on this?
Message 1 of 10

Accepted Solutions
NighthawkTech
Aspirant

Re: R9000 AD7200 x10 Firmware Ver 1.0.5.24 kills WiFi

Did you erase the nvram using the following commands via serial connection?

 

nvram erase 

go

 

 

 

 

View solution in original post

Message 7 of 10

All Replies
NighthawkTech
Aspirant

Re: R9000 AD7200 x10 Firmware Ver 1.0.5.24 kills WiFi

Hello!. I'm having the same problem. Could you tell me what version and Build of DD-WRT fixed the wi-fi? Thanks! 😞
Message 2 of 10
user12a
Star

Re: R9000 AD7200 x10 Firmware Ver 1.0.5.24 kills WiFi

I used the Kong build R9000-factory-to-ddwrt.img dated 3-18-2019.
Found at:
ftp://gakinaction.ddns.net/Kong%20PTB/3-23-2019/K4-AC-ALPINE/
Then you can upgrade to any bin in the dd-wrt repository.

 

To go back to factory, I was unable to get the R9000 in TFTP mode.
However it is easy to just flash it back within dd-wrt with ddwrt-netgear-R9000.bin 2/21/17
found in MyOpenForum.com, which brings back to Netgear ver 1.0.1.35

dd-wrt bin  fixes the R9000 WiFi but my experience with dd-wrt builds is that the USB file share is extremely slow.

 

Still have not heard back from anyone with Netgear to help.

Message 3 of 10
user12a
Star

Re: R9000 AD7200 x10 Firmware Ver 1.0.5.24 kills WiFi

It is MyOpenRouter, not MyOpenForum.com

Message 4 of 10
user12a
Star

Re: R9000 AD7200 x10 Firmware Ver 1.0.5.24 kills WiFi

It seems either Netgear does not read this forum or their online personnel are not knowledgeable to help solve issues here.  I have not been able to resolve this dead WiFi issue on the R9000 from FW upgrade.  I am certain that it is SW/FW related and no HW issue.  Only Netgear can resolve this FW issue that seemed to have plagued a number of people similarly. 

 

The R9000 is unable to turn on the radio through the Wireless AP after I flashed with the latest FW.  The iwconfig and apstats commands on the router through telnet reported the following as reported in the Wireless_log file in the router.   There is something wrong with the Wireless AP control in the FW.

 

########### [ Show Wireless Settings ] #############

########### [ iwconfig             ] #############

wlan0     IEEE 802.11  ESSID:off/any 

          Mode:Managed  Access Point: Not-Associated  

          Retry short limit:7   RTS thr:off   Fragment thr:off

          Encryption key:off

          Power Management:on

         

########### [ Associated station information ] #############

########### [ apstats              ] #############

apstats: No application recognized options. Using defaults: AP level, non-recursive.

Use -h for help

 

AP Level Stats:

 

WLAN stats:

No radio interfaces found

 

########### [ 80211stats           ] #############

########### [ athstats             ] #############

########### [ wifitool             ] #############

 

I could not get the Netgear FW to work.  In the meantime, I have flashed it with the latest DD-WRT build and all the WiFi appear to be working correctly.  As I said previously, this proves all the HW is working correctly.    DD-WRT does not support the Plex server.  The only reason I got this expensive router was to use the build-in Plex server, not for the useless 60GHz AD.   Now I have to go back to run the Synology NAS which also has Plex build-in.  Netgear needs to seriously test their firmware before releasing it.  I certainly hope they can fix it in the next firmware release.  Is anyone from Netgear reading this??

 

Message 5 of 10
user12a
Star

Re: R9000 AD7200 x10 Firmware Ver 1.0.5.24 kills WiFi

Just to let everyone know that this Wifi corruption issue has been finally resolved.   The netgear bin did corrupt the nvram such that the overlay volume dismounted.  I have completely reset the nvram (not simple factory reset) to true factory reset condition and the overlay volume remounted and all Wifi are back.   Everything is good.   Be very cautious on upgrading your Netgear firmware as Netgear is not there to help you when it bricks your router that is out of warranty.  Took half a year to reolve this.

Message 6 of 10
NighthawkTech
Aspirant

Re: R9000 AD7200 x10 Firmware Ver 1.0.5.24 kills WiFi

Did you erase the nvram using the following commands via serial connection?

 

nvram erase 

go

 

 

 

 

Message 7 of 10
user12a
Star

Re: R9000 AD7200 x10 Firmware Ver 1.0.5.24 kills WiFi

Execute these commands through telnet into the router, courtesy of kamoj at snb.

WARNING: These commands will erase all your settings and should not be tried out if you are under warranty.  Use at your own risk.

To make a real "Factory reset" issue these commands:

For R7800:

Code:

nvram default
nvram commit
mtd erase netgear
reboot


For the R9000 the mtd command does not exist so you should try these commands instead:

Code:

nvram default
nvram commit
ngmtd="$(awk -F: '/"netgear"$/ {print $1}' /proc/mtd | grep mtd)"
[ -n "$ngmtd" ] && flash_erase /dev/"$ngmtd" 0 0
reboot

Model: R9000|Nighthawk X10 AD7200 Smart WiFi Router
Message 8 of 10
NighthawkTech
Aspirant

Re: R9000 AD7200 x10 Firmware Ver 1.0.5.24 kills WiFi

I tried the commands on my R9000. Wifi still dead. Is Kamoj add-on mandatory for this procedure?
Message 9 of 10
user12a
Star

Re: R9000 AD7200 x10 Firmware Ver 1.0.5.24 kills WiFi

Resetting nvram has nothing to do with loading any add-on.

You need to verify if you indeed have a hardware issue.

My router wifi worked with the dd-wrt FW but not with NG's after firmware upgrade.  You may want to try dd-wrt or openwrt FW to verifiy your hardware first.  They use different nvram structure.

Good luck.

 

Message 10 of 10
Top Contributors
Discussion stats
  • 9 replies
  • 4431 views
  • 3 kudos
  • 2 in conversation
Announcements

Orbi WiFi 7