Orbi WiFi 7 RBE973
Reply

Synology nas Pihole

cyberwasp
Star

Synology nas Pihole

Recently Cable upgraded their service that included a pos router. It was suggested I  purchase my own. I got a Netgearnighthawk AX5400 (RAX50) which doesn't seem to appear in the above Model list, go figure.

 

My question to the community is as follows. I'm running a Synology NAS running Pihole. On my previous router I had the DNS of the router pointing to my Synology. I've been on chat with Netgear twice as it seems I can not set the DNS. Could someone out there please help. I'd like to understand why this is so difficult when it worked with a cheap pos cable modem/router the I had before cable upgraded my service. tiaSmiley Sad

Message 1 of 8

Accepted Solutions
cyberwasp
Star

Re: Synology nas Pihole


@plemans wrote:

 



My NAS IP is 192.168.1.2 and is static. In the Pihole setup under Serverip it's set to the same NAS adress. However it keeps starting/restarting. I followed this tutorial, "How to Setup Pi-hole on a Synology NAS using Docker! - YouTube. the first time a few months ago and it worked.Then for some reason it started this. So I figured, "delete it and start over. As soon as I put in my nas IP in ServerIP it start/stops over and over---what stops/starts over and over again?

 

Am still learning the lingo. What modem/gateway are you using? Cable modem into router? Your router is connected to something providing internet service. What device is that? 


 


plemans. I finally got everything back to working. I first shut everything down and reset the modem and booted the PC and then the NAS. I then deleted Pihole and it's directories. Reistalled pihole and made sure it was stable as the previous one was stopping and starting again. I then went into the router and it let me set the DNS to point to the NAS, "wouldn't before." I also reconnects a few wireless cams successfully.

My apologies for the confusion on my part as I've had my head stuck in Photoshop for the last 10 years and haven't paid much attention to tech. Old age sucks as far as memory goes. I used to know all of these terms and could breeze right through them. 

 

View solution in original post

Message 5 of 8

All Replies
plemans
Guru

Re: Synology nas Pihole

You can set the dns for the ip off the nas. 

I've done it on my pihole as well. 

what error are you getting? 

How do I set static Domain Name System servers on my NETGEAR router? | Answer | NETGEAR Support

 

What modem/gateway are you using? 

 

reason you couldn't find yours is you posted in the nighthawk AC forum and not the AX forum. 

 

Nighthawk Routers with WiFi 6 (AX) - NETGEAR Communities

 

 

Message 2 of 8
cyberwasp
Star

Re: Synology nas Pihole


@plemans wrote:

You can set the dns for the ip off the nas. 

I've done it on my pihole as well. 

what error are you getting? 

How do I set static Domain Name System servers on my NETGEAR router? | Answer | NETGEAR Support

 

What modem/gateway are you using? 

 

reason you couldn't find yours is you posted in the nighthawk AC forum and not the AX forum. 

 

Nighthawk Routers with WiFi 6 (AX) - NETGEAR Communities

 

 



My NAS IP is 192.168.1.2 and is static. In the Pihole setup under Serverip it's set to the same NAS adress. However it keeps starting/restarting. I followed this tutorial, "How to Setup Pi-hole on a Synology NAS using Docker! - YouTube. the first time a few months ago and it worked.Then for some reason it started this. So I figured, "delete it and start over. As soon as I put in my nas IP in ServerIP it start/stops over and over

 

Am still learning the lingo. What modem/gateway are you using? Cable modem into router?

Message 3 of 8
plemans
Guru

Re: Synology nas Pihole


 



My NAS IP is 192.168.1.2 and is static. In the Pihole setup under Serverip it's set to the same NAS adress. However it keeps starting/restarting. I followed this tutorial, "How to Setup Pi-hole on a Synology NAS using Docker! - YouTube. the first time a few months ago and it worked.Then for some reason it started this. So I figured, "delete it and start over. As soon as I put in my nas IP in ServerIP it start/stops over and over---what stops/starts over and over again? You'll enter the servers IP for the docker pihole address into the netgears DNS address for internet setup. showing pictures of what you're doing and what happens helps 

 

Am still learning the lingo. What modem/gateway are you using? Cable modem into router? Your router is connected to something providing internet service. What device is that? 


 

Message 4 of 8
cyberwasp
Star

Re: Synology nas Pihole


@plemans wrote:

 



My NAS IP is 192.168.1.2 and is static. In the Pihole setup under Serverip it's set to the same NAS adress. However it keeps starting/restarting. I followed this tutorial, "How to Setup Pi-hole on a Synology NAS using Docker! - YouTube. the first time a few months ago and it worked.Then for some reason it started this. So I figured, "delete it and start over. As soon as I put in my nas IP in ServerIP it start/stops over and over---what stops/starts over and over again?

 

Am still learning the lingo. What modem/gateway are you using? Cable modem into router? Your router is connected to something providing internet service. What device is that? 


 


plemans. I finally got everything back to working. I first shut everything down and reset the modem and booted the PC and then the NAS. I then deleted Pihole and it's directories. Reistalled pihole and made sure it was stable as the previous one was stopping and starting again. I then went into the router and it let me set the DNS to point to the NAS, "wouldn't before." I also reconnects a few wireless cams successfully.

My apologies for the confusion on my part as I've had my head stuck in Photoshop for the last 10 years and haven't paid much attention to tech. Old age sucks as far as memory goes. I used to know all of these terms and could breeze right through them. 

 

Message 5 of 8
cyberwasp
Star

Re: Synology nas Pihole

I hope you don't mind. I tried to find  the AX model forum but still not seeing a forum list. either I'm blind or there is not a way to get there. 

 

Had a recent set back. was trying to get my wireless Raspbery pi connect and swapped the two DNS entries to see if puting it as primary would work. When doing so the dns returned as blank. I forget what I did to get the entries to stay. when I hit apply and the page reloads, they are gone. 

rax50.JPG

Message 6 of 8
plemans
Guru

Re: Synology nas Pihole

I just tried it on a RAX200, an RAXE500, and a RBK752 (don't have your model) and it all worked fine on mine. 

Have you tried a different browser/pc?

Message 7 of 8
cyberwasp
Star

Re: Synology nas Pihole

Tried 3 browsers and 2 pc's plus my phone. The only way it would let me is a complete reset. start from scratch. Than tonight, tech support had me run an update. Now even the reset won't let me!   BTW: It's an RAX50 for which I didn't see in the model list either.

 

Ok, just got off with tech support and we tried something. I logged into router page went to Internet> DNS and it was blank. Went back to home and then back tro internet and the IP's I put in showed this time and let me edit them. Am thinking it's a bug of sorts as she's having me watch it and am expecting a call form a different tech, "higher up," I guess as he wants to record the whole routine.

 

Wish you were near so I can take you to dinner or something for the help. Thanks again!!!

Message 8 of 8
Top Contributors
Discussion stats
  • 7 replies
  • 2186 views
  • 2 kudos
  • 2 in conversation
Announcements

Orbi WiFi 7