Orbi WiFi 7 RBE973
Reply

VPN R7900 Connected to home, but no internet

nodaicrag
Aspirant

VPN R7900 Connected to home, but no internet

hello,

 

I was able to connect to my VPN home router in the USA. I have the R7900 Nighthawk. I followed the instructions from netgear and set up the client on my laptop abroad. I successfully connected to my router, at least by seeing the OpenVPN GUI showing green when I connect to my home router, so I assume that means I am connected via my VPN.

 

After connecting via the VPN, I can't seem to connect to the internet via the VPN on any browser: Chrome, Firefox, Edge and I even tried Internet Explorer 11. I tried a combination of port triggering on 12974 and allowing from 500 to 1294? Just a shot in the dark. I don't know what I'm exactly doing, just trying anything. 

 

I am in Thailand now. I am trying to connect to my home VPN primarily to watch Netflix. Is this possible once I can connect to the internet after connecting the VPN?

 

Thank you.

Model: R7900|Nighthawk X6 AC3000 Tri-Band WiFi Router
Message 1 of 6

Accepted Solutions
nodaicrag
Aspirant

Re: VPN R7900 Connected to home, but no internet

Thank you. I tried uninstalling, reinstalling and making sure all networks selected. I opened status page, if it helps it says something like "us=165694 Recursive routing detected, drop tun packet to [AF_INET]myipaddress:12974

 

Any other ideas? thank you

View solution in original post

Message 4 of 6

All Replies
nodaicrag
Aspirant

Re: VPN R7900 Connected to home, but no internet

Just to add more info to my post. I realized I had just uninstalled ExpressVPN. Would the prior installation of a VPN on my PC be affecting my VPN connection to my home router?

Message 2 of 6
JamesGL
Master

Re: VPN R7900 Connected to home, but no internet

Hi nodaicrag,

Unistall and reinstall the OpenVPN client on your computer. Also during the generating of the certificate make sure you have selected the "All sites on the Internet and Home network".

Message 3 of 6
nodaicrag
Aspirant

Re: VPN R7900 Connected to home, but no internet

Thank you. I tried uninstalling, reinstalling and making sure all networks selected. I opened status page, if it helps it says something like "us=165694 Recursive routing detected, drop tun packet to [AF_INET]myipaddress:12974

 

Any other ideas? thank you

Message 4 of 6
TheEther
Guru

Re: VPN R7900 Connected to home, but no internet

Make sure that the IP subnet where your laptop is connecting from is different than your home network's subnet.  For example, if you home network is 192.168.1.x/255.255.255.0, then your laptop must use something different (e.g. 192.168.2.x/255.255.255.0).  This is clearly mentioned but frequently overlooked in the manual:

 

"For the VPN tunnel to work, the local LAN IP address of the remote R7900 router must use a different LAN IP scheme from that of the local LAN where your VPN client computer is connected. If both networks use the same LAN IP scheme, when the VPN tunnel is established, you cannot access your home router or your home network with the OpenVPN software."

Message 5 of 6
nodaicrag
Aspirant

Re: VPN R7900 Connected to home, but no internet

It worked! Thank you! I changed the LAN IP to 192.168.3.1. I am now able to stream USA Netflix library from Thailand, however slower, but it works!

 

Thanks again!

Message 6 of 6
Top Contributors
Discussion stats
  • 5 replies
  • 13235 views
  • 1 kudo
  • 3 in conversation
Announcements

Orbi WiFi 7