Orbi WiFi 7 RBE973
Reply

X4S R7800 keeps dropping DNS settings

BoulderRob
Follower

X4S R7800 keeps dropping DNS settings

I've had a R7800 for a number of years and it's worked very well until a few months ago.  Now, every few weeks, it seems like my router is dropping the DNS settings.  I am using Cloudflare DNS, and originally thought my ISP was causing the problem.  But I find that if I change the DNS settings to any other DNS it works fine again.  I'm wondering if this is because of a firmware update?  I'm on version V1.0.2.92.   This DNS issue is affecting every device in the home, windows PCs, Macs, iphones, etc. 

 

 

Message 1 of 6
Kitsap
Master

Re: X4S R7800 keeps dropping DNS settings


@BoulderRob wrote:

I've had a R7800 for a number of years and it's worked very well until a few months ago.  Now, every few weeks, it seems like my router is dropping the DNS settings.  I am using Cloudflare DNS, and originally thought my ISP was causing the problem.  But I find that if I change the DNS settings to any other DNS it works fine again.  I'm wondering if this is because of a firmware update?  I'm on version V1.0.2.92.   This DNS issue is affecting every device in the home, windows PCs, Macs, iphones, etc. 

 


Have you enabled IPv6 in advanced settings?

 

Are you using IPv6 addresses for DNS?

 

Are you using both primary and secondary DNS addresses?

 

What are the IPv4 and IPv6 addresses you are using for DNS?

Message 2 of 6
IanDLacy
Initiate

Re: X4S R7800 keeps dropping DNS settings

I just started having this same problem with the same model running the same firmware. No IPv6, and using all three boxes, 1.1.1.1, 1.0.0.1, and third is the secondary IP that we had through DHCP from our ISP. This problem never showed up until I turned on ping and added a port forward the other day, but it didn't start happening until a few days after that, so I'm doubtful it is related (if it is, it shouldn't be).

On day one, rebooting the router seemed to fix it. We were only using the two DNS IPs obtained via DHCP from our ISP. I decided it was a problem with the ISP's DNS servers, and decided it would be a good idea not to completely rely on them. So later that day I added Cloudflare's primary and secondary, and kept the ISP's secondary, but moved it to the third slot, thinking this would solve the problem.

 

On day two, to my surprise, it happened again. This time I didn't reboot the router and instead went back into the panel to make sure everything looked good. I ended up clicking the 'test' button in the Internet settings panel and suddenly everything started working. Later that night I started looking for answers online and found some somewhat similar sounding complaints on a number of different Netgear routers close to ours, but nothing this recent, with this model, with this firmware.

 

On day three (today), not very surprised at this point, I had to do the same 'test' button trick again. This time I decided to customize the DNS settings on our two most important machines to make them immune to this strange problem.

The strangest thing is that it seems to be happening at roughly the same time every day: around 4 PM EDT. At this point I am 99% sure this is going to happen again tomorrow, so I'm going to write a script to periodically check if our DNS is working and log the time, to see if I can pin down the time exactly.

 

I hope some of this information proves to be useful.

Message 3 of 6
Kitsap
Master

Re: X4S R7800 keeps dropping DNS settings

One option that is available for the R7800 is firmware from Voxel.  It is third party firmware that is based on Netgear OEM firmware.  I use it on my R9000.  It is easy to get in or easy to get out if you do not like it.

 

Here is a link to the Voxel home page:  http://www.voxel-firmware.com/Downloads/Voxel/html/index.html 

 

Be sure and review the Readme file in the header.  Remember, if you have any warranty left on your R7800, installing third party firmware will void it.

 

There is an active Voxel forum section over on Small Net Builders.  Here is the link: 

https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-100sf.83319/ 

Message 4 of 6
IanDLacy
Initiate

Re: X4S R7800 keeps dropping DNS settings

Thanks for the advice! I've never heard of Voxel. How does this compare to stuff like DD-WRT, OpenWRT, and Tomato? Is there a reason I should pick Voxel over one of those?

After some more diagnostics, I think I may have narrowed down the problem. I need to let it run through tomorrow to confirm it though, so I will report back if I got it fixed.
Message 5 of 6
Kitsap
Master

Re: X4S R7800 keeps dropping DNS settings


@IanDLacy wrote:
Thanks for the advice! I've never heard of Voxel. How does this compare to stuff like DD-WRT, OpenWRT, and Tomato? Is there a reason I should pick Voxel over one of those?


This forum is not the place to ask those questions.  Go over to the Small Net Builders forum and ask.

Message 6 of 6
Top Contributors
Discussion stats
  • 5 replies
  • 1772 views
  • 5 kudos
  • 3 in conversation
Announcements

Orbi 770 Series