× NETGEAR is aware of a growing number of phone and online scams. To learn how to stay safe click here.
× Introducing the new Orbi 770 Series Mesh System. To learn more click here.
Nighthawk Mesh WiFi

Welcome to the Nighthawk Mesh Community


Advanced Whole Home WiFi Click to Buy Nighthawk Mesh WiFi 6
Reply

Re: 2.4Ghz devices won't connect to MR60/MK62 Mesh Router

rogue6
Tutor

2.4Ghz devices won't connect to MR60/MK62 Mesh Router

I've been having a lot of issues getting any devices that only operate on the 2.4Ghz band to connect to this router.  I have a Roomba model E3 that won't connect.  I have a brand new LG Washer and Dryer that won't connect.  Finally today I bought some Feit Smart Bulbs to use around the house, and they won't connect, either.

 

I did some searching in these forums and came across some advice on how to set up a separate network (SSID) on my router specifically on the 2.4GHz band, but it seems this process is no possible on my model (MK 62/MR60).  This only seems to be possible on the models listed on the page, MK83/MR80/MS80:

 

https://kb.netgear.com/000063027/Can-I-create-separate-2-4GHz-and-5GHz-SSIDs-on-my-Nighthawk-Tri-ban...

 

Is there any way to do something similar for the MK62/MR60 set of mesh routers?  I don't see any setting anywhere in the router settings to specifically set an SSID to only operate on the 2.4GHz band.  The instructions I linked mention going to ADVANCED SETUP>CUSTOMIZE NETWORK, but CUSTOMIZE NETWORK is not available in my router software.  I'm stuck.  I bought this router after reading that it specifically says it's backwards compatible with 2.4GHz devices, but I suspect it keeps defaulting to the 5GHz band during their setup, causing many of them to fail.  I need a workaround.  Can anyone give me some help on this?

 

Thanks in advance.

Message 1 of 9
plemans
Guru

Re: 2.4Ghz devices won't connect to MR60/MK62 Mesh Router

what modem/gateway do you have? 

I've had a couple devices that wouldn't connect to my mesh network but its gotten a lot better. 

When its only a couple devices, then I think its the 2.4ghz issue. When its quite a few, I get a bit more suspicious. 

Message 2 of 9
rogue6
Tutor

Re: 2.4Ghz devices won't connect to MR60/MK62 Mesh Router

I have a brand new Motorola MB7621. I bought it at the same time as the router.

The problem is definitely on the router side. When I try to connect a few of the smarter devices that fail (Roomba, Anova cooker, the bulbs) they all give a message reminding me that the device only works on a 2.4Ghz network. The roomba in particular call it out in such a way that it makes it pretty obvious that it can't connect to a 2.4Ghz band, because the router is defaulting to 5Ghz.

I just want a way to set up a specific SSID that only operates on the 2.4Ghz band like they suggest in the link I posted. But their walk through doesn't match the settings on this router, and I can't find ANY way to specify which band it works on.
Message 3 of 9
plemans
Guru

Re: 2.4Ghz devices won't connect to MR60/MK62 Mesh Router

there isn't a way to seperate out the bands. The devices are designed to be mesh systems and non-seperable. 

I know the orbi has an option where you can disable the 5ghz broadcast. Then sometimes if you disconnect your phone from the wifi and reconnect, it'll connect to the 2.4ghz. Not always but its a chance. Not sure if the MR60 system has this as I don't have one try with. 

 

Message 4 of 9
rogue6
Tutor

Re: 2.4Ghz devices won't connect to MR60/MK62 Mesh Router

Do you happen to know if there's a name or term for that feature to disable to 5Ghz band on the Orbi? That's essentially what I'm looking for, I just can't find it in the menus on the MK62/MR60. I figured I'd set up the guest network as a 2.4Ghz-only network, but don't see any options for the frequency.
Message 5 of 9
plemans
Guru

Re: 2.4Ghz devices won't connect to MR60/MK62 Mesh Router

Advanced ----> Advanced Setup ---> Wireless Setting--->Disable/Enable Broadcast SSID setting

Message 6 of 9
rogue6
Tutor

Re: 2.4Ghz devices won't connect to MR60/MK62 Mesh Router

Ok, I just tried that two ways and neither worked.  I first did it as you said in the Advanced Settings menu, which made my standard network disappear from visibility (as I understand it's supposed to with SSID turned off).  My guest network was still visible so I used that, but the deivce still can't connect to it.  

 

I then tried the reverse, disabling SSID on the Guest network and turning it back on for the main network.  Same issue, the 2.4GHz-only devices won't connect.  

 

Advacnced settings - SSID.JPGGuest Network - SSID.JPG

 

 

I think you're trying to do something like what's suggested in this forum thread:

 

https://kb.netgear.com/30688/How-to-hide-or-unhide-SSID-on-your-NETGEAR-Range-Extender

 

but in that software there's an explicity setting for each of the frequencies, 2.4 and 5.  Mine doesn't give anything like that.

 

Are there any workarounds by locking the Guest 5GHz network to a single channel or something?  

Message 7 of 9
plemans
Guru

Re: 2.4Ghz devices won't connect to MR60/MK62 Mesh Router

when mesh first came out this was a bit of an issue. I haven't had any issues with it in the last several years. 

What I used to do was this. (there was 2 routes I used. 

route 1: I'd turn off my router and setup a hotspot on my phone using the same ssid/password as my router on the 2.4ghz. Then I'd get my device setup, turn off the hotspot and turn the router back on. Devices auto connected

Route 2. I used an old 2.4ghz router for setup. I'd turn off the mesh router, turn on the old 2.4ghz only router, and then set up my devices with the same ssid as the mesh ssid/password. Then turn off the old router and turn the mesh back on. 

 

Again, I haven't had to use this method on a long time. I haven't even needed to use the disable ssid broadcast for 5ghz option that others have used. Devices have just connected. 

Message 8 of 9
rogue6
Tutor

Re: 2.4Ghz devices won't connect to MR60/MK62 Mesh Router

Now that's some clever thinking! I'll give that a try next.
Message 9 of 9
Discussion stats
  • 8 replies
  • 2478 views
  • 1 kudo
  • 2 in conversation
Announcements

Orbi 770 Series