×

Introducing the Orbi 970 Series Mesh System with WiFi 7(BE) technology. For more information visit the NETGEAR Press Room.

Nighthawk Mesh WiFi

Welcome to the Nighthawk Mesh Community


Advanced Whole Home WiFi Click to Buy Nighthawk Mesh WiFi 6
Reply

Re: Chromecast and Mesh Routing issues

GhettoSmurf373
Initiate

Chromecast and Mesh Routing issues

If anyone is like me and recently upgraded to the Netgear Nighhawk Whole Home Mesh WiFi 6 (AX1800), you have probably discovered issues with Chromecast. I searched and searched the web and could not find any information other than "AP Isolation issues" and "reset chromecast" over and over. 

We found that if the Chromecast is connected to the 'main' router, you can be connected to any satellite and cast to your device. However, if your Chromecast is powered down, and or network resets for any reason, you will be placed to the nearest device. In my case, that was the satellite. We believe the Chromecast locks to the MAC address and cannot associate back to the main router. So once a power cycle happens, even if your phone and Chromecast are connected to same satellite, you will not be able to cast.

 

The solution (for me and my AX1800, I hope it works for you)
1. Go to your routers home page (typically 192.168.1.1)

2. Select Advanced Settings

3.Select Setup tab

4. Select LAN Setup

5. Scroll down to the "RIP Direction" section

6. Ensure "Both" is selected for "RIP Direction"

7. Select RIP_1 for "RIP Version"

 

After selecting this, it didn't matter which satellite my Chromecast or my phone was connected to, I was able to cast. Hope this helps someone!

Message 1 of 37
Christian_R
NETGEAR Employee Retired

Re: Chromecast and Mesh Routing issues

Hi GhettoSmurf373,

 

Thanks for sharing your experience as it may help others! 

 

Christian 

Message 2 of 37
FDohadwala
Initiate

Re: Chromecast and Mesh Routing issues

This worked, thanks for sharing. This information is not available on Negear workarounds. I hope Netgear adds this for public benefit. It was a pain getting chromecast to work, we were about to return the router until we saw this article. Hope Netgear is listening.


@GhettoSmurf373 wrote:

If anyone is like me and recently upgraded to the Netgear Nighhawk Whole Home Mesh WiFi 6 (AX1800), you have probably discovered issues with Chromecast. I searched and searched the web and could not find any information other than "AP Isolation issues" and "reset chromecast" over and over. 

We found that if the Chromecast is connected to the 'main' router, you can be connected to any satellite and cast to your device. However, if your Chromecast is powered down, and or network resets for any reason, you will be placed to the nearest device. In my case, that was the satellite. We believe the Chromecast locks to the MAC address and cannot associate back to the main router. So once a power cycle happens, even if your phone and Chromecast are connected to same satellite, you will not be able to cast.

 

The solution (for me and my AX1800, I hope it works for you)
1. Go to your routers home page (typically 192.168.1.1)

2. Select Advanced Settings

3.Select Setup tab

4. Select LAN Setup

5. Scroll down to the "RIP Direction" section

6. Ensure "Both" is selected for "RIP Direction"

7. Select RIP_1 for "RIP Version"

 

After selecting this, it didn't matter which satellite my Chromecast or my phone was connected to, I was able to cast. Hope this helps someone!


 

Model: AC2400|Nighthawk AC2400 Smart WiFi Router
Message 3 of 37
SteveS27
Aspirant

Re: Chromecast and Mesh Routing issues

This didnt work for me. Have Chromecast with Google TV & Noghthawm Mesh Mk63 AX1800

Message 4 of 37
falcon9202
Aspirant

Re: Chromecast and Mesh Routing issues

Seems to have worked with me! Was getting very frustrated because the UPnP and AP isolation suggestions from google weren't working for me. THANK YOU!

Message 5 of 37
theturtleguy
Initiate

Re: Chromecast and Mesh Routing issues

I wish I can tip the OP. This fixed all my problems!!!!!

Message 6 of 37
shaun_s
Star

Re: Chromecast and Mesh Routing issues

I have the same problem but the solution didn't work for me unfortunately. I have the MK63 (MR60 router and two MS60 satellites) on the latest firmware V1.0.6.102.

 

I've done some extensive testing and I'm quite sure the problem only happens when both the media device (Chromecast) and phone are connected to the SAME satellite AND on the SAME wifi band.

Message 7 of 37
pieters
Aspirant

Re: Chromecast and Mesh Routing issues

I experience the same issue, but I run in access point mode. So the "LAN Setup" menu item is greyed-out (which is logical...). I found a a work around where I need to enable the guest wifi, but I do not need the guest wifi. 

Does any have an solution for this?

 

Message 8 of 37
SteveVT
Aspirant

Re: Chromecast and Mesh Routing issues

I have the MR60 mesh router with one satellite.  This solution did not work for me, either.  When the Chromecast on the MR60, it works.  When it is on the satellite, it does not work.

Message 9 of 37
Fastace911
Aspirant

Re: Chromecast and Mesh Routing issues

This worked and thank you much! Always appreciate people taking the time to post solutions.
Message 10 of 37
Moose1
Aspirant

Re: Chromecast and Mesh Routing issues

Thank you so much for sharing. Fixed the issue!!!
Message 11 of 37
JECaine
Tutor

Re: Chromecast and Mesh Routing issues

Thank you! This worked perfectly. I would not have thought to change the RIP protocol.
Message 12 of 37
JECaine
Tutor

Re: Chromecast and Mesh Routing issues

Additional question: so the solution below worked for me temporarily.  I believe it worked temporarily because it involved me restarting my router, but when I looked further I realized the issue I was having was larger than just not being able to connect to the chromecast or cast to the google display.  Since getting the mesh network I am unable to connect to my Google Display from my android phone at all. If I logoff/on to the wifi I will be able to connect to my google devices temporarily, but it eventually times out and I lose connection and I can't reconnect unless I repeat the process.  
Does anyone have any insight 
Thanks
JECaine

@GhettoSmurf373 wrote:

If anyone is like me and recently upgraded to the Netgear Nighhawk Whole Home Mesh WiFi 6 (AX1800), you have probably discovered issues with Chromecast. I searched and searched the web and could not find any information other than "AP Isolation issues" and "reset chromecast" over and over. 

We found that if the Chromecast is connected to the 'main' router, you can be connected to any satellite and cast to your device. However, if your Chromecast is powered down, and or network resets for any reason, you will be placed to the nearest device. In my case, that was the satellite. We believe the Chromecast locks to the MAC address and cannot associate back to the main router. So once a power cycle happens, even if your phone and Chromecast are connected to same satellite, you will not be able to cast.

 

The solution (for me and my AX1800, I hope it works for you)
1. Go to your routers home page (typically 192.168.1.1)

2. Select Advanced Settings

3.Select Setup tab

4. Select LAN Setup

5. Scroll down to the "RIP Direction" section

6. Ensure "Both" is selected for "RIP Direction"

7. Select RIP_1 for "RIP Version"

 

After selecting this, it didn't matter which satellite my Chromecast or my phone was connected to, I was able to cast. Hope this helps someone!


 

Message 13 of 37
Rivinence
Tutor

Re: Chromecast and Mesh Routing issues

I have the Nighthawk MR62 Bundle (1 MR60 router, 1 MS60 satellite) running firmware V1.0.6.102_2.0.45. I, like everyone else was having issues with my Google casting devices. What ended up working for me was to uncheck "Disable IGMP Proxying". Ever since I did that everything has been running smoothly. I hope this will help someone out there.
Message 14 of 37
JECaine
Tutor

Re: Chromecast and Mesh Routing issues

Thank you Rivinence,
I unchecked that setting and I will check it in the morning. I will let you know how it goes.
JC
Message 15 of 37
JECaine
Tutor

Re: Chromecast and Mesh Routing issues

Thanks again Rivinence, unfortunately this solution didn't fix the problem I'm having. I'm just going to buy myself some MoCA adapters and go wired. Hopefully that fixes the problem
Message 16 of 37
ndatimba
Aspirant

Re: Chromecast and Mesh Routing issues

Thank you so much! Didn't only solve my issue with Chromcast, but also my connectivities issues with my Sonos devices. You made my entire family happy 🙂 🙂 🙂

Thank you, thank you, from Montreal, Canada.

 

 

Message 17 of 37
tingest
Aspirant

Re: Chromecast and Mesh Routing issues

I cannot begin to thank you for this!!! We kept wondering what went wrong and finally we have found out. You are more helpful than the technical service team for my internet service haha
Message 18 of 37
conten37
Aspirant

Re: Chromecast and Mesh Routing issues

I can't start to thank you for this!!! We saved wondering what went wrong and sooner or later we've got located outhere. You are greater useful than the technical carrier team for my internet service haha

Message 19 of 37
TxTalley
Aspirant

Re: Chromecast and Mesh Routing issues

Also had to factory reset my Chromecast to finalize the resolution.  So if it's still failing after your change on the router, factory reset the Chromecast itslef.  

 

Thanks for the post and answer!

Message 20 of 37
shaun_s
Star

Re: Chromecast and Mesh Routing issues

I have the MK63 (MR60 router and two MS60 satellites).

 

I've tried all the suggested solutions but none worked.  (It may seem to work for a while but after the devices connect back to their respective satellite, the problem returns.)

 

I've waited over 8 months for a firmware fix but none of the updates fixed the problem.  It's been a waste of time.

 

Get a refund if you can.  Unfortunately, I'm stuck with mine.  Very disappointed.

Message 21 of 37
FURRYe38
Guru

Re: Chromecast and Mesh Routing issues

Instead of waiting for a fix, did you open a support ticket to let NG know about the problem your seeing? 

Highly recommended to contact NG support and let them know about this. Reference this forum thread as well. 

@DarrenM 


@shaun_s wrote:

I have the MK63 (MR60 router and two MS60 satellites).

 

I've tried all the suggested solutions but none worked.  (It may seem to work for a while but after the devices connect back to their respective satellite, the problem returns.)

 

I've waited over 8 months for a firmware fix but none of the updates fixed the problem.  It's been a waste of time.

 

Get a refund if you can.  Unfortunately, I'm stuck with mine.  Very disappointed.


 

Message 22 of 37
shaun_s
Star

Re: Chromecast and Mesh Routing issues

Someone on this thread already opened a support ticket:

https://community.netgear.com/t5/Nighthawk-Mesh-System/Devices-on-mk62-mr60-and-ms60-become-invisibl...

 

Nothing happened and the case was closed.

 

I also described in detail of the problem in this post:

 

https://community.netgear.com/t5/Nighthawk-Mesh-System/Devices-on-mk62-mr60-and-ms60-become-invisibl...

 


@FURRYe38 wrote:

Instead of waiting for a fix, did you open a support ticket to let NG know about the problem your seeing? 

Highly recommended to contact NG support and let them know about this. Reference this forum thread as well. 

@DarrenM 


@shaun_s wrote:

I have the MK63 (MR60 router and two MS60 satellites).

 

I've tried all the suggested solutions but none worked.  (It may seem to work for a while but after the devices connect back to their respective satellite, the problem returns.)

 

I've waited over 8 months for a firmware fix but none of the updates fixed the problem.  It's been a waste of time.

 

Get a refund if you can.  Unfortunately, I'm stuck with mine.  Very disappointed.


 


 

Message 23 of 37
FURRYe38
Guru

Re: Chromecast and Mesh Routing issues

Please open up another support ticket then. 


@shaun_s wrote:

Someone on this thread already opened a support ticket:

https://community.netgear.com/t5/Nighthawk-Mesh-System/Devices-on-mk62-mr60-and-ms60-become-invisibl...

 

Nothing happened and the case was closed.

 

I also described in detail of the problem in this post:

 

https://community.netgear.com/t5/Nighthawk-Mesh-System/Devices-on-mk62-mr60-and-ms60-become-invisibl...

 


@FURRYe38 wrote:

Instead of waiting for a fix, did you open a support ticket to let NG know about the problem your seeing? 

Highly recommended to contact NG support and let them know about this. Reference this forum thread as well. 

@DarrenM 


@shaun_s wrote:

I have the MK63 (MR60 router and two MS60 satellites).

 

I've tried all the suggested solutions but none worked.  (It may seem to work for a while but after the devices connect back to their respective satellite, the problem returns.)

 

I've waited over 8 months for a firmware fix but none of the updates fixed the problem.  It's been a waste of time.

 

Get a refund if you can.  Unfortunately, I'm stuck with mine.  Very disappointed.


 


 


 

Message 24 of 37
shaun_s
Star

Re: Chromecast and Mesh Routing issues

When I clicked on Contact Support (https://www.netgear.com/support/contact.aspx), it took me to "Page Unavailable".

 

Anyway, all my support entitlements have expired.

 


@FURRYe38 wrote:

Please open up another support ticket then. 


@shaun_s wrote:

Someone on this thread already opened a support ticket:

https://community.netgear.com/t5/Nighthawk-Mesh-System/Devices-on-mk62-mr60-and-ms60-become-invisibl...

 

Nothing happened and the case was closed.

 

I also described in detail of the problem in this post:

 

https://community.netgear.com/t5/Nighthawk-Mesh-System/Devices-on-mk62-mr60-and-ms60-become-invisibl...

 


@FURRYe38 wrote:

Instead of waiting for a fix, did you open a support ticket to let NG know about the problem your seeing? 

Highly recommended to contact NG support and let them know about this. Reference this forum thread as well. 

@DarrenM 


@shaun_s wrote:

I have the MK63 (MR60 router and two MS60 satellites).

 

I've tried all the suggested solutions but none worked.  (It may seem to work for a while but after the devices connect back to their respective satellite, the problem returns.)

 

I've waited over 8 months for a firmware fix but none of the updates fixed the problem.  It's been a waste of time.

 

Get a refund if you can.  Unfortunately, I'm stuck with mine.  Very disappointed.


 


 


 


 

Message 25 of 37
Discussion stats
Announcements

Orbi WiFi 7