Reply

Re: 5g wifi keeps disconnecting AC1900

Jesus-
Tutor

5g wifi keeps disconnecting AC1900

I've had my r7000 router for about 3 years. Have never had issues with it until 5 days ago. Woke up to the internet completely down, the internet light was orange. Tried rebooting router and spectrum modem multiple times but wifi was still down. I did a factory reset and it helped fix the issue for a few hours. Then the 5g wifi started disconnecting on all my 12 devices(9 iPhones, 1 android oneplus 6,2 Amazon fire sticks) , my devices would say "connected, no internet" the connection would come back after a few minutes or after a reboot. I bought a R6900p to see if that'd fix it. But it didn't, I'm still having the same issue. I've tried out most/all of the different channels, tried factory reset a couple times, turned off dos protection. Nothing fixed it. The 5g wifi is still dropping off multiple times a day. Sometimes it happens every 30 minutes, other times it happens after 5-6 hours. I'm on version V1.3.1.64_10.1.36
Model: A7000|Nighthawk AC1900 WiFi USB Adapter - USB 3.0, R6900P|Nighthawk AC1900 Smart WiFi Dual Band Gigabit Router
Message 1 of 47
plemans
Guru

Re: 5g wifi keeps disconnecting AC1900

From the firmware version you posted, you've got the R7000P. 

What modem are you using? 

Is it only the 5ghz? all your devices that are hardwired and on 2.4ghz stay connected?

It seems a little suspicious when the same problem is happening to 2 different routers. It tends to point at a different cause when thatt happens. 

Current setup: CAX80->Trendnet TEG-S380->GS716T-> RBK752->pi-hole
1.4gig download/50mbps upload
We’re members of the public helping out on our own time.
Message 2 of 47
Jesus-
Tutor

Re: 5g wifi keeps disconnecting AC1900

The modem is Hitron E31N2V1

My old router is a R7000 and the new is a R6900P. Yes it is only the 5ghz connection that has issues. All devices on the 2.4ghz and hardwired stay online with no connection issues. Thank you for any help!
Message 3 of 47
plemans
Guru

Re: 5g wifi keeps disconnecting AC1900

It just seems odd that 2 different routers are having the exact same problem.

Is it isolated to a single device or which ones are having issues?

What region are you in? Some regions are more strict with their indoor/dfs channels. 

Current setup: CAX80->Trendnet TEG-S380->GS716T-> RBK752->pi-hole
1.4gig download/50mbps upload
We’re members of the public helping out on our own time.
Message 4 of 47
Jesus-
Tutor

Re: 5g wifi keeps disconnecting AC1900

I'm in the US,and yes all devices connected to 5g will have the same issue. 9 iPhones, 1 android, 2 Amazon firesticks, 1 laptop
Message 5 of 47
plemans
Guru

Re: 5g wifi keeps disconnecting AC1900

Are they disconnecting or saying "internet not available" but still having an wifi connection

Current setup: CAX80->Trendnet TEG-S380->GS716T-> RBK752->pi-hole
1.4gig download/50mbps upload
We’re members of the public helping out on our own time.
Message 6 of 47
Jesus-
Tutor

Re: 5g wifi keeps disconnecting AC1900

They stay connected and say "internet not available "
Message 7 of 47
plemans
Guru

Re: 5g wifi keeps disconnecting AC1900

so the 5g itself isn't disconnecting. 

If you disconnect, reconnect to the router (not reboot the router) with your device, does it fix the issue?

Do they all loose the connection at the same time when it drops? 

Current setup: CAX80->Trendnet TEG-S380->GS716T-> RBK752->pi-hole
1.4gig download/50mbps upload
We’re members of the public helping out on our own time.
Message 8 of 47
Jesus-
Tutor

Re: 5g wifi keeps disconnecting AC1900

If I disconnect on my devices and reconnect it doesn't fix it. I'll have to wait a few minutes for the connection to start working again. Sometimes it doesn't work at all if I wait so I'll have to reboot the router to fix it
Message 9 of 47
plemans
Guru

Re: 5g wifi keeps disconnecting AC1900

Again, the issue seems strange because you have 2 routers with the exact same issue. It really makes me wonder if its a modem issue thats happening to the 5ghz for some reason. 

Do you have a backup modem you could try? 

Current setup: CAX80->Trendnet TEG-S380->GS716T-> RBK752->pi-hole
1.4gig download/50mbps upload
We’re members of the public helping out on our own time.
Message 10 of 47
Jesus-
Tutor

Re: 5g wifi keeps disconnecting AC1900

I am also thinking it's the modem. It's owned by spectrum so I'm planning to go tomorrow and switch it out for a new one. I don't have time today. I'll let you know how it goes. Thanks again for the help
Message 11 of 47
Maih2403
Aspirant

Re: 5g wifi keeps disconnecting AC1900

I am having the same problem. My 5g keeps dropping everyday (sometimes multiple times per day). I’ve reset the modem and router, which fixes the issue for awhile at least, but this isn’t a long term fix. I have a spectrum modem as well, please let us know if the modem change fixes this issue. Otherwise it may be a firmware issue with the router, which may require buying a new router 😞
Model: A7000|Nighthawk AC1900 WiFi USB Adapter - USB 3.0
Message 12 of 47
Jesus-
Tutor

Re: 5g wifi keeps disconnecting AC1900

I went to spectrum and exchanged the modem for a new one, but it's the same model. I am still having the exact same problem. 😕 I am gonna try getting a different brand router now. Don't know what else to do
Message 13 of 47

Re: 5g wifi keeps disconnecting AC1900

I have that exact adapter and no 5ghz problems with network. I multiple TVs, phones, tablets and computers also have a printer. The only difference is the router mine's a r7450. I also have spectrum internet so if I were you I would go out and buy the r7450 asap.
Network products owned WNDR3300 WN3000RPV3 R7450 Dell R610 server A7000
Message 14 of 47
Trottirj
Star

Re: 5g wifi keeps disconnecting AC1900

I have the same issue. 2.4g is always okay. 5g keeps dropping out. 

I tried different channels but still the same problem. 

Coincidentally I just added a google nest mini to my older google home and google mini.

HELP

 

Any solutions...

Model: A7000|Nighthawk AC1900 WiFi USB Adapter - USB 3.0
Message 15 of 47
plemans
Guru

Re: 5g wifi keeps disconnecting AC1900


@Trottirj wrote:

I have the same issue. 2.4g is always okay. 5g keeps dropping out. 

I tried different channels but still the same problem. 

Coincidentally I just added a google nest mini to my older google home and google mini.

HELP

 

Any solutions...


@Trottirj Try starting your own thread. different devices cause different issues. You might have the same kind of router but different modem/home/devices/etc.  Your own thread allows clearer instructions because we're not trying to seperate out the original posters issues/devices from yours. 

Thanks. 

Current setup: CAX80->Trendnet TEG-S380->GS716T-> RBK752->pi-hole
1.4gig download/50mbps upload
We’re members of the public helping out on our own time.
Message 16 of 47
Trottirj
Star

Re: 5g wifi keeps disconnecting AC1900

I thought this thread was for the AC1900, R7000 and 5g issues?

Message 17 of 47
plemans
Guru

Re: 5g wifi keeps disconnecting AC1900


@Trottirj wrote:

I thought this thread was for the AC1900, R7000 and 5g issues?


It is but everyones situation is unique and it might be something else causing the issue. 

If you've tried the standard fixes found in the forums for the R7000 and it doesn't work, then start your own thread. 

Current setup: CAX80->Trendnet TEG-S380->GS716T-> RBK752->pi-hole
1.4gig download/50mbps upload
We’re members of the public helping out on our own time.
Message 18 of 47
angelglo
Aspirant

Re: 5g wifi keeps disconnecting AC1900

Was this issue ever resolved?  I have been having the same issues lately.  My 5g has been dropping.  I look at my router and the 5g light is off.  Then it goes to orange and stays there.  It is very irritating.  I have been using netgear for quite some time but it might be time to switch.  

Message 19 of 47
MarkCartagena
Initiate

Re: 5g wifi keeps disconnecting AC1900p

I have the same exact problem, at both my dealerships (we use the R7000P) at both dealerships. We'll be fine for a while then it seems as though when a new user connects to the 5G band, all connections to it have "Internet Not Available" 

Model: R7000P|Nighthawk AC2300 Smart WiFi Dual Band Gigabit Router
Message 20 of 47
ebaltazar
Star

Re: 5g wifi keeps disconnecting AC1900p

I have noticed this same issue with my router. It may have been happening for a very long time, but I have only been able to notice it since having to work from home. Usually several times a day, my 5Ghz band loses internet connection. 2.4Ghz is rock solid. I feel that it may be firmware. My router is just over a year old. I am confident that its replacement will not be a Netgear.

Model: R7450|Nighthawk AC2600 Smart WiFi Router
Message 21 of 47
eromanos
Aspirant

Re: 5g wifi keeps disconnecting AC1900p

I also am having the exact same issue, 5g gives me good speeds but constant drop outs. Whereas 2g gives poor speeds but no drop outs.

Has anyone solved the problem?
Model: R7000P|Nighthawk AC2300 Smart WiFi Dual Band Gigabit Router
Message 22 of 47
ebaltazar
Star

Re: 5g wifi keeps disconnecting AC1900p

For me, the fix was installing an older firmware. The recent firmware was causing my dropouts.
Model: R7450|Nighthawk AC2600 Smart WiFi Router
Message 23 of 47
jcortez444
Aspirant

Re: 5g wifi keeps disconnecting AC1900

Hello,

 

 Did the new router work? I am having the same issue. My router is a Motorola SURFboard SB6141.

Message 24 of 47
Space_Nerd
Initiate

Re: 5g wifi keeps disconnecting AC1900p

Which firmware version fixed the issue? Also, anyone having this issue with AT&T fiber modem? I’m switching from Spectrum to AT&T and am curious if I’ll still have the issue. Thanks.
Model: A7000|Nighthawk AC1900 WiFi USB Adapter - USB 3.0
Message 25 of 47
Top Contributors
Discussion stats
Announcements

Orbi WiFi 6E