Reply

AC1900 WiFi - From Great to Terrible WiFi

MovieFlask
Novice

AC1900 WiFi - From Great to Terrible WiFi

I've had an AC1900 Nighthawk since the holidays and connected it up to my XFinity cable modem in January. Everything went smoothly and I was seeing WiFi around the house at about 50-70mbps down and 10-15 up. Then, about a week ago, the WiFi just started performing terribly. The connected computer to the router is still getting 125mbps down or so, but devices connected through WiFi are seeing connections starting at 10mbps, and dipping to 2mbps or disconnecting.

If I run a speedtest, it will start around 10-12mbps and just dip and dip and dip. Was there a firmware update recently?

I have no introduced any new wireless devices into the house recently. It seems like the signal output just took a nose-dive. I can't even connect with video game consoles at regular intervals.
Message 1 of 6
netwrks
Master

Re: AC1900 WiFi - From Great to Terrible WiFi

On 2.4 and 5ghz?
Message 2 of 6
MovieFlask
Novice

Re: AC1900 WiFi - From Great to Terrible WiFi

2.4. So during lunch I went into the router settings and I chose to "Test Connection". The connection seems way better now. I'm not sure if it is fixed 100% and I've rebooted the router (and modem) numerous times.

I'm not sure why/how this simple thing fixed it. It went through the "Test Connection" for about 60 seconds and now the speed tests are stabilized and everything is connecting fine.

So maybe it's fixed...
Message 3 of 6
netwrks
Master

Re: AC1900 WiFi - From Great to Terrible WiFi

I'm not sure how you have your 2.4ghz configured, but, ensure WMM is enabled, QoS disabled, and give the 2.4ghz a channel (whatever channel works best for your environment). I leave the mode settings at max setting for 2.4 and 5ghz. I've had no issues with iOS or Intel devices. WMM setting enabled on the Intel WIFI Client, also. Running a mix of .n and .ac.
Message 4 of 6
MovieFlask
Novice

Re: AC1900 WiFi - From Great to Terrible WiFi

Thanks for the advice.
Message 5 of 6
Retired_Member
Not applicable

Re: AC1900 WiFi - From Great to Terrible WiFi

Surprised it took 3 months to slow down. I've gotten in the habit of rebooting once or twice a month.
Message 6 of 6
Top Contributors
Discussion stats
  • 5 replies
  • 5773 views
  • 0 kudos
  • 3 in conversation
Announcements