Reply

Re: Attached Devices showing devices that are NOT attached

dtm1968
Aspirant

Attached Devices showing devices that are NOT attached

Hello, I have Nighthawk R7960P router that is not removing devices when they are NOT attached to the router.  There are 4 devices that belonged to my son, who has left the house that still remain in Attached Devices.  I have tried blocking the devices, restating the IP range (the router gives out the IP addresses) and have rebooted the router. (which resets the router to factory settings - another issue).

Is this a bug or is there a way to fix this?

 

thanks

 

Message 1 of 3

Accepted Solutions
dtm1968
Aspirant

Re: Attached Devices showing devices that are NOT attached

Problem solved by restoring factory defaults.  Under Advance --> Administration --> Backup Settings --> Revert to factory default settings.

Only caveat is that all of your pre-configured settings, (port forwarding, Access Control, etc) will be reset and you need to start from scratch.

View solution in original post

Message 2 of 3

All Replies
dtm1968
Aspirant

Re: Attached Devices showing devices that are NOT attached

Problem solved by restoring factory defaults.  Under Advance --> Administration --> Backup Settings --> Revert to factory default settings.

Only caveat is that all of your pre-configured settings, (port forwarding, Access Control, etc) will be reset and you need to start from scratch.

View solution in original post

Message 2 of 3
CalCal23
Apprentice

Re: Attached Devices showing devices that are NOT attached

@dtm1968 

 

If you don't want to factory reset your router, but you still want a solution try this...

 

Full Procedure for Fixing the Attached Devices List on R8000P.

 

If you are like me and you hate how inaccurate the Attached Devices List is on these routers then this is for you.  This procedure will allow you to get an accurate Attached Devices List.  You won't see inaccurate IP addresses or duplicate IP addresses if you follow these step by step instructions....

 

 

  1. Make sure you are hardwired into the R8000P Router via ethernet
  2. Login to your router and go to attached devices
  3. Locate a device that is no longer on your network, or that has the incorrect IP address or that has a duplicate IP address
  4. turn on Access Control
  5. block all of the incorrect devices in Access Control
  6. Make sure that you do NOT block the IP address of the computer that you are using to interface with the router
  7. At the bottom of the Access Control webpage there's an arrow that says Blocked Devices Not on My Network and expand that arrow
  8. Copy and paste the MAC address of each device that is wrong, based on your observations of the Attached Devices List.  You have to do this one at a time.  Each time you do it, it will say, Duplicate MAC Address and ask you to wait about 10 seconds to return you to the previous page
  9. Now all of your blocked devices should show up under the arrow, Blocked Devices Not on My Network.  If they don't do a soft reset of your router (via Advanced Tab -->  Reboot Device) and then navigate back to that area of the router control settings.
  10. Next, select all of the undesirable devices in the Blocked Devices Not on My Network and select delete
  11. You can then turn off Access Control
  12. Navigate back towards the Attached Devices section of your router and notice that some things may have changed.  However you are stil probably showing the incorrect IP addresses for the devices that should be connected to your network.  Some of the old devices that are no longer on your network may be gone.
  13. This is not the end however, you need to do another couple of soft restarts of your router to get the Attached Devices List correctly populated.
  14. After 2x soft restarts of your router, your Attached Devices Tab should be correctly populated.

I hope this detailed and consolidated procedure works for you as it did for me.  It took me about 3-4 hours of trial and error to get this to work correctly.  Please let me know if I should make any tweaks to this procedure to get it more accurate for you.  I know there's a lot of steps and it sucks somewhat...but there is a solution.

Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 2088 views
  • 1 kudo
  • 2 in conversation
Announcements

Orbi WiFi 6E