Reply

Bug Report, R8000, V1.0.4.46 UPNP does not work and other odd issues

AtomicMre
Guide

Bug Report, R8000, V1.0.4.46 UPNP does not work and other odd issues

Main issue:  After upgrading my R8000 to 1.0.4.46, none of my devices or games (Destiny 2, Steam in general) are able to configure UPNP anymore.  I mainly use UPNP to play Destiny 2 with my friends at my house and due to the peer-to-peer nature of that game it is a requirement if multiple clients are on the same network.  I even attemped a factory reset after upgrading to 1.0.4.46 and it was still broken.  The only solution that worked was downgrading back to 1.0.4.28.

 

From Bungie's support page:
"UPnP is REQUIRED if players plan to use more than one console to play Destiny on the same network simultaneously."
https://www.bungie.net/en/Help/Troubleshoot?oid=13610

 

 

Secondary issue:  Enabling IPv6 on my R8000 causes my router to stop responding completely after a week to 10 days of uptime.  My ISP is Comcast and we are on their internet tier that allows for 150Mb down/ 6Mb up in case that information is relevant.  When the router begins to lock up, clients that are already on the network only start losing connection slowly (they have full internet speed at least until the internet stops working completely) which makes me wonder if it is DNS related.  (side note: I've been having this issue for more than a year now so 1.0.4.46 was not the firmware that caused it)

 

 

Minor issue:  I have a Toshiba Canvio 1.0 TB USB 3.0 attached to my R8000 for network storage.  Anytime the router restarts, it does not recognize the drive until I unplug and replug it in.  This is a minor but aggravating annoyance.  

Model: R8000|Nighthawk X6 AC3200 Smart WIFI Router
Message 1 of 12
blipblorp
Aspirant

Re: Bug Report, R8000, V1.0.4.46 UPNP does not work and other odd issues

Same problem here with the R8000.  1.0.4.46 killed UPNP for me.

 

Plex and Tablo and countless other apps on my network now report that they're no longer able to open any ports.

Model: R8000|Nighthawk X6 AC3200 Smart WIFI Router
Message 2 of 12
myersw
Master

Re: Bug Report, R8000, V1.0.4.46 UPNP does not work and other odd issues

Not sure about UPNP, but following were removed in this firmware. This is from release notes. 

Removes the following features: iTunes Server, Downloader, Time Machine, Kwilt, DLNA and TiVo

 

Isn't that wonderful for those that bought the router for one or more of those features. BUT you now have Armor available, which you get to pay money for. Isn't Netgear wonderful? 

--Bill
ISP Comcast, Modem-Netgear CM1150V, Router-Unifi Security Gateway-Pro4, AP-2 Unifi AP-LR
Tesla > Edison
Message 3 of 12
IrvSp
Master

Re: Bug Report, R8000, V1.0.4.46 UPNP does not work and other odd issues

@myersw, given that NG folks here were unaware that DLNA was removed from the R7000, and only once reports came in that DLNA didn't work did they discovered DLNA was removed as well. Now that they didn't know was 'startling' to me. How could they not know what the "spec's" were for the addition of Armour and what was to be taken out? I would almost bet that it wasn't clear to whomever authorized the removal of features probably was unaware that DLNA was intertwined in some part of the code to be removed. If it was done 'accidently' then they would have fixed that as soon as possible rather than declaring it too was removed.

 

Now on the R8000 UPnP reports coming in? Wonder if it works on an R7000?

Message 4 of 12
blipblorp
Aspirant

Re: Bug Report, R8000, V1.0.4.46 UPNP does not work and other odd issues

The attached screenshot shows Plex desparately trying (and failing) to use upnp to open a usable port.

This used to work without a problem.  Now those "open" ports just aren't opening.

Here's the thing - I haven't upgraded my Plex in months, but I updated my R8000 firmware last week.  The problem here seems to be Netgear's firmware.

 

I should also mention that I did try reflashing the firmware and restoring factory defaults to see if that would fix things.  It did, for a few hours.  But now I'm back to upnp not working again.

Model: R8000|Nighthawk X6 AC3200 Smart WIFI Router
Message 5 of 12
Retired_Member
Not applicable

Re: Bug Report, R8000, V1.0.4.46 UPNP does not work and other odd issues

Just spent over 5-hours troubleshooting my network yesterday, only to find that once again, I have another Netgear Router hosed by the latest firmware update. This will be my 3rd Netgear router in a row that this has happened with (breaking firmware updates that is). I've already dealt been dealing with with half the features "kind-of working" on this $250 router, and now I get the option of "Netgear Armor" (which I don't want at all), but have major features required for devices to function now broken along-side it.

 

Definitely switching brands after this. So much wasted time troubleshooting your routers over the past 5-10 years, that I'm just done. You're in the same bucket as Linksys at this point...you just churn out Firmware to add your own company features vs. caring about whether customers are left in the dark...it's not like UPnP hasn't been around for a while or anything...practically EVERY household relies on it at this point.

Model: R8000|Nighthawk X6 AC3200 Smart WIFI Router
Message 6 of 12
IrvSp
Master

Re: Bug Report, R8000, V1.0.4.46 UPNP does not work and other odd issues


@Retired_Member wrote:

 

Definitely switching brands after this. So much wasted time troubleshooting your routers over the past 5-10 years, that I'm just done.


I agree with you 100%!!!!

 

I didn't wait to put that version of f/w on my 18 month old R8000. I didn't want to keep at the V1.0.4.28 level of f/w either.

 

I did like the Tri-Band and researched other vendor models AND both REVIEWS and FORUMS.

 

Reviews of what I replaced the R8000 with were, well, mixed. Forums too, some vendor's do not have actual forums either. Some look just like here.

 

In the past, when my 5 year old R7000 started acting flakey on me I thought it had lived a good life and I also did research on a new router. Settled on the R8000 due to the experience with the R7000. It wasn't until later when the possibility of my R7000 either having f/w problems or damaged by the f/w became a possiblity after others reported similar problems here. However the R8000 just worked. That was until the new f/w (.46) was released and features I USED were removed. Cut my losses and moved on.

 

When I was researching replacing the R7000 almost all forums were the same. However now, one is CLEARLY better. TP-Link! Check out the forum and you'll see very few each day, and Moderator's who actually will take an active roll in problems and contact support for you and get answers. Many reports in the forum are from end-user that don't have router experience or actual h/w problems.

 

The above forum and reviews made me switch to a TP-Link A20 (very similar to the C4000) which is fairly new. Features are basically the same as the R8000 (and it costs less to boot).

 

Is the A20 perfect? Yes and no. It performs flawlessly for me. Some minor hiccups during install. Some features such as logging are not as user friendly. QoS is always active and can't be turned off, but can be customized. DOES NOT interfere with Internet speed. USB sharing, all I can say is it works but is PRIMATIVE in that there is only ONE possible share for both drives and all folders/sub-folders. Minor other things, but this is V1 firmware and could change with later firmware.

 

Basically it just works. Has DLNA, Time Machine, UPnP, and more. Traffic Monitor can be enable and doesn't seem to slow down Internet either. Optionally Trend Micro can be turned on, and it is FREE for 3 years... and since the inclusion is new, at this time there is no list renewal fee (unlike NG's Armour pricing).

 

Oh, want to see what the GUI looks like, go here, https://emulator.tp-link.com/a20-us-v1/index.html , you can click on everything and see all the options and what settings can be done. Neat idea!

 

 

Message 7 of 12
myersw
Master

Re: Bug Report, R8000, V1.0.4.46 UPNP does not work and other odd issues

Totally agree with @IrvSp  get something other then Netgear. 

 

I chose to go a little lighter up in equipment. Went toward the commercial grade in my case. That was over a year ago and network has been solid. No wifi drops, no router reboots, no slowdowns, just works unlike my r8000 and r8000p. I am even running their beta code on the gateway (Ubuquiti speak for router) , AP's and smart switches. All told, by watching eBay I was able to outfit the network for about $450. Not that far different from list for a high end consumer router. The beta code just works, unlike the released code from Netgear. I to like Irv had a r7000 that worked, and got a r8000 then r8000p hoping to find something that would run as well as the r7000 had. The firmware from Netgear right now is a joke. Being done by 3rd party, from what I am told, who does not seem to have a clue about the code, testing that bugs are fixed, or QA. Version after version have the same bugs. That just should not happen from a company who cares. Then to remove features folks bought their router for so they can put on a money grab called Armor is just the latest move showing how little they care about the customer. 

--Bill
ISP Comcast, Modem-Netgear CM1150V, Router-Unifi Security Gateway-Pro4, AP-2 Unifi AP-LR
Tesla > Edison
Message 8 of 12
Artemau
Aspirant

Re: Bug Report, R8000, V1.0.4.46 UPNP does not work and other odd issues

Thank you for posting this! Just observed this same issue with my R8000 trying to play Destiny 2. Rolling back to 1.0.4.28 was the fix for the broken UPNP.

 

Model: R8000|Nighthawk X6 AC3200 Smart WIFI Router
Message 9 of 12
Kronvrak
Guide

Re: Bug Report, R8000, V1.0.4.46 UPNP does not work and other odd issues

Do anyone know if Netgear is working on fixing the UNPN issue?

Model: R8000|Nighthawk X6 AC3200 Smart WIFI Router
Message 10 of 12
AtomicMre
Guide

Re: Bug Report, R8000, V1.0.4.46 UPNP does not work and other odd issues


@Kronvrak wrote:

Do anyone know if Netgear is working on fixing the UNPN issue?


Well, the firmware has been broken for almost 3 months now and there isnt even a beta firmware with a fix posted. 

This thread is 2 1/2 months old and hasn't been acknowledged by any Netgear community people. 

 

Given those two facts, I'd feel pretty safe guessing no and honestly I'm not planning on sticking around to find out what they 'fix' next.

Model: R8000|Nighthawk X6 AC3200 Smart WIFI Router
Message 11 of 12
schumaku
Guru

Re: Bug Report, R8000, V1.0.4.46 UPNP does not work and other odd issues

@Christian_R  please.

Message 12 of 12
Top Contributors
Discussion stats
  • 11 replies
  • 3168 views
  • 0 kudos
  • 8 in conversation
Announcements

Orbi WiFi 6E