Reply

Re: Can't disable WPS

MrCallahan
Tutor

Can't disable WPS

Bought an R7000 a few days ago, set it up, and flashed it to 1.0.3.68. The "WPS Wizard" button is grayed out, and the "Enable Router's PIN" box is checked, but grayed out as well so I cannot uncheck it. Is there a way to fix this, or should I do a full reset?

Thanks
Message 1 of 16
Inolvidable
Aspirant

Re: Can't disable WPS

I am not 100% sure but as far as I know WPS can not be disabled in the stock firmware. If somebody knows how would be great
Message 2 of 16
VE6CGX
Master

Re: Can't disable WPS

IMO. disabling WPS is meaningless. If some wants to connect using WPS, it won't happen unless you click the WPS button on the router.
Message 3 of 16
twalls
Tutor

Re: Can't disable WPS

If the WPS PIN is enabled, people can try guessing the numbers to get connected (even without the button being pressed). In fact, even Netgear recognizes this issue and advises to disable the WPS PIN if you have no need for it:

http://kb.netgear.com/app/answers/detail/a_id/19824/~/how-do-netgear-home-routers-defend-wifi-protec...

Note that they offer some protection by temporarily locking out the WPS function if too many bad guesses are made for the PIN. You should see a flashing light for the WPS button if this happens.

If you can't uncheck the WPS PIN, then something odd is going wrong. I'm also not sure what it means that the WPS Wizard button is grayed out, mainly because it is already a gray button. Smiley Tongue The only thing I can think of is it won't show the WPS functionality if the Wi-Fi security isn't set, but then you have bigger problems than having WPS enabled...
Message 4 of 16
RogerSC
Virtuoso

Re: Can't disable WPS

twalls wrote:
If the WPS PIN is enabled, people can try guessing the numbers to get connected (even without the button being pressed). In fact, even Netgear recognizes this issue and advises to disable the WPS PIN if you have no need for it:

http://kb.netgear.com/app/answers/detail/a_id/19824/~/how-do-netgear-home-routers-defend-wifi-protec...

Note that they offer some protection by temporarily locking out the WPS function if too many bad guesses are made for the PIN. You should see a flashing light for the WPS button if this happens.


Yes, the temporary locking out of the WPS function should deter the reaver exploit for discovering the WPS pin, since the "cracker" won't be able to get there in a finite period of time (at least, that's the theory). The reaver exploit depends on being able to go through a *lot* of trials uninterrupted by timeouts.
Message 5 of 16
RogerSC
Virtuoso

Re: Can't disable WPS

Also, I think that the critical place to disable this is under Advanced wireless settings (at the bottom of that page), where you can disable the WPS PIN. I've never been fond of wizards, I'd rather deal with the settings directly, then you know that things are set up properly. In any case, it looks to me that the "WPS Wizard" is for using WPS to connect to the router, not for disabling WPS.

So if you just go directly to the Advanced Setup, and then the Wireless Settings page, you should be able to disable the WPS PIN there.
Message 6 of 16
MrCallahan
Tutor

Re: Can't disable WPS

I can't disable the PIN under Advanced Settings. I can't modify anything that has to do with WPS.
Message 7 of 16
MrCallahan
Tutor

Re: Can't disable WPS

Message 8 of 16
toddntampa
Novice

Re: Can't disable WPS

MrCallahan, I don't know if this will help your situation or not, but I also had this same problem and I haven't updated my firmware yet. I had turned off SSID broadcast so my neighbors would not even see my wireless network. Once I enabled SSID Broadcast (Advanced -> Setup -> Wireless Setup -> Enable SSID Broadcast), I was again able to use the WPS Wizard! Smiley Happy
Message 9 of 16
RogerSC
Virtuoso

Re: Can't disable WPS

toddntampa,

Not broadcasting your SSID doesn't make your network "invisible", it only means that the line in everyone else's client WiFi network picker, or inSSIDer, etc., doesn't show an SSID. But your network is shown, and is available to those that are interested in breaking into it. It doesn't do anything for security, and in fact may cause problems with some clients. And also apparently with WPS *smile*.

The best security that you have is WPA2/AES with strong passwords. MAC filtering and not broadcasting your SSID don't add any general security from attackers.
Message 10 of 16
toddntampa
Novice

Re: Can't disable WPS

RogerSC,

Great information for others reading this forum! The BEST security *is* strong WPA2/AES passwords.


(I never said I was hiding my network from my neighbors for security reasons though. Smiley Very Happy)
Message 11 of 16
johnsdagg
Guide

Re: Can't disable WPS

Toddntampa is correct. I have purposefully turned off SSID broadcast on one of my wireless networks. When SSID broadcast is off for any wireless network I cannot change WPS settings.
Solution: If you want to change WPS settings,
*turn on SSID for all wireless networks
*change WPS settings and apply
*turn off SSID broadcast for whichever networks you want and apply

Apparently it's a bug in the GUI but there is an easy way to get around it.
Message 12 of 16
RogerSC
Virtuoso

Re: Can't disable WPS

toddntampa wrote:

(I never said I was hiding my network from my neighbors for security reasons though. Smiley Very Happy)


That is part of my point...you aren't hiding anything by not broadcasting your SSID. You may be making things more difficult for yourself, though. I did infer that you did this for security. I don't really know why anyone would not broadcast their SSID, since neighbors and people in your house will see your wifi network anyways. I do see people talking about doing this in conection with security, though *smile*.
Message 13 of 16
ceyotoo
Initiate

Re: Can't disable WPS

Disabling SSID Broadcast also disables WPS. It shows a pop-up when you turn off SSID Broadcasting stating such.

Message 14 of 16
mondenath
Prodigy

Re: Can't disable WPS

WPS wont be a major security concern. As try the below firmware.

 

By default the ACL works in such a way that even if password / pin is known to someone its useless and it blocks them being unknow mac or not approved devices. You can easily pin point in the ACL table.

 

So try the below firmware and see if smoothens the progress.

 

https://community.netgear.com/t5/Nighthawk-WiFi-Routers/R7000-firmware-v1-0-5-44-limited-release/td-...

Message 15 of 16
2ark0
Initiate

Re: Can't disable WPS

This worked for me, I had disabled the option under "Setup" > "Wireless Setup" > "Enable SSID Broadcast " for my 2.4 wireless. After I enabled again the option WPS wizards got enabled back!!

Message 16 of 16
Top Contributors
Discussion stats
  • 15 replies
  • 19932 views
  • 8 kudos
  • 10 in conversation
Announcements