Reply

Rif.: Cannot access http server using ddns hostname from my own network

ddregs1
Tutor

Cannot access http server using ddns hostname from my own network

Hi all,

I am using my own internet provider cable modem (VDSL2) and a R7800 router behind that to access the internet.

The R7800 is configured via cable to the internet port, it uses the connection established by the modem (it doesn't create a new PPPoE session) and has DDNS properly configured. The port forwarding is done on R7800, while the cable modem has just been set to use DMZ (and the R7800 is on DMZ), and firewall is turned off.

A raspberry Pi 3 is deployed on the local network with a static IP and http is forwarded by R7800 to that Linux machine.

When I try to access http server from the external world using DDNS, it all works perfectly. So far , port forwarding is working.

When I try to access http server from the local network using the hostname given by DDNS , it doesn't work (the request times out). No matter if I try to access it using a wireless device (iPhone/iPad) or a cabled device (PC or Mac). If I try accessing it using the local IP, it works. 

I tried using only the cable modem , setting up port forwarding, ddns , and it works. Unfortunately this cable modem hangs when used heavily.

I suspect it has something to do with the cable modem , as I previously had another model and it worked (that model was replaced by the provider, it was a Technicolor now it is a Sercomm VD625).

Is there something I can do to fix this issue? I have a few apps (house security) on my phones that need to access local devices with different ports than http, but I would need to switch the configuration when they're used with wifi (local IP) or via LTE from the external world, and it would be rather cumbersome to deploy with wife and kids phones....

Thanks for your help

 

Model: R7800|Nighthawk X4S AC2600 Wifi Router
Message 1 of 2
ddregs1
Tutor

Rif.: Cannot access http server using ddns hostname from my own network

To further expand, network is configured this way:

- ISP cable modem has IP 192.168.0.1

- R7800 is connected via WAN port to the cable modem, and has a static IP on the cable modem 192.168.0.9 , and it has been set as DMZ.

- firewall, ddns, port forwarding are disabled on the cable modem

 

- R7800 has IP 192.168.1.1

- HTTP server is on the network with IP 192.168.1.112, IP reserved on R7800 via MAC address

- port forwarding has been set on R7800 to forward port 80 to IP 192.168.1.112

- ddns is set and properly working on R7800 (name is xxxxx.mynetgear.com , where xxxxx is the actual hostname)

 

Using the network I can ping xxxxx.mynetgear.com , and the address gets resolved

I cannot access the webserver though using xxxxx.mynetgear.com. I can access it using 192.168.1.112

 

If I use only the cable modem everything works (but as described, cable modem crashes almost once every 2 days, while R7800 is stable).

 

Thanks for your help

Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 204 views
  • 0 kudos
  • 1 in conversation
Announcements