Reply

Cant upgrade Firmware on a R7960P

Bellpr
Follower

Cant upgrade Firmware on a R7960P

I'm on Firmware v 1.4.1.50_1.3.10 and trying to upgrade the Firmware to V1.4.1.68_1.3.28.  It says the update was successful via the Phone app but never completes the upgrade successfully.  When I try the upgrade via my PC, It always say it failed.  message:


Unable to download GUI language file from Netgear server

Model: R7900|Nighthawk X6 AC3000 Tri-Band WiFi Router
Message 1 of 4
FormelEins
Aspirant

Re: Cant upgrade Firmware on a R7960P

Same issue. Netgear R7960P-V1.4.1.68_1.3.28 firmware update failed. Going from V1.4.1.50_1.3.10 to R7960P-V1.4.1.68_1.3.28
Admin login gets message  "A router firmware upgrade is available."
 
Going thru Firmware Update Assistant; it connects to the Netgear server and shows the GUI notes. It's telling me that it's downloading and updating the language table. But then it's unable to download the GUI language file from the Netgear server.
 
I then proceeded to the Netgear site and download as well as unzipped the firmware.
I uploaded the firmware to the router. Got the warning that the internet connection will be temporary disconnected and it looked like the router was updating its firmware. Then it showed me the router rebooting. 
It appears that the update it's going through properly but at the end the firmware version does not change. 
 
Just in case the firmware image was bad, I tried also updating to R7960P-V1.4.1.66_1.3.26.chk. No Joy!
Message 2 of 4
schumaku
Guru

Re: Cant upgrade Firmware on a R7960P

There are several lengthy threads on this issue. 

 

I'd suggest to use the tftp recovery process for uploading the current firmware.

 

Windows:

How to upload firmware to a NETGEAR router using Windows TFTP 

 

MacOS and similar for any OS (without a utility):

How to upload firmware to a NETGEAR router using TFTP client?  

Message 3 of 4
Dfixit1
Aspirant

Re: Cant upgrade Firmware on a R7960P

Tried the app upgrade, says successful but not.

Connected laptop to router, downloaded .166 & .168 and manually tried both to update, says sucessful but still stuck on V1.4.1.50_1.3.10

So why should we have to dos prompt to fix this issue?

Poor support for Netgear, as they hosed it with the V1.4.1.50_1.3.10

Ive always like netgear but their poor support is going to make me move to another manufacturer.

Regards

 

Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 248 views
  • 0 kudos
  • 4 in conversation
Announcements