Reply
Highlighted
Follower
Follower

Complaint

In the two days since I purchased the AC2600 router, I have spent almost 5 hours on the phone, between 4 calls,  with Netgear support and I am still unable to connect to the internet. In addition to the time spent on the phone with Netgear support, I have spent a similar amount of time trawling through forums and videos trying to find a solution. Without luck. 

Steps taken so far:

- allow Netgear genie to setup the connection

- power cycle the netgear router

- power cycle the netgear router and the NBN modem

- reboot the netgear router

- update the firmare on the netgear router

- input PPPOE details

- VLANID enabled; 2

- Input the MAC address of the exisiting (TPlink) router, that was meant to be replaced by the Netgear router.

- Several phone calls to the ISP, after giving up with at the concslusion of each call with Netgear customer support

- Replaced the Netgear nighthawk router with the identical model and still no internet connection. 

When I plug in my existing TPlink router, the internet connection is fine. I then disconnect the TPlink router and connect the Netgear router, and suddenley no internet. 

The amount of time and money spent on the Netgear router is ridiculous for it to still not be connected to the internet. The Netgear customer support so far has left a lot to be desired. Please help me resolve this.

One very frustrated and disastisfied customer. 

Model: D7800|Nighthawk X4S – AC2600 WiFi VDSL/ADSL Modem Router
Message 1 of 2
Highlighted
Virtuoso

Re: Complaint

I don't think there is a simple solution to your problem.  Return the Netgear for a refund and get a TP-Link!

Keith

(2xWNR2000, 3xWNCE2001, FWAG114, FS116, GS116, 6xR7000)
Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 117 views
  • 0 kudos
  • 2 in conversation
Announcements