Reply

D7800 Slow speed after upgrading connection to Fibre

shannonperera
Aspirant

D7800 Slow speed after upgrading connection to Fibre

Hi all,


I recently upgraded my home internet connection to Vodfone's Fibre Max plan. This plan is meant to give expected speeds around 700-900Mbps.

 

I have a D7800 Modem/Router which I have configured as per Vodafone provided (basic) settings and have been able to establish a connection - however it is much slower than expected, only around 150-250Mbps with my laptop plugged directly into the router.

 

The thing that makes it more confusing is that when I log into the router and complete a speedtest from there I get a download speed of around 550Mbps. So it seems like the router is receiving a high speed connection but then on the 'output' side the speed is dropping significantly.

 

I'm not sure if this is even possible? Or could it be that I need to update some settings to ensure that the full connection speed flows through the router? (apologies for my lack of knowledger here!)

 

The settings that Vodafone advised to set are listed below:

 Field

 Configuration

 Access Type

Ethernet

 Connection Type

IP routing (IP/DHCP)

 MTU

1500

 VLAN

On

VLAN ID

10

 IP protocol version

 IPv4 + IPv6

 IPv4 address type

 DHCP

 DNS

 Automatic

 IPv6 addressing type

 DHCP

 

I haven't set anything related to IPv4 as I wasn't sure what the setting should be.

 

Would anyone have any suggestions on how I could improve the connection speed? Any help would be appreciated!

 

Thanks,

Shannon

Model: D7800|Nighthawk X4S – AC2600 WiFi VDSL/ADSL Modem Router
Message 1 of 3

Re: D7800 Slow speed after upgrading connection to Fibre


@shannonperera wrote:

 

I have a D7800 Modem/Router which I have configured as per Vodafone provided (basic) settings and have been able to establish a connection - however it is much slower than expected, only around 150-250Mbps with my laptop plugged directly into the router.

 

Only you, and Vodafone, know what those settings are. So we are left guessing.

 

Did you read the manual for the D7800 and follow the instructions on using it with a cable service?

 

Visit the support pages:

Support | NETGEAR

Feed in your model number and check the documentation for your hardware.

Check the section in the manual Set Up the Modem Router for Cable or Fiber Service.

You may have done that already. I can't tell from your message.

I mention it because Netgear gave up on supplying paper manuals and CD versions some years ago and people sometimes miss the downloads.

 

Did you reset the D7800 before you changed the service? You should do that to wipe out any settings inherited from the old service.

 


@shannonperera wrote:

 

I have a D7800 Modem/Router which I have configured as per Vodafone provided (basic) settings and have been able to establish a connection - however it is much slower than expected, only around 150-250Mbps with my laptop plugged directly into the router.

 

The thing that makes it more confusing is that when I log into the router and complete a speedtest from there I get a download speed of around 550Mbps. So it seems like the router is receiving a high speed connection but then on the 'output' side the speed is dropping significantly.

 

Not sure that I follow what you are doing there. Where does this 550 Mbps come from? What do you mean by "log into the router"? Is that the D7800 or whatever Vodafone provides?

 

Is that modem/router or an "ONT" with a plain Ethernet outlet.

 

What speed does your laptop deliver when you plug into the Vodafone box, without the router in there?

 

How are you testing speeds? Wifi is never going to be as fast as wired.

 

It may not make much difference, but the D7800 is a DSL modem/router. You might get more help, and find earlier questions and answers specific to your device, in the appropriate section for your hardware. That's probably here:

DSL Modems & Routers

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 2 of 3
shannonperera
Aspirant

Re: D7800 Slow speed after upgrading connection to Fibre

Hi @michaelkenward ,

 

Thanks for your response to my query. In answer to some of your questions

 

1) Please see below for the router settings that the ISP provided to configure the router:

 Field

 Configuration

 Access Type

Ethernet

 Connection Type

IP routing (IP/DHCP)

 MTU

1500

 VLAN

On

VLAN ID

10

 IP protocol version

 IPv4 + IPv6

 IPv4 address type

 DHCP

 DNS

 Automatic

 IPv6 addressing type

 DHCP

 

2) Confirming I have downloaded and read the latest version of the D7800 instruction manual and completed the fibre config as per these instructions (using the limited info provided by the ISP of course)

 

3) Yes, I have completed a full reset of the router and config of fibre settings.

 

4) With regards to the 550Mbps comments , I found that in the D7800 router config, the QoS setup under the Advanced tab of the Router (accessing via 192.168.1.1), I can run a speed test from within the Router itself (apologies for my lack of technicial explanation here!) I have included a screenshot below if this helps explain - this particular example actually shows a faster download speed of 621.50 Mbps.

 

Router Speedtest 2.PNG

However if I run a similar speedtest using URL https://www.speedtest.net and using my laptop plugged in with a Cat5e cable directly into the router and  then I will only get a speed of 150-150Mbps.

 

In terms of the physical setup I have the ONT and then a Cat5e cable from the ONT into the D7800. Then a Cat5e cable from the D7800 to my laptop.

 

To me is seems like the Router is somehow limiting the speed? Could this even be possible?

 

Thanks,

Shannon

Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 93 views
  • 0 kudos
  • 2 in conversation
Announcements

Orbi WiFi 6E