Reply

Re: DNS_PROBE_FINISHED_NXDOMAIN Error

Bharath_Bekal
Luminary

DNS_PROBE_FINISHED_NXDOMAIN Error

My router DNS is configured to Get Automatically from ISP. From past few weeks i get DNS_PROBE_FINISHED_NXDOMAIN while trying to browse new pages for first attempt , if i reload the page it opens.

If i assigned static DNS IP(8.8.8.8) to my system i don't see this issue. It occurs only when DNS is pointed to the router .  Any suggestion how to fix this issue 

 

Model: NighthawkNighthawk X6 R8000
Firmware Version
V1.0.4.74_10.1.80

Model: R8000P|Nighthawk X6S AC4000 Tri Band WiFi Router
Message 1 of 24

Accepted Solutions
Gipper4u
Luminary

Re: DNS_PROBE_FINISHED_NXDOMAIN Error

If you want to put a bandaid on the problem, in Windows, click on the little wifi icon at bottom right, select Network & Internet settings, click on the adapter you are using (likely Wi-Fi), click on change adapter options, right click on Wi-Fi adapter and choose properties, double click Internet Protocol Version 4, change DNS to use the following DNS server and enter 1.1.1.1 and 1.0.0.1.  This will fix the issue until NG releases an update.  To reverse this change do the same, but select Obtain DNS server address automatically.

 

*Rolling back firmware is a security risk so please don't advise that and mark the thread solved. That is not an acceptable solution!  This is not solved until NetGear releases a firmware upgraded that addresses the issue!

View solution in original post

Message 17 of 24

All Replies

Re: DNS_PROBE_FINISHED_NXDOMAIN Error

A recent firmware update has broken DNS in several Netgear routers.

 

Solved: Re: R8000 - Have to load every page 2x after insta... - NETGEAR Communities

 

 

Backtrack to the previous firmware and wait for Netgear to mend it.

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 2 of 24
Retired_Member
Not applicable

Re: DNS_PROBE_FINISHED_NXDOMAIN Error

I started to get the DNS_PROBE_FINISHED_NXDOMAIN error along with ERR_NAME_NOT_RESOLVED since a recent update as well.  It is distressing and has been causing me anxiety.  I purchased the unit in March 2021 and it has been fine until now.  I have spent countless hours trying all of the fixes noted by others in the community and via online research to no avail prior to discovering that others in the community are having the same issue and have narrowed it down to a Netgear issue as well. 

 

Netgear do you plan to issue an update with the fix in the next few weeks?  If not I am done and will cancel my subscription and buy another brand.  Please advise.....

Model: R8000P|Nighthawk X6S AC4000 Tri Band WiFi Router
Message 3 of 24

Re: DNS_PROBE_FINISHED_NXDOMAIN Error


@Retired_Member wrote:

 

Netgear do you plan to issue an update with the fix in the next few weeks?  If not I am done and will cancel my subscription and buy another brand.  Please advise.....


I don't know what "subscription" you have, but when it comes to mending broken firmware, this doesn't run on any fixed timetable. It is also a drawn out process that goes through various stages. (As you have found, this doesn't always work as effectively as it should.) So, don't hold your breath for "the next few weeks".

 

In the meantime, your best strategy is probably to revert to earlier firmware and wait for the update.

 

You have not told us what firmware you have on your router. I assume that you have done the obvious thing and checked the support pages for the R8000P to see if there is anything new there:

 

Nighthawk X6S R8000P | AC4000 Tri Band WiFi Router | NETGEAR Support

 

including the recent "hotfix":

 

R8000P Firmware Version 1.4.1.82 - Hot Fix | Answer | NETGEAR Support

The support page is also the place to find older versions.

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 4 of 24
Retired_Member
Not applicable

Re: DNS_PROBE_FINISHED_NXDOMAIN Error

Thank you for your advice!

Message 5 of 24
SnooSnoo
Luminary

Re: DNS_PROBE_FINISHED_NXDOMAIN Error

This is extremely frustrating, i paid money for a reliable router and have had nothing but problems. 

 

I'm putting together information to send UK watchdog regarding Netgears firmware updates which previously when updating the router used to clear all wireless security allowing anyone to join the network and invalidate your home security.

 

@netgear 

 

V1.4.2.84_1.3.42 - This firmware version causes the above DNS_PROBE_FINISHED_NXDOMAIN Error when loading webpages. 

 

V1.4.1.66 - This firmware version causes a guest network to activate called "Netgear 5G - Guest" which is unconfigurable in the router and allows anyone in the local area to connect and compromise your home security. Even after configuring all guest networks and applying passwords it still broadcasts and allows anyone to connect. I only found this out by switching my router on and off noticing that specific SSID to be broadcasting via my router. 

 

Netgear is simply the worst company for home and business routers, their CEO should resign and software engineers should be fired! 

 

 

Message 6 of 24
FURRYe38
Guru

Re: DNS_PROBE_FINISHED_NXDOMAIN Error

You should contact NG support and let them know. 

 

FYI, Avoid using @ netgear tag. That profile has not been accessed since 2015.

 

Good Luck. 


@SnooSnoo wrote:

This is extremely frustrating, i paid money for a reliable router and have had nothing but problems. 

 

I'm putting together information to send UK watchdog regarding Netgears firmware updates which previously when updating the router used to clear all wireless security allowing anyone to join the network and invalidate your home security.

 

@netgear 

 

V1.4.2.84_1.3.42 - This firmware version causes the above DNS_PROBE_FINISHED_NXDOMAIN Error when loading webpages. 

 

V1.4.1.66 - This firmware version causes a guest network to activate called "Netgear 5G - Guest" which is unconfigurable in the router and allows anyone in the local area to connect and compromise your home security. Even after configuring all guest networks and applying passwords it still broadcasts and allows anyone to connect. I only found this out by switching my router on and off noticing that specific SSID to be broadcasting via my router. 

 

Netgear is simply the worst company for home and business routers, their CEO should resign and software engineers should be fired! 

 

 


 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM1200 Modem |  Wifi Router Orbi RBK752 (Router Mode), Wired Backhaul and R8500 | Switches NG GS105/8, GS308v3, GS110MX and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 7 of 24
SnooSnoo
Luminary

Re: DNS_PROBE_FINISHED_NXDOMAIN Error

NG Support? Smiley LOL

 

Thanks for trying to help but your comment is laughable. 

 

LOL.

 

Message 8 of 24

Re: DNS_PROBE_FINISHED_NXDOMAIN Error


@SnooSnoo wrote:

NG Support? Smiley LOL

 

Thanks for trying to help but your comment is laughable. 

 

LOL.

 


Looking back at your messages on this community, I can see no sign that you have sought help to fix your problems.

 

Would you like to give it a whirl?

 

If so, best not to hitch a ride on the end of a continuing discussion. Start a new conversation and take it from there.

 

This thread is now near on two months old and going nowhere.

 

 

 

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 9 of 24
SnooSnoo
Luminary

Re: DNS_PROBE_FINISHED_NXDOMAIN Error

Michael, i have no choice to wait until a new firmware version is released. I live in a pretty large house and my ISP's routers wireless signal strength and processing power is crap. Also i'm not going to use custom firmware from advanced tomato either as i'm skeptical about the security of it's firmware. 

 

I might try and reflash the router with the lastest version this weekend to see if it resolves my issues.

Message 10 of 24
FURRYe38
Guru

Re: DNS_PROBE_FINISHED_NXDOMAIN Error

Would be more helpful too to know what exact router model your having problems with. Something to start a new thread and give more details.


Good Luck though. 


@SnooSnoo wrote:

Michael, i have no choice to wait until a new firmware version is released. I live in a pretty large house and my ISP's routers wireless signal strength and processing power is crap. Also i'm not going to use custom firmware from advanced tomato either as i'm skeptical about the security of it's firmware. 

 

I might try and reflash the router with the lastest version this weekend to see if it resolves my issues.


 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM1200 Modem |  Wifi Router Orbi RBK752 (Router Mode), Wired Backhaul and R8500 | Switches NG GS105/8, GS308v3, GS110MX and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 11 of 24

Re: DNS_PROBE_FINISHED_NXDOMAIN Error


@SnooSnoo wrote:

Also i'm not going to use custom firmware from advanced tomato either as i'm skeptical about the security of it's firmware. 

 


Good thinking. You should not need to do that. But "security" is one of those scary words that often means nothing much. Many security issues are theoretical attacks dreamed up in academic labs. They never make it into the real world.

 


@SnooSnoo wrote:

 

I might try and reflash the router with the lastest version this weekend to see if it resolves my issues.


 

Not sure that "the latest version" is going to fix things. Many people fix the bug you see by reverting to older firmware.

 

I see no sign that you have sought help with the issue that you described earlier.

 

V1.4.1.66 - This firmware version causes a guest network to activate called "Netgear 5G - Guest" which is unconfigurable in the router and allows anyone in the local area to connect and compromise your home security. Even after configuring all guest networks and applying passwords it still broadcasts and allows anyone to connect.

 

Start a new conversation and see where that takes you.

 

 

 

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 12 of 24
Gipper4u
Luminary

Re: DNS_PROBE_FINISHED_NXDOMAIN Error

I have the same problem and can confirm that setting DNS manually on local computer resolves the issue.  No matter what DNS I assign on my router, I get constant DNS_PROBE_FINISHED_NXDOMAIN errors if DNS is pointing to the router. 

 

Nighthawk R7960P   

Firmware Version
V1.4.2.84_1.3.42  

Message 13 of 24
404pagenotfound
Luminary

Re: DNS_PROBE_FINISHED_NXDOMAIN Error

DNS is core part of what a router does. If this is 'a drawn out process that goes through various stages'  how could a bug as basic as this get out to customers.  And why is it still not fixed?   I spend a few days tracking this issue down, and the last thing I would have assumed is that DNS on my router is borken.

 

 

Message 14 of 24
FURRYe38
Guru

Re: DNS_PROBE_FINISHED_NXDOMAIN Error

There other long posts about DNS being broken. I believe NG is aware and has been made aware of the problems users are seen. You'll need to contact NG support and let them know what your experiencing. Otherwise, users have found that downgrading FW resolves the DNS issue until NG can get this fix fulling on newer FW. 


Good Luck. 


@404pagenotfound wrote:

DNS is core part of what a router does. If this is 'a drawn out process that goes through various stages'  how could a bug as basic as this get out to customers.  And why is it still not fixed?   I spend a few days tracking this issue down, and the last thing I would have assumed is that DNS on my router is borken.

 

 


 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM1200 Modem |  Wifi Router Orbi RBK752 (Router Mode), Wired Backhaul and R8500 | Switches NG GS105/8, GS308v3, GS110MX and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 15 of 24
404pagenotfound
Luminary

Re: DNS_PROBE_FINISHED_NXDOMAIN Error

Netgear release a firmware that stops their "router from routing" bSmiley Frustrated, and customer are suppose to be ok with that?  Its time to look for a replacement router which will not a Netgear brand.

 

Also I have just confirmed that QOS is running on the router as well even though I have it disabled in the UI.   

Message 16 of 24
Gipper4u
Luminary

Re: DNS_PROBE_FINISHED_NXDOMAIN Error

If you want to put a bandaid on the problem, in Windows, click on the little wifi icon at bottom right, select Network & Internet settings, click on the adapter you are using (likely Wi-Fi), click on change adapter options, right click on Wi-Fi adapter and choose properties, double click Internet Protocol Version 4, change DNS to use the following DNS server and enter 1.1.1.1 and 1.0.0.1.  This will fix the issue until NG releases an update.  To reverse this change do the same, but select Obtain DNS server address automatically.

 

*Rolling back firmware is a security risk so please don't advise that and mark the thread solved. That is not an acceptable solution!  This is not solved until NetGear releases a firmware upgraded that addresses the issue!

Message 17 of 24
404pagenotfound
Luminary

Re: DNS_PROBE_FINISHED_NXDOMAIN Error

I've replace the R8000 with a Archer A73, which I was planning on using as an access point.  My home network is running a lot better.

  • No more DNS errors
  • No more devices randomly dropping wifi
  • No more bandwidth throttling even though QOS is off in the UI. Steam, Epic and Ubisoft downloads were all cap out at ~20MBytes.  Now they are around 80-100MBytes.

The R8000 is great peice of hardware, unfortunately let down by poor software that even get basic DNS working :(.  I migh try and put a custom firmware on the R8000 to see how that performs.

 

Message 18 of 24
Robwuk
Luminary

Re: DNS_PROBE_FINISHED_NXDOMAIN Error

I too have been experiencing NX_Domain issues after a recent firmware update. I see this has happened before.
Intermittently I will get the error which will clear upon a reload. It is very furstrating, annoying and you begin to lose confidence in Netgear.

It is occuring on all devices connected to my  R7900P      router.

Model: R7900|Nighthawk X6 AC3000 Tri-Band WiFi Router
Message 19 of 24
StealthOne
Luminary

Re: DNS_PROBE_FINISHED_NXDOMAIN Error

I'm also seeing this issue.

 

Firmware V1.0.4.76_10.1.82

Message 20 of 24
FURRYe38
Guru

Re: DNS_PROBE_FINISHED_NXDOMAIN Error

What router model do you have? 


@StealthOne wrote:

I'm also seeing this issue.

 

Firmware V1.0.4.76_10.1.82


 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM1200 Modem |  Wifi Router Orbi RBK752 (Router Mode), Wired Backhaul and R8500 | Switches NG GS105/8, GS308v3, GS110MX and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 21 of 24
StealthOne
Luminary

Re: DNS_PROBE_FINISHED_NXDOMAIN Error

Nighthawk X6 R8000

 

I've downgraded to V1.0.4.68_10.1.75.  So far I haven't seen any DNS issues.

Message 22 of 24
FURRYe38
Guru

Re: DNS_PROBE_FINISHED_NXDOMAIN Error

Thank you for confirming the model and that downgrading helps. 


@StealthOne wrote:

Nighthawk X6 R8000

 

I've downgraded to V1.0.4.68_10.1.75.  So far I haven't seen any DNS issues.


 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM1200 Modem |  Wifi Router Orbi RBK752 (Router Mode), Wired Backhaul and R8500 | Switches NG GS105/8, GS308v3, GS110MX and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 23 of 24
broneilb
Luminary

Re: DNS_PROBE_FINISHED_NXDOMAIN Error

STILL seeing this problem.  JFC, NG... fix it.

 

Changing adapter DNS to 1.1.1.1 and 1.0.0.1 like Gipper4u suggested is working.

 

 

Model: R8000P

 

FW: V1.4.3.88_1.3.50

Message 24 of 24
Top Contributors
Discussion stats
  • 23 replies
  • 5996 views
  • 14 kudos
  • 10 in conversation
Announcements

Orbi WiFi 6E