Reply
Highlighted
Guide

DNS not working with IPv6 - R7000

I found out my ISP now supports IPv6 in my area (Cox Phoenix) so I deciced to try it out.  Under IPv6 settings changed internet connection type to "auto" and applied and it came back as DHCP.  Got IPv6 WAN, LAN and DNS ip addresses and after a restart my Windows 7 machine also had IPv6 addresses.  Generally connectivity seems to work, but dns lookups are slow because the initial IPv6 lookup always times out and then does the IPv4 one

 

Symptoms:

  • Whenever I type an address click on a hyperlink for something not recently accessed, the page takes ages to load (firefox, chrome, IE.)
  • http://test-ipv6.com/ tells me IPv6 dns lookups aren't happening:

    IPv6 connections work, but connections using DNS names do not use IPv6. For some reason, your browser or your OS is not doing IPv6 DNS 'AAAA' lookups
  • From my linux machine, dig times out:
    $ dig AAAA www.example.com
    
    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-20.P1.el5_8.6 <<>> AAAA www.example.com
    ;; global options:  printcmd
    ;; connection timed out; no servers could be reached

What works:

  • Change the DNS lookup on my Windows machine to use Google's DNS server directly (not the router), 2001:4860:4860::8888
  • Change the DNS lookup on my Windows machine to use Cox's DNS server directly (not the router), 2001:578:3f:0:0:0:0:30
  • On my linux machine, dig lookup specifiying Cox or Google's DNS server:
    $ dig AAAA www.example.com @2001:578:3f:0::30
    
    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-20.P1.el5_8.6 <<>> AAAA www.example.com @2001:578:3f:0::30
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 59160
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;www.example.com.               IN      AAAA
    
    ;; ANSWER SECTION:
    www.example.com.        75550   IN      AAAA    2606:2800:220:1:248:1893:25c8:1946
    
    ;; Query time: 25 msec
    ;; SERVER: 2001:578:3f::30#53(2001:578:3f::30)
    ;; WHEN: Fri Dec 25 11:09:03 2015
    ;; MSG SIZE  rcvd: 61

What doesn't fix it:

  • Changing the router's IPv6 DNS to always use Cox's server ips explicitly
  • Changing the router's IPv6 DNS to always use Google's server ips explicitly

Given I can direct my machines to DNS servers directly, bypassing the router, and it all works, I suspect there is an issue with the router.  Or I'm missing something in the configuration of the router (though it doesn't look like there's much to miss.)  I upgraded to firmware version V1.0.5.48_1.1.79 prior to trying IPv6, so I don't know if it worked prior to that.

 

Any suggestions?

 

Message 1 of 28
Highlighted
Guide

Re: DNS not working with IPv6 - R7000

TL;DR version (I can't find how to edit the original.)

 

For IPv6, if my client machines try to use the router for DNS lookup, every query takes many many seconds.  If I configure my machines to use the DNS servers directly, bypassing the router, then IPv6 works fine.

 

Is anybody else succesfully using ISP provided IPv6 with this router?

 

Message 2 of 28
Highlighted
Master

Re: DNS not working with IPv6 - R7000

Hi thughes,

 

Please try to update the firmware of your router to version 1.0.6.28. Reset the router after the update and reconfigure manually.

 

 

http://kb.netgear.com/app/answers/detail/a_id/30175

Message 3 of 28
Highlighted
Guide

Re: DNS not working with IPv6 - R7000

I gave it a try - still the same problem...

 

Message 4 of 28
Highlighted
Initiate

Re: DNS not working with IPv6 - R7000

I am having this exact same problem on the R7000 with FW V1.0.6.28_1.1.83. Used IPv6 autodetect which got a DHCPv6 address on the WAN from Cox (I'm in Phoenix). It also filled in the DNS server information. I have the LAN set to use autoconfig since I have android devices that cannot use DHCPv6. I cant resolve any IPv6 hostnames. If I look at the ipconfig output on my windows 10 machine, it has a gateway address of the router's link local address, but the DNS field is blank. If manually choose the cox or google ipv6 dns address in windows, all works fine. I'm so frustrated at this point that I have disabled IPv6 on the router, simply because the implementation is too buggy. I'll probably return this router. My old Linksys EA6400 had no problems with IPv6. Its a shame because this router has excellent wireless range.

Message 5 of 28
Highlighted
Master

Re: DNS not working with IPv6 - R7000

Hi All,

 

Engineers are aware of this. I will provide an update as soon as there is any feedback.

 

Regards,

 

JamesGL

Community Team

Message 6 of 28
Highlighted
Aspirant

Re: DNS not working with IPv6 - R7000

I am having the same issue has there been anyupdates? i cant get DNS to work at all either automaticly or manualy. i have to set it on every machine to get it to work.

Message 7 of 28
Highlighted
Aspirant

Re: DNS not working with IPv6 - R7000

Hi,

 

I also have this problem : impossible to use router DNS, I have to set it directly under windows to get it to work.

 

Can we have an update for support team? It's a major bug.

 

Regards,

J

 

 

Message 8 of 28
Highlighted
Aspirant

Re: DNS not working with IPv6 - R7000

hope they get it fixed.

Message 9 of 28
Highlighted
Guide

Re: DNS not working with IPv6 - R7000

Yeah, I tried to work around it at first by setting my PCs to bypass the router for DNS.  But then my phones were still suffering and I couldn't figure out how to manually adjust the DNS for them; so finally gave up and turned off IPv6.  Given it was reported nearly two months ago, and acknowledeged a month ago, I'm surprised there's been no news on a fix...

 

Message 10 of 28
Highlighted
Aspirant

Re: DNS not working with IPv6 - R7000

if at some pont I need IPV6 and the issue does not get fixed I will go back to asus and never use netgear for enything ever again.

Message 11 of 28
Highlighted
Aspirant

Re: DNS not working with IPv6 - R7000

Message 12 of 28
Highlighted
Initiate

Re: DNS not working with IPv6 - R7000

Netgear was too slow. I returned this and got an Asus AC68P and it worked perfectly with IPv6 out of the box. If you want your router to look like a fighter jet, get a netgear. If you want it to work, get an Asus.

Message 13 of 28
Highlighted
Retired_Member
Not applicable

Re: DNS not working with IPv6 - R7000


 If you want your router to look like a fighter jet, get a netgear. If you want it to work, get an Asus.


You should contact ASUS and give them permission to use this as a marketing tool.

 

ROFLMAO

Message 14 of 28
Highlighted

Re: DNS not working with IPv6 - R7000

Hi, I had the same v6 problem in 1.0.4.30. Had to turn off v6 because of the timeouts in DNS. Netgear should provide the machines/clients the ISP's DNS IP instead of proxying using the router's IP.

Might be a problem with the happy eyeballs v6 to v4 fallback in the proxy.

In ddwrt, it is possible to set the DNS to give the ISP's DNS instead of proxy. Netgear, please give us the option to disable the DNS proxy and the problem will be solved
Message 15 of 28
Highlighted

Re: DNS not working with IPv6 - R7000

Hi @JamesGL,

 

Any feedback from the engineers about this problem?

 

The issue persists even with 1.0.5.64_1.1.88

 

Thank you

Message 16 of 28
Highlighted

Re: DNS not working with IPv6 - R7000

Hi @JamesGL,

 

Any feedback from the engineers about this problem?

 

The issue persists even with 1.0.5.64_1.1.88

 

Thank you

Model: R7000|Nighthawk AC1900 Dual Band WiFi Router
Message 17 of 28
Highlighted

Re: DNS not working with IPv6 - R7000

Hi @JamesGL,

 

Any feedback from the engineers about this problem?

 

The issue persists even with V1.0.5.70_1.1.91

 

Thank you

Model: R7000|Nighthawk AC1900 Dual Band WiFi Router
Message 18 of 28
Highlighted
Initiate

Re: DNS not working with IPv6 - R7000

I opened a support case with Netgear for this during my 90 day free support.  Still not working as of V1.0.7.2_1.1.93.  I keep IPv6 turned off and am disgusted with the poor support for IPv6.  My old ASUS router worked good with IPv6, but did not have the range that the R7000 has.  Please Netgear engineers, fix the IPv6 DNS support.

Model: R7000|Nighthawk AC1900 Dual Band WiFi Router
Message 19 of 28
Highlighted
Guide

Re: DNS not working with IPv6 - R7000

Same herr for the R6400. DNS on IPv6 still not working. This is amazin almost 1 1/2 years! NETGEAR fix this issue!
Message 20 of 28
Highlighted
Guru

Re: DNS not working with IPv6 - R7000

https://community.netgear.com/t5/Nighthawk-WiFi-Routers/Router-has-IPv6-DNS-Servers-manually-det-but...


@pipechess wrote:
Same herr for the R6400. DNS on IPv6 still not working. This is amazin almost 1 1/2 years! NETGEAR fix this issue!

 


My Setup (Cable 900Mbps/50Mbps)>CAX80(Modem Mode)>RBK853 v3.2.16.6(Router Mode)

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 21 of 28
Highlighted
Guide

Re: DNS not working with IPv6 - R7000

Anybody know if recent firmware updates fix this?  I still see similar complaints posted, so assuming not.  I finally installed tomato firmware a few months ago which fixes this issue but seems to noticeably diminish wireless performance so I'm considering going back to stock.

 

It's been nearly 19 months since I reported and 18 months since we were told "engineers are aware of this" but still no fix.  I feel stupid I wasted so much time troubleshooting and documenting in detail the problem for you.  I'm assuming at this point this model is abandoned in terms of significant updates.

 

This was my first high-end router purchase (previously always went with the $35.00 on-sale models) and was expecting a lot more in terms of quality and support considering the huge premium price.  I won't be purchasing Netgear in the future.

Message 22 of 28
Highlighted
Guide

Re: DNS not working with IPv6 - R7000

No. I was told that someone would take on my complaint but nothing. I actually switched to a different router. Sad, because the Nighthawks wireless is very reliable and fast. BUt I need IPv6 correctly implemented. I guess I have the Nightawk as backup....

Message 23 of 28
Highlighted
Guru

Re: DNS not working with IPv6 - R7000

You might contact ElaineM here on the forums and ask...


@thughes wrote:

Anybody know if recent firmware updates fix this?  I still see similar complaints posted, so assuming not.  I finally installed tomato firmware a few months ago which fixes this issue but seems to noticeably diminish wireless performance so I'm considering going back to stock.

 

It's been nearly 19 months since I reported and 18 months since we were told "engineers are aware of this" but still no fix.  I feel stupid I wasted so much time troubleshooting and documenting in detail the problem for you.  I'm assuming at this point this model is abandoned in terms of significant updates.

 

This was my first high-end router purchase (previously always went with the $35.00 on-sale models) and was expecting a lot more in terms of quality and support considering the huge premium price.  I won't be purchasing Netgear in the future.


 


My Setup (Cable 900Mbps/50Mbps)>CAX80(Modem Mode)>RBK853 v3.2.16.6(Router Mode)

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 24 of 28
Highlighted

Re: DNS not working with IPv6 - R7000

Hi,

I've contacted her, but nothing changed
Message 25 of 28
Top Contributors
Discussion stats
  • 27 replies
  • 14351 views
  • 22 kudos
  • 11 in conversation
Announcements