Reply

DNS works on LAN but not WIFI

fmiranda
Luminary

DNS works on LAN but not WIFI

Hello everyone, 

 

Trying to understand what is happening in my setup, let me know if you ahve any suggestions:

 

I have a AT@T modem setup as bridge connected to my Netgear R7800. That means my 7800 gets the "ISP IP provider" and since the device is setup as a router, it provides access to the Internet to all my other devides on my network. (so far so good).

 

I decided to disable the DHCP service from the Router, as it would not allow me to provide advanced features like TFTP server and other things to provide PXE boot. So I decided to use a Linux box that I have on my network connected to the 7800 as my DNS server as well as my DHCP server. 

 

Everything works great when I'm connected to the LAN. All my other devices connected to the LAN can resolve internal DNS names as well as external. (everything good so far)

 

The issue is when using devices connected to the WIFI. If I use IP, I can reach any internal device, no problems. If I use names for external access, like google.com, or any other Internet related access, I can use names. If I try to use DNS names from my internal network it does not work.

 

Example: 

 

Ping server1.local does not work. Ping 192.168.1.20 (the IP of the server1.local) it works. 

 

I used a laptop to try to debuf this problem, tried the SAME network configurations on WFI and LAN. on WIFI cannot use internal name resolution, on LAN it works great. 

 

I also tried on both wifi and LAN setup the network on my client using manual confguration instead of relaying just on the DHCP server (which works flawless), but no success. 

 

Any idea how to solve this ? 

 

Thank you,

 

Model: R7800|Nighthawk X4S AC2600 Wifi Router
Message 1 of 1
Top Contributors
Discussion stats
  • 0 replies
  • 244 views
  • 0 kudos
  • 1 in conversation
Announcements

Orbi WiFi 6E