Reply

Enable HTTPS for router admin

MrBuckley
Aspirant

Enable HTTPS for router admin

Is it possible to enable https for the router admin page? This post seems to indicate no but perhaps something has changed in two + years?

If not, is it possible to disable wireless administration? 

 

Nighthawk X4S R7800

firmware 1.0.2.46

Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 1 of 9

Re: Enable HTTPS for router admin


@MrBuckley wrote:

Is it possible to enable https for the router admin page? This post seems to indicate no but perhaps something has changed in two + years?

 

This is happening in new firmware. I haven't looked lately at my R7800, which sits on shelf, but I have a feeling that this now has that feature. But that may have have been the "non-standard" beta fiirmware I was on.

 

But this issue may be something of a red herring. Remote access does use https. It is only local control, which goes nowhere near the Internet, that has this "failing".

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 2 of 9
MrBuckley
Aspirant

Re: Enable HTTPS for router admin

Hi michaelkenward

 

Thank you for the response!  Yes, you're correct that remote access uses https.  While it may be a red herring, it would be nice to have the option to use https for local access or at least disable wireless administration.  In todays world, I only see a benefit to making these options available as a means of further risk mitigation.

 

Is it possible to file a feature request for Netgear firmware?

 

Thanks again.

Message 3 of 9

Re: Enable HTTPS for router admin


@MrBuckley wrote:

 

Is it possible to file a feature request for Netgear firmware?

 


Too late. It was requested years ago.

 

Idea Exchange For Home - NETGEAR Communities

 

Here's one of them:

 

Modems/Routers : Add HTTPS when connecting to the ... - NETGEAR Communities

 

This may or may not be why Netgear is introducing this gradually. Some devices have https already.

 

Perhaps I will dig out the R7800 I have and check that. Maybe it was only when I was using it as a beta platform for something else.

 

 

 

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 4 of 9
JamesGL
Master

Re: Enable HTTPS for router admin

Message 5 of 9
JamesGL
Master

Re: Enable HTTPS for router admin

Hi MrBuckley,

 

We’d greatly appreciate hearing your feedback letting us know if you need further assistance.

Message 6 of 9
MrBuckley
Aspirant

Re: Enable HTTPS for router admin

Hi JamesGL,

 

Thank you for the response!  Are you suggesting that I try this firmware?  If so, it doesn't appear to be for the correct model...  Can you confirm it will work on my specific model?  Is there an interoperability matrix I can reference?

 

Thank you.

Message 7 of 9

Re: Enable HTTPS for router admin


@MrBuckley wrote:

Hi JamesGL,

 

Are you suggesting that I try this firmware?  If so, it doesn't appear to be for the correct model...  Can you confirm it will work on my specific model? 

 

Firmware does not carry over between different models.

 

You have to stick to the firmware for your model. It will not accept something written for different hardware.

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 8 of 9
MrBuckley
Aspirant

Re: Enable HTTPS for router admin

Hi michaelkenward,

 

I was thinking that might be the case.  Given that, I'm not sure what JamesGL is suggesting.

 

Thanks.

Message 9 of 9
Discussion stats
  • 8 replies
  • 10977 views
  • 0 kudos
  • 3 in conversation
Announcements