Reply

Flashing Firmware from ExpressVPN to Netgear Factory Settings Not Working

TimHortons
Follower

Flashing Firmware from ExpressVPN to Netgear Factory Settings Not Working

Unable to flash current R7000 firmware successfully. Firmware reverts back to ExpressVPN GUI no matter what.

Tried the following:

  • dowload latest Netgear firmware for R7000 "...2.88zip", go into load new firware via express VPN admin GUI, Rotuer appears to accept the zip file, then I verify and it loads the firmware. Once rebooted it returns to the EXpress VPN GUI when using the local IP or the routerlogin.net
  • hard reset by holding in the reset button 6 seconds
  • turn off, turn on, wait 6 seconds, repeat 5X
  • Express VPN instructions followed from website and chat, they are unable to resolve and told me to load firmware via TFTP

As a last resort it was advised to try and load the firmware via TFTP but the link for Mac (provided my Netgear) does not work with the latest MacOS Catalina. So, that is not a good option.

 

Any ideas how to return this Nighthawk R7000 to factory firmware? It refuses to do so and always returns to the ExpressVPN GUI. ExpressVPN is unable to reslove this issue.

Anyone able to give me manual instructions to load firmware via TFTP. I read some of it and it looks like an aweful way to proceed as I am not a programmer that loves working in the unfriendly text-coding-interface.

 

THanks in advance if you have a good solution.

Model: R7000|AC1900 Smart WIFI Router
Message 1 of 2
antinode
Guru

Re: Flashing Firmware from ExpressVPN to Netgear Factory Settings Not Working

> dowload latest Netgear firmware for R7000

 

   Regarding R7000 firmware in particular, "latest" and "best" are
spelled differently for a reason.  A Web or forum search for your actual
firmware version might find some interesting facts and/or sugestions.

V1.0.9.42_10.2.44 might be a better choice than "latest".

 

   Did you read the instructions in the Release Notes?

 

> [...] Rotuer appears to accept the zip file, [...]

 

   I'd try sending the .chk" (firmware image) file to the router, not
the whole ",zip" archive.

 

> [...] the link for Mac (provided my Netgear) does not work with the
> latest MacOS Catalina. [...]

 

   If you want to try the TFTP recovery scheme, then use the built-in
command-line TFTP client program, not some (obsolete) third-party TFTP
client program.  See, for example:

 

      https://community.netgear.com/t5/x/x/m-p/1622096#M102004

 

> [...] I read some of it [...]

 

   You read some of _what_, exactly?

 

: [...] it looks like an aweful way to proceed as I am not a programmer
> that loves working in the unfriendly text-coding-interface.

 

   You do have a working keyboard, right?  What, exactly, is the
difficulty?

Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 950 views
  • 0 kudos
  • 2 in conversation
Announcements