Reply

Re: Horrible Netgear Support

alltelagent32
Follower

Horrible Netgear Support

First, let me say that I am not one to usually post on a community forum, but after just getting off the phone with Netgear support I was compelled to write this. I have a Netgear Nighthawk R7000P wireless router that I’ve been using for about 8 months now. Over the past 3 months the 5.0GHz radio has been malfunctioning. The 5.0GHz radio would stop working, therefore all devices on that band would disconnect. After power cycling the router, the radio would work for about another 24 to 48 hours, then would stop working again. I of course checked for firmware updates, reset the router to factory settings (knowing full well this was not a configuration issue), all that non-sense and finally after putting up with this issue for nearly 3 months, the 5.0GHz radio stopped working for the last time. Power cycling the router did no good and after reading other online forums, I learned that I am not the only one experiencing this issue. I was forced to move all my devices to the 2.4GHz SSID. Against my better judgement, I decided to call Netgear customer service. I waited on the phone for approximately 5 minutes before my call was taken. The support representative asked for the serial number of my device, then confirmed my contact information and finally inquired about the color of the LED lights on the wireless router. I patiently complied with all his requests, but as soon as I told him the LED lights were all white, he immediately attempted to dismiss my issue and sell me their “Gearhead” support. He insisted that this was not a hardware issue and that I must pay for Gearhead support if I wanted additional troubleshooting to determine hardware failure. Netgear provides a standard 1-year hardware warranty on their wireless routers. I simply do not understand how they can definitively determine hardware failure based upon whether the LED is amber, red or white (I get that the whatever Linux kernel the router is running is executing some sort of script or daemon to perform diagnostics to determine the color of the LED.). This is highly inappropriate for Netgear to trap their customers into purchasing their “Gearhead” support to determine if hardware failure has occurred and yet they claim to have 1-year hardware warranty. I guess you can only utilize that 1-year hardware warranty after you pay $89 (minimum) to layer on their 6 months of “Gearhead” support. I realize that their consumer support must set some novice technical baseline of their customers and I respect their policies and procedures, but to completely dismiss their customers is unacceptable. That said, this would have to be the worst customer service experience that I’ve ever had, and I will NEVER purchase a Netgear product so long as I live.

Model: R7000P|Nighthawk AC2300 Smart WiFi Dual Band Gigabit Router
Message 1 of 4

Re: Horrible Netgear Support

This place provides free support.

 

 

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 2 of 4
Helam
Initiate

Re: Horrible Netgear Support

Just want to add my voice to this.

I have an Orbi router that started acting up recently until it just plain stopped working altogether. I have had the product for 7 months. Before calling support I spent several hours troubleshooting the issue myself, following various steps outlined on netgear's support site as well as the forums here, including several different methods of resetting the router to factory settings. None of the steps worked, the router wouldn't reset, it could not be accessed from a browser, giving a "500 Internal Server Error". 

Eventually I gave up and called support. I was asked about the status of 2 different LED lights and then immediately told it was not a hardware issue and that I would need to purchase a support contract (minimum $90, auto-renewing) before they could do anything else to help me.
Suppressing my outrage at this ridiculous and greedy policy, I asked if there would be a refund available if they were still unable to fix the product after purchasing the contract. They said yes, so I purchased the contract.
I then proceeded on a 1.5 hour call with the support technician to go through all the steps that I had done on my own earlier that day, trying and retrying all the different troubleshooting steps with no results. The technician said he needed to discuss the issue with his team and that they would call me the next day.
They did not call me the next day.
2 days later I called again and a different technician had me retry some of the same steps again. I said I believed the product was broken and asked if it could be returned and refunded or replaced. I was told that I could not return the product for a refund but that I could get a replacement.
The RMA process was started and I had to pay another $30 for advance next-business-day shipping so that I could get the replacement as soon as possible (I work from home and having internet access is vital).
The technician told me that my payment was received and that everything was good to go and that I should receive my replacement within 24-48 hours.
48 hours later when I did not have the product still I discovered an additional email had been sent after my most recent call to request that I upload a photo of the serial number on my product as proof that I actually have it. The email had a broken link to login to a page where I do not have an account, and alternatively, a follow up link to update the case without an option to upload any photo.
I called support again and got assistance with uploading the photo and was told it may take some time to process and continue with the RMA process.
Hopefully I will have my replacement soon but it will still be several days after I was told (and after what I paid for) and results in a huge pain because of the lack of a working product for so many days.
I will be getting a refund for the support contract ($90) but the fact that I had to pay for it in the first place (and then work to get a refund) is not exactly a great customer experience.
To be clear, every individual I spoke with was kind and professional and did a good job (except for not calling me back, and someone deciding to put my RMA process on hold after I was told it was good to go), but the "support" policies in place are ridiculous and only serve to push customers away and give NetGear a bad reputation. It makes the company seem greedy and puts a bad taste in the mouths of customers. I have since spoken to others about this and several people have said things along the lines of "Oh yeah, I could have told you about that before you bought NetGear, their support policies are awful."
I have definitely learned that I should investigate a company's support policies before buying their products in the future. I hope that this gets to someone who cares and that can make a difference, because I'm sure someone thinks that these policies are great and will make you guys a bunch of money, but in the long run I think you will only lose customers because of the terrible customer experience. Regardless of how reliable (or not reliable) the products are, anyone who comes into contact with these policies will lose trust in the brand altogether.

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 3 of 4
Helam
Initiate

Re: Horrible Netgear Support

Update: 1 week later, still no replacement. I call and ask why and they said the attached file is a zip file and that they need an image file. The file upload clearly says it supports zip files. The agent from last week checked the attachment I uploaded while I was on the phone and said it was fine and that it was good to go now! If this really was the hold up, nobody told me. The ticket status is "Awaiting agent action". I upload another image while on the phone and then he says "I don't see proof of purchase." but the ticket only requested a photo of the serial number to proceed with the RMA process. Supposedly my ticket has been "escalated" again. I asked to speak with management and was told that was not necessary because it was already escalated with priority. I asked to speak with them anyway and was put on hold for a minute before being told that no resources were available to speak with me and was then told to have a nice day.

 

I wonder if the higher-ups know how bad their support system is. I'm never buying NetGear again, and I'll steer anyone who asks FAR away from it as well. It's sad because I don't really have a problem with the products, just the way they "support" (if I could make those quotes bigger I would) the products.

Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 328 views
  • 5 kudos
  • 3 in conversation
Announcements