Reply

I can't connect to my new R6400 router, even though I get internet by connecting directly to modem

sadelbrid
Initiate

I can't connect to my new R6400 router, even though I get internet by connecting directly to modem

I just moved into my new place and I have Xfinity. I chose not to pay $15+/month for their modem and router, so I bought a CM700 modem and R6400 Nighthawk router. I activated my modem via Xfinity and I get internet by tethering directly to the modem. When I connect the router to the modem, I get all white lights. This indicates that it has an internet connection from the modem. However when I tether to the router, Windows 10 indicates that it can't identify the connection and that it can't connect. Similarly when I try to connect to the WiFi network, my phone says it can't obtain the IP address.

 

I've been troubleshooting all day with no luck. I've tried resetting my modem and routers. I've reset my modem while my router was connected and my PC tethered to the router (someone suggested this could fix a MAC address issue with the modem). I've gone through the Nighthawk app setup guide several times. I've even tried swapping the cable between the modem and router. I'm at a loss. It's frustrating that the unit indicates that it has internet connection, but none of my devices can connect. Any help would be appreciated. I work from home so I need this figured out this weekend.

Model: R6400|AC1750 Smart WiFi Router
Message 1 of 3

Accepted Solutions
sadelbrid
Initiate

Re: I can't connect to my new R6400 router, even though I get internet by connecting directly to mo

I figured out a solution, though I don't know what the actual techinical problem was. To get internet access, you need to tell Xfinity that you have a new network connected by going to xfinity.com/activate. I had done this several times with my computer tethered to the modem and no router connected. This was always successful, but when I hooked the router up, I couldn't connect (even though the router showed a white internet LED). I decided to hook everything up how I wanted it before I went to the activation link: router connected to modem and computer tethered to the router. Then I got on my laptop and went to xfinity.com/activate using my phone's hotspot. I went through the activation process one more time and then my router started working (ethernet and WiFi).

View solution in original post

Model: R6400|AC1750 Smart WiFi Router
Message 3 of 3

All Replies
it_geek
Guide

Re: I can't connect to my new R6400 router, even though I get internet by connecting directly to mo

Would appreciate if you can provide screenshots of the errors as well. Use imgur as the image host.

Proud Owner of an R8000 since August 2014!
Message 2 of 3
sadelbrid
Initiate

Re: I can't connect to my new R6400 router, even though I get internet by connecting directly to mo

I figured out a solution, though I don't know what the actual techinical problem was. To get internet access, you need to tell Xfinity that you have a new network connected by going to xfinity.com/activate. I had done this several times with my computer tethered to the modem and no router connected. This was always successful, but when I hooked the router up, I couldn't connect (even though the router showed a white internet LED). I decided to hook everything up how I wanted it before I went to the activation link: router connected to modem and computer tethered to the router. Then I got on my laptop and went to xfinity.com/activate using my phone's hotspot. I went through the activation process one more time and then my router started working (ethernet and WiFi).

Model: R6400|AC1750 Smart WiFi Router
Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 1080 views
  • 1 kudo
  • 2 in conversation
Announcements

Orbi WiFi 6E