IPad unable to access internet after connecting to Wi-Fi (R6350)

For 6 months my IPad worked well with the R6350 (AC1750) router until recently when it stopped accessing internet even after connecting to the Wi-Fi network. The IPad conneccts but cant access internet. (all other devices at home can access though). Interestingly, the same IPad  connects and works well with a Wi-Fi repeater though, but not with the primary router (R6350 - AC1750).

The router seems ok, because many other devices are functioning ok on the same network/channel. 

Tried the following :

  1. Power recycle on IPad, Router 
  2. Network setting reset on IPad
  3. Renaming of Network
  4. Forget Network and reconnect


Help please !




Model: R6300v2|AC1750 Dual Band Gigabit router
Message 1 of 3
NETGEAR Moderator

Re: IPad unable to access internet after connecting to Wi-Fi (R6350)

Do you have the repeater named exactly the same as the router? that could be the issue its trying to use the settings for the repeater when connecting to the router.



Message 2 of 3

Re: IPad unable to access internet after connecting to Wi-Fi (R6350)

Thank you ! The repeater and router have different names. I was able to fix the issue.. Which was because of the router automatically blocking the device. Strange that it did that! Despite unblocking multiple times, the router would block the device. Eventually, it accepted the request and unblocked. All is well. Curious though in why the router self blocked three device in first place.. Any help there?
Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 0 kudos
  • 2 in conversation