Reply

Mobile devices slow on Nighthawk R7900

jrivera
Initiate

Mobile devices slow on Nighthawk R7900

I noticed all of my mobile devices have slow internet speeds.. Both up and download speeds. However my MacBook and Dell XPS both reach download speeds above 110Mbps. I even tried testing my download speed on a relative's wifi network and was able to achieve speeds above 100Mbps on the first test. 

 

I'm running dual band on my router and both are producing slow speeds. 

 

Testing results on 5G

MacBook - 115.50Mbps

IPhone X - 25.64Mbos

IPhone 5s - 21.80

IPad 3rd Gen - 24.55

 

Testing results on 2G

MacBook - 53.85Mbps

IPhone X - 4.30Mbps

IPhone 5s - 16.60Mbps

IPad 3rd Gen - 4.64Mbps

 

Is anyone else experiencing slow speeds like this on their mobile devices? I've also reset my router and network settings on my devices. At a loss here.. Any help would be highly appreciated!

Model: R7000P|Nighthawk AC2300 Smart WiFi Router with MU-MIMO
Message 1 of 4

Accepted Solutions
jrivera
Initiate

Re: Mobile devices slow on Nighthawk R7900

Thanks for replying and your suggestion. I attempted to reset my router again for the second time and it seemed to have helped my issue. For some odd reason I didnt see a change and encountered the same behavior after the first reset but after the second the speed was increased and is operating as it should. 

View solution in original post

Message 4 of 4

All Replies
JamesGL
Master

Re: Mobile devices slow on Nighthawk R7900

Hi jrivera,

 

Try changing the channel of your wireless network.

Disable QoS.

Message 2 of 4
JamesGL
Master

Re: Mobile devices slow on Nighthawk R7900

Hi jrivera,

 

We’d greatly appreciate hearing your feedback letting us know if you need further assistance.

Message 3 of 4
jrivera
Initiate

Re: Mobile devices slow on Nighthawk R7900

Thanks for replying and your suggestion. I attempted to reset my router again for the second time and it seemed to have helped my issue. For some odd reason I didnt see a change and encountered the same behavior after the first reset but after the second the speed was increased and is operating as it should. 

Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 1639 views
  • 1 kudo
  • 2 in conversation
Announcements

Orbi WiFi 6E