Reply
Highlighted
Tutor

Re: Netgear Nighthawk R8000 X6- not getting full speed

Reposting -

 

Hi All,

 

I just wanted to note that I have seen this issue discussed on several boards, but everyone continues to point at QoS. While QoS seems to be a factor, and as stated by some others, really isn't necessary with speeds >200 anyway, I would suggest that having a look at access control may help if disabling QoS didn't solve the problem. I have tested this myself and found that by enabling Access Control, LAN speeds are significantly affected. My ISP provides my with 250 and external speed checks from the router confirm this. However, from my devices (LAN) I only see approximately 130 after enabling Access Control, once disabled, back to normal.

 

Hope this helps someone!

 

Marc

Message 26 of 37
Highlighted

Re: Netgear Nighthawk R8000 X6- not getting full speed


@Marc-V wrote:

I have tested this myself and found that by enabling Access Control, LAN speeds are significantly affected. My ISP provides my with 250 and external speed checks from the router confirm this. However, from my devices (LAN) I only see approximately 130 after enabling Access Control, once disabled, back to normal.

 

In addition to QoS and Access Control, it seems that anything that puts a strain on the processor can cause the slowdowns.

 

Another one that has been implicated, although perhaps not as thoroughly tested as you have achieved, is traffic metering.

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 27 of 37
Highlighted
Initiate

Re: Netgear Nighthawk R8000 X6- not getting full speed

I did a back flash to a lower firmware and then updated to lastest. 

 

worked 

Model: R8000|Nighthawk X6 AC3200 Smart WIFI Router
Message 28 of 37
Highlighted

Re: Netgear Nighthawk R8000 X6- not getting full speed


@adam1023 wrote:

I did a back flash to a lower firmware and then updated to lastest. 

 

worked 


Neat.

 

Sometimes just flashing with the latest will work.

 

But a "backflash" could be a useful tactic for some people.

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 29 of 37
Highlighted
Aspirant

Re: Netgear Nighthawk R8000 X6- not getting full speed

I had the exact same issues you had. Bought the Nighthawk AX45 instead of Spectrum's. Got better speed. Thought i'd upgrade to 400 mbps. I get 480 mbps from the modem and only 240 out of the router. So, I returned it and bought the Nighthawk AX8! Does the exact same thing, excet it only clocks 160mbps on wifi. Hits 320 mbps on wired. I am so frustrated I could throw it out the window. And don't get me started on Customer Service!!

Message 30 of 37
Highlighted
Aspirant

Re: Netgear Nighthawk R8000 X6- not getting full speed

Dude! You are a life saver!!! I have gone through all the settings on this post, and nothing fixed my issues until I turned off Traffic Metering. I'm fairly certain that is the setting that I turned off and my d/l speed went from 300 to 900. Thank you!!!

Message 31 of 37
Highlighted
Aspirant

Re: Netgear Nighthawk R8000 X6- not getting full speed

Bought this router a couple weeks back and was running really great. A few days later updated the firmware to 

1.0.4.58 and didn't think too much about it.  Then noticed speeds were only going to 180Mb when I get 350Mb. Was doing this on wired too.  After spending ages turning of certain options/features I eventually downgraded the firmware to the previous version and it was all back to normal.

 

Word of warning Firmware Version 1.0.4.58 is completely screwed for speed.  I heard this happened before.  Why would Netgear keep screwing up like this.

 

Rolling back to 1.0.4.52 and it's all working fine.

Model: R8000|Nighthawk X6 AC3200 Smart WIFI Router
Message 32 of 37
Highlighted
Aspirant

Re: Netgear Nighthawk R8000 X6- not getting full speed

yes!!! disabled access control and I got my spectrum 440mpbs. you rock!!! I'm running on the latest firmware Firmware Version
V1.0.4.58_10.1.72

Message 33 of 37
Highlighted
Tutor

Re: Netgear Nighthawk R8000 X6- not getting full speed

You are very welcome! Happy downloading!
Message 34 of 37
Highlighted
Initiate

Re: Netgear Nighthawk R8000 X6- not getting full speed

Thank You all you helped me troubleshoot my problem. Well I discovered "ACCESS CONTROL" Was Bottlnecking my speeds. I am supposed to get 1000mbs download and 35mbs upload <--Streamer and gammer here. So far I went from 600 to 300 download speed when I upgraded with COX gigablast for $80 a month. Virginia, Portsmouth area. I used to have 300mbs download in Viriginia Beach before I moved and 30mbs upload. When I moved to Portsmouth They upgraded me to 700mbs download but capped me at 10mbs upload Smiley Sad So they said the gigablast will give me more upload. So finally they connected it and I started to get 600mbs and not the 1000... They explained they are fixing that eventaully ... wtf so my router had me capped at 350mbs..

 

WHEN DOING A SPEEDTEST: make sure to connect to Atlanta Georgia when you do a speed test or your nearest populated city. I found the COX servers near me are capped at 10mbs upload which is highley suspecious server activity (I have tested the upload delima in two virginia cities and I get the same numbers). So I switched to atlanta Georgia which is far away and BOOM! I got 36mbs upload. Eventually my goal is to upgrade to the new $500 Nighthawk router but I heard it also has its own issues and firmware problems. this R8000, the CPU is slow but it does do the trick. 

Model: R8000|Nighthawk X6 AC3200 Smart WIFI Router
Message 35 of 37
Highlighted
Initiate

Re: Netgear Nighthawk R8000 X6- not getting full speed

I had Cox Communication Tech Just now today. He came in with his handheld computer and he ran a test directly from the wire and it is showing me I am at 1000.06 mbs  download and 36 mbs upload. I ran a speed test off of his Computer because he has an eithernet out jack and I did a speed test and once again I was only getting 500 mbs, Not from my modem or router. So guess where the problem is? It is my computer! I have not tried restarting my computer in Safemode With network because I know the answer already! It is my onboard Eithernet adpter ont he motherboard. I am going to see if there is an update to the realtek eithernet. I could just buy a high quality one and put in one of the ports. Now I know it is not my router with slow speeds! It is my computer. I think it is time to reinstal windows 10 and start over. Erase everything and only installing what I need helps a lot since I have done many times before. IU hope this helps people to troubleshoot their Router and in hopes to look at other avenues beyond the router. Hell you never know any of your components could have eithernet problems. 

Model: R8000|Nighthawk X6 AC3200 Smart WIFI Router
Message 36 of 37
Highlighted
Tutor

Re: Netgear Nighthawk R8000 X6- not getting full speed

Hello all,

I've been reading through this after realizing that AT&T gigbit fiber was actually providing me full gig but it was my router that was causing the up and down speeds to cap at about 300 mbps.  

Today, I tried EVERYTHING suggested through here:

  • QoS off (already was)
  • Access control off (alread was)
  • Wired (duh)
  • Parental controls (all off)

Today, I updated to the latest firmware V1.0.4.62_10.1.74 and still wasn't getting above 300 mpbs.  Finally, I went to the QoS settings section and even though Dynamic QoS is off, I can still run the speed test from there and the option to "Let Speedtest detect my Internet bandwidth" was selected.  I selected the other option, I want to define my Internet Bandwidth and applied this. It still shows the "let speedtest detec" option checked, but now I'm getting way closer to my max speed.  I'm getting over 600 mbps, but it's a busy time of day so that's acceptable, and almost double what I had been getting!

Hope this helps.  Good luck, speed demons.

Model: R8000|Nighthawk X6 AC3200 Smart WIFI Router
Message 37 of 37
Top Contributors
Discussion stats
Announcements