Discussion stats
  • 22 replies
  • 4013 views
  • 2 kudos
  • 8 in conversation
Announcements

Top Contributors
Reply
Highlighted
Aspirant

Netgear R7800 Problem with new Firmware 1.0.2.60

Hello Together

 

Why have I problem with the new Firmware? Every 5-10 minutes I have short internet breaks. Playing online games with the new firmware is impossible. 
If I get the previous Firmware (example: 1.0.2.38), it works. Does have someone a solution?

 

Thanks for the feedbacks.

 

With kind regards

Michael

Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 1 of 23
Highlighted

Re: Netgear R7800 Problem with new Firmware 1.0.2.60

Did you reset the router to factory settings after the firmware flash?

New firmware sometimes introduces changes that are not compatible with the old configuration.

So while it isn't guaranteed to fix problems a factory reset is the first thing to try if you have issues with new firmware.

This is a nuisance because you then have to reconfigure the device all over again.

You can backup your settings before you reset and restore them later. But that may just bring back the fault. Then again, at least you will know if the reset fixed the problem.

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 2 of 23
Highlighted
Aspirant

Betreff: Netgear R7800 Problem with new Firmware 1.0.2.60

Thank you for your answer.


I have already come up with this idea. Unfortunately it did not work. I took a pen and put in the small hole to reset the router. It did not work either. Smiley Sad

Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 3 of 23
Highlighted
Aspirant

Betreff: Netgear R7800 Problem with new Firmware 1.0.2.60

I'm having the same issue. 5GHz line. And I just bought the router so updated shortly after turning it on, and I thought this was some hardware fault. I might dial back to a previous version or try dd-wrt... REALLY annoying!

Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 4 of 23
Highlighted
Aspirant

Re: Netgear R7800 Problem with new Firmware 1.0.2.60

1.0.2.58 has the same 5GHz speed problem as .60.  .52 is your best bet.

Message 5 of 23
Highlighted
Luminary

Re: Netgear R7800 Problem with new Firmware 1.0.2.60

Yes .. .58 and .60 have this issue..  Install 1.0.2.52  and you should be fine.   

 

NetGear I hope is aware of it now..but these versions are  still up there.. it is confounding.   Havoc4421 if you get a support case also tell them  that they should take  .58 and .60  off site so people dont download.   I surmise anyone that is buying a R7800 may return it with

these firmwares for refund and go with another brand.

Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 6 of 23
Highlighted
Aspirant

Re: Netgear R7800 Problem with new Firmware 1.0.2.60

Yeah, I opened a ticket and so far only got the usual bs response from them asking to reset the router etc (classic blame the user strategy). I did revert to v52 and now everything is snappy.
Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 7 of 23
Highlighted

Re: Netgear R7800 Problem with new Firmware 1.0.2.60


@havoc4421 wrote:
 got the usual bs response from them asking to reset the router etc (classic blame the user strategy).

 



For the benefit of anyone else who finds this discussion that reset response has nothing to do with "blame the user".

 

Quite the opposite. It is an admission that Netgear's code – like that of all firmware writers it seems – is not smart enough to carry over all the settings without risk of damage. The odd thing is that while the factory reset is more a "witchcraft" move than a technically informed solution, it does seem to fix problems sometimes, especially on the wifi front.

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 8 of 23
Highlighted
Aspirant

Re: Netgear R7800 Problem with new Firmware 1.0.2.60

Fair enough. But in this case, just flashing back from 60 to 52, without even reverting to factory settings (so kept my WiFi passwords etc) immediately solved the connection/speed issues.
Message 9 of 23
Highlighted
Luminary

Re: Netgear R7800 Problem with new Firmware 1.0.2.60

Thanks.. my netgear support person did not suggest I do a factory reset.    Based on what I've read here it does not seem it make a difference.

I will say at least we have firmware to revert back to..   I was reading some other router manufacturers forums and some have not updated their firmware in a year..they dont even try to fix things..

Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 10 of 23
Highlighted

Re: Netgear R7800 Problem with new Firmware 1.0.2.60


@RMinNJ wrote:

Thanks.. my netgear support person did not suggest I do a factory reset.    Based on what I've read here it does not seem it make a difference.



I don't know what uncited reports you have read, but that statement is nonsense. There are plenty of examples of issues evaporating after a reset.

 

If you don't want to fix problems, fine.  But anyone else who wants to debug their R7800 should investigate all suggestions, including factory reset.

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 11 of 23
Highlighted
Luminary

Re: Netgear R7800 Problem with new Firmware 1.0.2.60

@michaelkenward

You are absolutely right.. when I get a block of time I will write down all my settings,  back them up and do a resejt..

I simply havent done it as I asked and my netgear support person said no.     Screenshots and logs were taken,  some settings tried..  (cranking down 5Ghz  to "up to 800Mbps"    (half the rate) is the only setting that fixed it..  but not really acceptable.   

 

Do you reccommend typing everything back in manually or loading the backup file?

 

 

 

Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 12 of 23
Highlighted

Re: Netgear R7800 Problem with new Firmware 1.0.2.60


@RMinNJ wrote:

@michaelkenward

You are absolutely right.. when I get a block of time I will write down all my settings,  back them up and do a resejt..

 

Screenshots take seconds.

 


 

Do you reccommend typing everything back in manually or loading the backup file?

 


 

A backup file misses the whole point.

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 13 of 23
Highlighted
Luminary

Re: Netgear R7800 Problem with new Firmware 1.0.2.60

You can factory reset till the cows come home but it won't fix the issues with .58/60 firmware. So suggest you don't waste your time. Going back to .52 or using Voxel's firmware is your option at this point. Till IF and WHEN Netgear comes out with a fix. 

Asus RT-AX58U. Merlin 384.18_Alpha 1
(AT&T Fiber, Gigabit)
Message 14 of 23
Highlighted
Luminary

Re: Netgear R7800 Problem with new Firmware 1.0.2.60

@James721

 

Thanks.  

 

I will say though if I have time I'll try as its perplexing that netgear could not reproduce the problem..they , I assume, loaded my backup.cfg file onto their factory reset R7800 (their not going to type all my settngs in).. and said they did not see the issue. But I can see the packet loss in as little as 400 ping packets on the 5Ghz.    A factory reset seems it would get my unit closer to where they started.  The problem just seems so obvious..how could they possibly not see it...

Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 15 of 23
Highlighted

Re: Netgear R7800 Problem with new Firmware 1.0.2.60


 

The problem just seems so obvious..how could they possibly not see it...

 


Too many variables. Too many unknowns.

 

We all have different network setups. ISPs are notoriously different in how they implement things. If it was that easy to spot issues, the first tests on new firmware would find them.

 

Anyone who has ever participated in beta tests of new routers will have tales of a small of unpaid band of extremely enthusiasts trying to break things as they attempt to pin down what is going on while Netgear's propeller heads do their thing. (I acquired my R7800 in beta tests of new router firmware for a different box. Such fun and games.)

 

This is why I pay little attention to ignorant claims that the people who write firmware are incompetent and don't care. Nothing could be further from the truth.

 

Whether the techies have the resources it takes to fix things is another matter.

 

 

 

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 16 of 23
Highlighted
Aspirant

Re: Netgear R7800 Problem with new Firmware 1.0.2.60

Just got this response from support - once I'm back from holiday next week I might reflash to 60 and try this, even though I might keep MTU at 1500 as I know this works best for my ISP:

 

Kindly follow the steps below and check it once:

1. On the NETGEAR genie page, please select Basic tab>>Wireless, change the Channel to 9 for 2.4GHz, 161 for 5GHz and click on Apply.

Please select Advanced tab>>Advanced Setup>>Wireless Settings, change the Fragmentation to 2338 and CTS/RTS to 2339 and click on Apply.

Please select Advanced tab>>Setup>>QOS, uncheck the WMM settings and click on Apply.

Please select Advanced tab>>Setup>>WAN, change the MTU value to 1468 and click on Apply.

After applying all the settings, please select Advanced tab>>Advanced Home and click on Reboot and observe the connection for next 2-4 hours with this setup.

Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 17 of 23
Highlighted
Luminary

Re: Netgear R7800 Problem with new Firmware 1.0.2.60

Right...  but why doesn't 1.0.2.52 need all these settings?   Why does the MTU suddenly

need to be different? 

 

 

Not sure I would be changing my MTU that has worked with my ISP for years.

 

I have .52 loaded on the router now.. in my advanced setup->wireless settings  I 

see the CTS/RTS set to the maximum 2347 but I have no Fragmentation settings.

So I would change the Fragmentation value in this solution first...perhaps it is new, introduced with the newer firmware ?

 

My WMM is on for 2.4 and 5.0.   I assume disabliing this is meant as a troubleshooting measure...not a final solution.

 

 

 

 

 

Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 18 of 23
Highlighted
Aspirant

Re: Netgear R7800 Problem with new Firmware 1.0.2.60

I had a look at Voxel's firmware changelog and they did roll back some bits of code to v52 levels due to wifi connectivity issues. Guess if they picked that up, so should Netgear...

 

1.0.2.60SF:

1. Partial rollback: integrated binaries and kernel objects from the stock 1.0.2.58 are reverted back to 1.0.2.52
   (except net-cgi, trafficmeter, ookla, greendownload) to avoid probelms with Wi-Fi stability.
2. expat package is upgraded 2.2.5->2.2.6.
3. at package is upgraded 3.1.20->3.1.23.
4. curl package is upgraded 7.61.0->7.61.1.
5. ethtool package is upgaded 4.17->4.18.
Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 19 of 23
Highlighted
Aspirant

Re: Netgear R7800 Problem with new Firmware 1.0.2.60

Is there another brand of router makers that I dont have to factory reset every time there is a router update? Its insane netgear thinks its ok for me to redo all my devices and settings. Between my smart home and multiple people in this house i have set up over 20 static IPs, and probably have 40+ devices on there. Im simply not willing to do this every time there is an update. 

Model: R7000|Nighthawk AC1900 Dual Band WiFi Router
Message 20 of 23
Highlighted

Re: Netgear R7800 Problem with new Firmware 1.0.2.60


@ConstantGamer wrote:

Is there another brand of router makers that I dont have to factory reset every time there is a router update?

 


Good question. From what I have seen, they are mostly the same. Visit a few of their support forums and see what they say.

 

In reality, most makers of network hardware buy the same chips from a handful of companies and tailor them for their boxes.

 

This is a constant complaint with a long running "feature request".

 

Playing around with my motherboard the other day, I found that it can export a text file with my settings. Why not routers?

 

If possible, avoid the reset. Don't get into it unless you experience post-flash problems.

 

 

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 21 of 23
Highlighted
Luminary

Re: Netgear R7800 Problem with new Firmware 1.0.2.60

Working with NetGear support I just tested some beta firmware and it looks like they found the problem..5Ghz has been stable.   Just loaded the firmware.   No factory reset was suggested or done for my entire support case

Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 22 of 23
Highlighted
Tutor

Re: Netgear R7800 Problem with new Firmware 1.0.2.60

Just downgraded my R7000 back to .42. Was having nonstop 5ghz issues even after a reset on .60 firmware.
Model: R7000|Nighthawk AC1900 Dual Band WiFi Router
Message 23 of 23