Reply

Re: Netgear ReadySHARE has been broken for 2 year now!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

OlegP
Apprentice

Netgear ReadySHARE has been broken for 2 year now!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Smiley MadSmiley MadSmiley MadSmiley MadSmiley MadSmiley Mad

 

The app has been nonfunctional for at least two years! As in, it 100% doesn't work on Windows 10. Seriously? How is this possible?

 

It didn't work when I used to own the Nighthawk XR500. Now I have the Nighthawk X6S and it still doesn't work!!!!

 

The app will launch but will not display neither the router nor any of the devices connected to it.

 

I tested this on three separate Windows 10 machines. Two of them running the latest 2004 build and the other running one build prior.

 

Is there an ETA to fix this? Netgear? Are you listening? Don't advertise the function then on your packaging if your crap doesn't work!!!! Don't include it on the boxes the routers ship in, because IT DOESN'T WORK!!!!

 

Smiley MadSmiley MadSmiley MadSmiley MadSmiley MadSmiley Mad

Model: R8000P|Nighthawk X6S AC4000 Tri Band WiFi Router
Message 1 of 8
OlegP
Apprentice

Re: Netgear ReadySHARE has been broken for 2 year now!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Any one else having issues with using a USB printer and the ReadySHARE app on their Windows computers?

 

Will Netgear acknowledge the issue or give an update on a potential fix?

 

Or am I just farting in the wind at this point?

Message 2 of 8
schumaku
Guru

Re: Netgear ReadySHARE has been broken for 2 year now!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Hi Oleg,
To avoid confusion we should talk about ReadyShare USB or as named in newer routers Netgear UBS (or was it Nighthawk USB?)

Just had a USB printer near to an R9000, so plugged it (no indication on the R9000 logs not anywhere else). Installed the USB utility on a current Win 10 (64 bit) ... and can't see anything in the utility screen.

Have tried both user as well as administrator mode btw. - no obvious difference here.

However, when changing the network (different. SSID, different LAN) the --R9000 shows up in red (so the bugware must have had something detected on the appropriate LAN).

The utility look and feel is more from 1990 than for Windows 10 - and then an App running in the foreground usermode instead as in the background and controlled in a different way

When I remember right, several users reported that the utility doesmrefuse to install/run on newer MacOS, too.

Appears 100% untested and non-maintained code. It's a shame ...
Message 3 of 8
schumaku
Guru

Re: Netgear ReadySHARE has been broken for 2 year now!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

@Christian_R  please 

Message 4 of 8
OlegP
Apprentice

Re: Netgear ReadySHARE has been broken for 2 year now!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Yes, it's definitely broken and has been like that for some time. I'm starting to really doubt that Netgear actually cares at this point to fix this feature anymore.

 

It's a damn shame.

Message 5 of 8
schumaku
Guru

Re: Netgear ReadySHARE has been broken for 2 year now!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Hello Oleg,

 

Wonders of Windows updates? Suspect related to the appearence of the recent cummulative update https://support.microsoft.com/de-de/help/4557957/windows-10-update-kb4557957 to Win 10 2004 Update something happened ...

 

After connecting to the R9000 with the USB sharing enabled, Windows requesed the installation of a "Kernel USB Software Bus by TCP" (why ever under Bluetooth and other devices, sigh...) and wonders of technology the USB Control Center started to show the USB devices on the R9000 here.... 

 

Kernel USB Software Bus by TCP all.PNG 

Message 6 of 8
schumaku
Guru

Re: Netgear ReadySHARE has been broken for 2 year now!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

@Christian_R  please ....

Message 7 of 8
schumaku
Guru

Re: Netgear ReadySHARE has been broken for 2 year now!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

@OlegP 

 

I think it should be rather easy to make it workable. The problem is that the drivers are not properly installed why ever. Lot of legacy and very old style driver kit was used by Netgear resp. the makers of NetUSB - and it was never reviewed and updated since 2013.

 

Try this:

 

  1. Use Windows Explorer and access the folder where the USB Control Center was installed, e.g. C:\Program Files (x86)\NETGEAR\USB Control Center
  2. Locate the NetUSB.inf file
  3. Right click the NetUSB.inf file, and choose "Install"
  4. Accept any security prompts related (if any)
  5. Expect a message stating that you have to reboot the system to finsih the driver install - Reboot
  6. After reboot, launch the Netgear USB Control Center App (it's not put to autostart by the installer)

Fingers crossed - enjoy!

 

NTGR USB Ctl Ctr.PNG

Message 8 of 8
Top Contributors
Discussion stats
  • 7 replies
  • 1135 views
  • 1 kudo
  • 2 in conversation
Announcements