Reply

Netgear Router R7900P - flaking out, slow menu, wireless not showing up

ngwtf
Aspirant

Netgear Router R7900P - flaking out, slow menu, wireless not showing up

I bought a netgear router r7900P ~2 months ago. Setup was relatively painless but I've been less than impressed with it's performance. The wifi connection is iffy across the house, but most recently what's happening is the admin netgear genie screen is *extremely slow*. It takes 5-10s to load a page (the spinning icon is shown during that time). Further, my main network: netgear32 is not showing up but the other networks: -1 and -2 are showing up. I tried rebooting the router but it didn't help. What happened? Is this wifi just a flaky router? Given the price I'm really surprised it's so unreliable. 

Model: R7900P|Nighthawk X6S Smart WiFi Router with MU-MIMO
Message 1 of 7
FURRYe38
Guru

Re: Netgear Router R7900P - flaking out, slow menu, wireless not showing up

What browser are you using? Try other browsers like IE11, FF or Opera to see if same thing happens. 

Be sure to disable any security or ad blocking plug ins in browsers before using the routers web page. 

 

Wireless and wired connections experience same thing? 

 

 

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)> RBK953(v6.0.3.68) & XR450(v130)
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, and WNHDE111
Message 2 of 7
ngwtf
Aspirant

Re: Netgear Router R7900P - flaking out, slow menu, wireless not showing up

Using Chrome. Other browsers do the same thing. Not sure about wired/wireless but tbh I don't really care. My main problem is that my primary 2.4GHz network isn't showing up. I've tried toggling SSIS broadcast, manually assigning channels, the whole bit. It started yesterday - no changes on my part. No interference from phones, or anything else. Are these netgear router's just flaky devices? 

Message 3 of 7
FURRYe38
Guru

Re: Netgear Router R7900P - flaking out, slow menu, wireless not showing up

Has a factory reset been performed to see if the 2.4Ghz radio shows up. 

Besure the SSID and Radio is enabled under Advanced/Advanced wireless settings. 

IF so, you might do a factory reset, load either same version FW or prior version FW using IE11 or FF browsers. Factory reset the router and set up the router. You might use the default wifi settings initially to see if the SSIDs appear. 

IF the 2.4Ghz does not appear on any devices wireless list using default SSID names, then the router maybe faulty. You'll need to phone connect with NG support. 


@ngwtfwrote:

Using Chrome. Other browsers do the same thing. Not sure about wired/wireless but tbh I don't really care. My main problem is that my primary 2.4GHz network isn't showing up. I've tried toggling SSIS broadcast, manually assigning channels, the whole bit. It started yesterday - no changes on my part. No interference from phones, or anything else. Are these netgear router's just flaky devices? 


 

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)> RBK953(v6.0.3.68) & XR450(v130)
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, and WNHDE111
Message 4 of 7
ngwtf
Aspirant

Re: Netgear Router R7900P - flaking out, slow menu, wireless not showing up

I'll just return this at Costco. I did a test with this supposedly "great" netgear router vs. my old, cheaper one and the bandwidth and range is nearly identical. Not sure what the nighthawk is doing but it sure is not helping my wifi home network. Quite disappointed. 

Message 5 of 7
FURRYe38
Guru

Re: Netgear Router R7900P - flaking out, slow menu, wireless not showing up

Have be a faulty unit.

 

Good Luck.

 


@ngwtfwrote:

I'll just return this at Costco. I did a test with this supposedly "great" netgear router vs. my old, cheaper one and the bandwidth and range is nearly identical. Not sure what the nighthawk is doing but it sure is not helping my wifi home network. Quite disappointed. 


 

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)> RBK953(v6.0.3.68) & XR450(v130)
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, and WNHDE111
Message 6 of 7
RedSevens
Guide

Re: Netgear Router R7900P - flaking out, slow menu, wireless not showing up

I've been having random issues with this router as well. Have had it since around December. I had to undo the smart connect and it saved me from having to reboot my router at least once a day. Though random issues persist. Thought all issues were gone, but no. Now, if I do speed test from within the router I get about 60 and 5. Then I do it from a phone app and I get about 30 and 5, until I reboot my router and then I get regular speeds again.
Message 7 of 7
Top Contributors
Discussion stats
  • 6 replies
  • 891 views
  • 0 kudos
  • 3 in conversation
Announcements

Orbi WiFi 6E