Reply
Skip_007
Aspirant

Nighthawk AC1900 Model R7000 and Canon MG6120 Printer - No IP Address Assigned when running QoS

I recently decided to set up Quality of Service (QoS) because of adding a couple of Samsung smart TVs to my network. I also have a 2 desktop computers and 1 laptop that are used for gaming.  I got everything set and assigned the priorities that I wanted. Thought everything was fine and then I happened to try to print something. The printer, which is connected to my wifi did not work at all.  When I looked at the connected devices it showed the printer, but no IP address was assigned to it.  So, I tried to reconnect it to my network, at the printer it showed it connected and was assigned an IP address, however Genie did not show it at all now and it would not work.  After doing a bit of research and coming up empty, I tried turning off QoS. When I did that the printer showed up, was assigned and IP address and worked.

 

I do not understand why no IP address gets assigned to the printer when QoS is on. Just seems kind of strange. I checked and both the router and printer have the latest updates and work fine when QoS is off.  Every other device that is supposed to connect does so with no problem. 

Not sure where to look or what to do other than leaving QoS turned off, although I would like to be able to run it.

 

Any suggestions, tips or a solution to this issue would be great.  Thanks in advance for any help you can provide.

Model: R7000|Nighthawk AC1900 Dual Band WiFi Router
Message 1 of 4
JamesGL
Master

Re: Nighthawk AC1900 Model R7000 and Canon MG6120 Printer - No IP Address Assigned when running QoS

Hi Skip_007,

 

What is the firmware version of the router? Make sure to update it. 

 

https://kb.netgear.com/000052576/R7000-Firmware-Version-1-0-9-14

 

If still the same, reset the router and reconfigure it manually.

Message 2 of 4
JamesGL
Master

Re: Nighthawk AC1900 Model R7000 and Canon MG6120 Printer - No IP Address Assigned when running QoS

Hi Skip_007,

 

We’d greatly appreciate hearing your feedback letting us know if you need further assistance.

Message 3 of 4
Skip_007
Aspirant

Re: Nighthawk AC1900 Model R7000 and Canon MG6120 Printer - No IP Address Assigned when running QoS

As of right now the problem is not resolved.  I turned off QoS and as soon as I did the printer was assigned an IP Address.   Right now the Firmware version on the router is V1.0.9.12_1.2.23 I have downloaded the new version that was suggested . . . Version V1.0.9.14_1.2.25, however I am a bit reluctant to install it since I do not have any computers that are wired to the router.  Everything I have is running wirelessly and I am not sure what the results might be if I try to upgrade it that way. 

 

Anyway, at this point things are working as they were before, I am just not able to use the QoS feature and have access to my printer at the same time.  

 

Thanks for all the help and I will keep you posted should I be able to apply the upgrade firmware.

Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 271 views
  • 0 kudos
  • 2 in conversation
Announcements