Reply

Nighthawk AC1900 WiFi slow

WB
Aspirant
Aspirant

Nighthawk AC1900 WiFi slow

I have Comcast high speed internet which tests out at about 170 mbps download speed when the ethernet cable is plugged into my computer directly.  When it's plugged into the router, I get, at best, 45 mbps download speed.  I have restored default settings, installed and uninstalled the Genie, specified channels that have no other competing devices and this is the best I've been able to get.  Should I be satisfied, are there ways to improve this or should I look for another router?  Thanks for any help you can give me.

Message 1 of 12

Accepted Solutions
TheEther
Guru

Re: Nighthawk AC1900 WiFi slow

Not exactly, but you did reveal that the adapter is capable of 802.11ac.  That's a good sign because it means it is unlikely to be the bottleneck, provided that your Wi-Fi settings on the R7000 AND your PC are correct.  You should log into your R7000 and look on the Attached Devices page.  Ideally, you should see your PC listed on the 5G Wireless Devices section because the fastest Wi-Fi speeds are only available on 5 GHz.  If not, read on.

 

First off, log into your R7000 and, if you haven't already done so, click on Wireless and set up a password for the 5 GHz Wireless network.  Use WPA2-PSK [AES] for the strongest security.  Click on Apply if you changed any settings.  Then click on Advanced > Advanced Setup > Wireless Settings and make sure Enable Wireless Radio for the 5 GHz network is checked (it should already be enabled, but you never know).  If necessary, turn it on and click Apply.  You may also want to update the firmware because Netgear made a number of Wi-Fi fixes.  The latest as of this post is 1.0.4.30, though you may also want to try 1.0.4.28 because some people claim that 5 GHz is broken on 1.0.4.30 (works for me, so go figure).  Be sure to do a factory reset and reconfigure everything by hand to avoid any weird update glitches.

 

Second, you should insure that your PC's Wi-Fi adapter is set up to use 5 GHz Wi-Fi.  Normally, it should but it doesn't hurt to double check.  Without knowing your exact adapter, I can only provide general guidance, though I think it may be an Intel.  If you are running Windows, right click on the Wi-Fi symbol (generally on the bottom right of the screen in the notification bar) and click on Open Network and Sharing Center.  You can also get there from the Control Panel.  From there click on Change adapter settings.  Right click on your Wi-Fi adapter and click on Properties, then Configure, then Advanced.  This is it, the heart of your adapter's controls.  For example, this what the settings look like on my adapter:

 

Intel 7260AC settings

 

You should make sure to write down the current settings in case you need to revert back.  In my case, the settings of interest are HT Mode (should be set to VHT Mode), Transmit Power (start with Highest to be safe), Preferred Band (set it to either No Preference or 5 GHz) and Wireless Mode (strangely my adapter doesn't have a setting for 802.11ac, so I set it to 802.11a/b/g).  Once you are done, click OK and Apply to save any changes.  I'm not sure if you need to reboot or disable/enable the adapter.

 

Go back to the R7000 and look on the Attached Devices page.  You should hopefully see your PC listed on the 5G Wireless Devices section.  Redo your speedtest.  Hopefully, it will be nice and fast.  Good luck.

View solution in original post

Message 6 of 12

All Replies
TheEther
Guru

Re: Nighthawk AC1900 WiFi slow

What is the brand and model of your computer's Wi-Fi adapter?

Message 2 of 12
WB
Aspirant
Aspirant

Re: Nighthawk AC1900 WiFi slow

Nighthawk AC1900  model R7000

Message 3 of 12
TheEther
Guru

Re: Nighthawk AC1900 WiFi slow

I was asking about your computer's Wi-Fi adapter, not your Netgear.
Message 4 of 12
WB
Aspirant
Aspirant

Re: Nighthawk AC1900 WiFi slow

Oh, sorry.  The computer is a new Lenovo Edge 15" laptop with built-in wireless. The specs on the Lenovo site refer to Bluetooth® 4.0, 802.11 a/c WiFi, 1G LAN -- is this the adapter?  If not, I'm not sure where on the computer I would find this information but happy to take suggestions.  Thanks for responding.

Message 5 of 12
TheEther
Guru

Re: Nighthawk AC1900 WiFi slow

Not exactly, but you did reveal that the adapter is capable of 802.11ac.  That's a good sign because it means it is unlikely to be the bottleneck, provided that your Wi-Fi settings on the R7000 AND your PC are correct.  You should log into your R7000 and look on the Attached Devices page.  Ideally, you should see your PC listed on the 5G Wireless Devices section because the fastest Wi-Fi speeds are only available on 5 GHz.  If not, read on.

 

First off, log into your R7000 and, if you haven't already done so, click on Wireless and set up a password for the 5 GHz Wireless network.  Use WPA2-PSK [AES] for the strongest security.  Click on Apply if you changed any settings.  Then click on Advanced > Advanced Setup > Wireless Settings and make sure Enable Wireless Radio for the 5 GHz network is checked (it should already be enabled, but you never know).  If necessary, turn it on and click Apply.  You may also want to update the firmware because Netgear made a number of Wi-Fi fixes.  The latest as of this post is 1.0.4.30, though you may also want to try 1.0.4.28 because some people claim that 5 GHz is broken on 1.0.4.30 (works for me, so go figure).  Be sure to do a factory reset and reconfigure everything by hand to avoid any weird update glitches.

 

Second, you should insure that your PC's Wi-Fi adapter is set up to use 5 GHz Wi-Fi.  Normally, it should but it doesn't hurt to double check.  Without knowing your exact adapter, I can only provide general guidance, though I think it may be an Intel.  If you are running Windows, right click on the Wi-Fi symbol (generally on the bottom right of the screen in the notification bar) and click on Open Network and Sharing Center.  You can also get there from the Control Panel.  From there click on Change adapter settings.  Right click on your Wi-Fi adapter and click on Properties, then Configure, then Advanced.  This is it, the heart of your adapter's controls.  For example, this what the settings look like on my adapter:

 

Intel 7260AC settings

 

You should make sure to write down the current settings in case you need to revert back.  In my case, the settings of interest are HT Mode (should be set to VHT Mode), Transmit Power (start with Highest to be safe), Preferred Band (set it to either No Preference or 5 GHz) and Wireless Mode (strangely my adapter doesn't have a setting for 802.11ac, so I set it to 802.11a/b/g).  Once you are done, click OK and Apply to save any changes.  I'm not sure if you need to reboot or disable/enable the adapter.

 

Go back to the R7000 and look on the Attached Devices page.  You should hopefully see your PC listed on the 5G Wireless Devices section.  Redo your speedtest.  Hopefully, it will be nice and fast.  Good luck.

Message 6 of 12
WB
Aspirant
Aspirant

Re: Nighthawk AC1900 WiFi slow

Thanks so much for taking the time to respond with instructions/suggestions.  I checked all the settings against the information you provided and everything corresponded to your setting suggestions.  I did have our Apple TV set to use 5G so I added the computer.  I just ran a test and got 82 mbps download speed after a few tries so that's the best speed I've gotten so far.  Also, in the process of checking the adapter settings per your instructions, I discovered that I have an Intel Dual Band Wireless AC3160 adapter.  Good to know - and good to know how to find that information.  I'm still finding my way around Windows 10 after working with XP for years.  

 

So many thanks, again, for your help!

 

 

Message 7 of 12
IrvSp
Master

Re: Nighthawk AC1900 WiFi slow

Sort of confused here...

 

Are you connecting WIRED or WIRELESS?

 

You did mention both and as I read it you get 170Mbps when wired from the modem to PC. It is NOT clear though about the R7000 to the PC. I sort of get the feeling that is WIRELESS using the AC adapter.

 

The actual speed will vary on the PC wireless card. Even the Netgear A6200 only connects to the R7000 at 866Mbps and actual speed is much lower. Not unusual to see PC to PC transfer speeds way below 10% of that 'connect' speed.

 

Do you get 170Mbps when connecting wired to the R7000? QoS should be off, but WMM should be on.

Message 8 of 12
WB
Aspirant
Aspirant

Re: Nighthawk AC1900 WiFi slow

Initially, when I got the 170 mbps the ethernet cord was connected directly to my computer.  Then I tested my speed when connected through the network and got poor performance.  That's what prompted my original post.

 

I haven't retested thie direct to computer connection because now I am exceeding the expected 150 mbps ( 174 mbps this morning) using the router.  QoS is actually on at this point to give streaming priority over the computer on the 5G channel.  WMM was enabled.

 

I'm not sure what exactly fixed the problem but I'm grateful for your help.  Thanks again.

Message 9 of 12
netwrks
Master

Re: Nighthawk AC1900 WiFi slow

@WB If you have an ISP Service of 60-100mb or better, you can disable QoS. There is a feature with the Broaddcomm chipsets on the R7000, called Cut Through Forwarding (CTF), which gets disabled when QoS is enabled, and can slow down the  throughput on the router by having the  Linux Kernel OS do the processing of all the packets. You can read more on QoS/CTF  Here . Keep WMM enabled..

Message 10 of 12
WB
Aspirant
Aspirant

Re: Nighthawk AC1900 WiFi slow

Got it.  I'll disable and see what happens.  Thanks!

Message 11 of 12
TheEther
Guru

Re: Nighthawk AC1900 WiFi slow

Note that since you are using an Intel AC3160, it's helpful to know that its maximum link speed is 433 Mbps.  Actual throughput will be much less, probably anywhere from 15% to 35% of the link speed, or 65 Mbps to 150 Mbps.

Message 12 of 12
Discussion stats
  • 11 replies
  • 21525 views
  • 2 kudos
  • 4 in conversation
Announcements

Orbi WiFi 6E