Reply

Nighthawk R6900P started dropping 5G wifi

charlie9203
Guide

Nighthawk R6900P started dropping 5G wifi

I purchased the R6900P from Costco about a year ago and everything worked well.  About a week ago (after I updated the firmware, but rolled it back due to other issues) the router started having problems with the 5G wifi.  Its SSID would disappear from all devices for a while.  Then it would come back, but I would get the "Incorrect Password" error.  Deleting the network on the iphone and reopening still gets the "Incorrect Password" error.  If I wait anywhere from 5 minute to 5 hours it will come back and work with no changes made by me.  If I restart the Netgear modem it will work - for a while, then problems repeat. 

 

I finally loaded the latest firmware V1.3.1.26_10.1.3.  Then did a factory reset, followed by reentering my custom settings.  Note: see other thread about how the factory reset fixed the other issues I had with the new firmware.  After 12 hours the dropped 5G wifi happened again.  As other people mention, the 5G wifi light is on on the modem, and it is flashing. 

 

I just don't know if it is hardware or software related.  Any clues?  One possible symptom is that the wifi lights usually "blink" at a 100 to 200ms rate.  Now they often appear to be blinking at at 10ms rate that is so fast, the light just sort of dims a little.  So I thought there may be some interference somewhere.  I do have one of the Costco LED shop lights that senses when you walk close.  Supposedly it doesn't use IR but instead some RF near the 5G wavelength, and it has been reported that it can interfere with 5G wifi reception.  So I unplugged the light to see if that makes any difference.  But the setup has been the same for 6 months, so why now?  Maybe because I messed around with the firmware?

 

I also tried disabling the Mu-MIMO, disabling the implicit beamforming, and turning both 2.4 and 5G guest radios off.  It has been 24 hours so far and no dropped 5G.  If it continues working, I will add back in each thing I turned off to see if problem starts again.  It seems strange that only a small but significant subset of all users.  It also is strange that the problem just goes away for some people.  I think it must be due to a combination of outside factors or settings that affect many brands of routers, as every brand has the same issue when I search.  May be interference, neighbors devices unknowingly trying to access the 5G, someone accessing wifi in a stealth fashion, etc.   Or other 5G interference from other appliances.  It seemed that with the problem and with none of my 5G devices connected to the wifi, there was still a lot of light blinking going on suggesting traffic somewhere. 

 

Hopefully more soon.

Model: R7000|AC1900 Smart WIFI Router
Message 1 of 3
jeffro1014
Initiate

Re: Nighthawk R6900P started dropping 5G wifi

I have the same exact problem as described in the above post.  

 

Any updates or solutions out there?

Message 2 of 3
charlie9203
Guide

Re: Nighthawk R6900P started dropping 5G wifi

The proceedures I mentioned above are still working for me.  I did plug the Costco LED lights back in and haven't had any problems.  So to me, the fix was disabling the Mu-MIMO, disabling the implicit beamforming, and turning both 2.4 and 5G guest radios off.  I haven't had to reset the router since I changed those settings!  So try that to see if it works for you.

Model: R7000|AC1900 Smart WIFI Router
Message 3 of 3
Discussion stats
  • 2 replies
  • 1747 views
  • 3 kudos
  • 2 in conversation
Announcements