Reply
Aspirant

Nighthawk R7000 2g speeds half of 5g

recently upgraded my internet speeds with xfinity from 60mbps to 150. I am getting the new speeds wired, and my 5g connections, but a little less than half that with the 2g connections.

 

Mode is set to up to 600Mbps and latest firmware was downloaded when speeds weren't being obtained with older firmware. I have tried rebooting several times as well as changing wifi channel even though I am sitting 3' from router. I also tried disabling the 20/40MHz coexistance as I saw another post indicated that seemed to work for them.

 

Thoughts? Thank you very much.

Model: R7000|AC1900 Smart WIFI Router
Message 1 of 5

Re: Nighthawk R7000 2g speeds half of 5g

There is a good chance that your older devices that connect to your 2G network do not support connections above 75M.  For example my printer connects at 75M and my Ring Doorbell only connects at 52M.  While my tablet connects at 150M -- all on the same 2G Wifi.  Really, none of these devices are capable of using the bandwidth they are connecting at anyway!

Message 2 of 5
Aspirant

Re: Nighthawk R7000 2g speeds half of 5g

Not the case in this situation. Laptop as well as several smartphones are showing the higher speeds on 5g, but not 2g. No devices are getting above 50mbps on 2g while achieving over 130 on 5g
Message 3 of 5

Re: Nighthawk R7000 2g speeds half of 5g

Might still be the case as almost any dual band device will connect faster on 5G then 2G.  For example, my phone connects at ~900M on 5G but 150M on 2G. Manufactures generally put higher rate 5G radios in devices then the 2G radio.  However I would expect anything new enough to have a 5G radio can probably connect faster than 50M.

 

It's a bit suspicious that NO devices connect faster than 50M on your 2G network.  If you have the settings set to allow faster connections then this is probably because the channel you are using is very crowded. Choose channel 1, 6 or 11 as these are the only ones that do not overlap with other channels. Set the 2G network settings to "upto 289M" as the "upto 600M" causes the channel to widen, overlaps with other channels and is also supported by almost no 2G devices anyway.  You can download one of many wifi channel analysers to see which of 1, 6 or 11 is least busy or just try each one. Also disable 20/40MHz co-existance. You should be able to get solid 150M connections on your 2G network with most devices. 

Message 4 of 5
Aspirant

Re: Nighthawk R7000 2g speeds half of 5g

Thanks, have tried all of your suggestions both independently and together and still no luck.
Message 5 of 5
Top Contributors
Discussion stats
  • 4 replies
  • 480 views
  • 0 kudos
  • 2 in conversation
Announcements