Nighthawk R7000 automatically assigns wrong IP


Nighthawk R7000 automatically assigns wrong IP

Ovwer the last few weeks, my router has autoamtically set a "wrong" IP address to a PC (conncted by cable).


I'm using DHCP with a range of -, and I have set this computer (running Ubuntu Server LTS 18.4.3) to in the router DHCP settings.


Twice now, I have not had access to it, and when checking "attached devices", I find that this computer is connected, but with an IP of 192.168.1.X (and I think it's a random address, last time it was I've seen it at least twice now. Nothing really happened to promt this that I can see (no restarts of anything, no messing in router or Ubuntu, no connecting anything new at the time it happened). A reset of the router and a reboot of the computer fixes it, it then shows up on the expected again.


It's really a problem, since this computer is running the automation of my entire home. And it's really puzzling to me. It's been running fine for more than a year on the same assigned IP with no issues, and I haven't changed anything that I could see as relevant.


If it matters, I am using a Nighthawk EX7300 and a access point (connected to R7000 by cable), but I haven't changed anything with this for more than a year, and the Ubuntu PC connects directly to the R7000.


The R7000 is on firmware V1.0.9.88_10.2.88.

The EX73000 is on firmware v, and I'm currently in the progress of updating to


Hope anyone has an idea of why this happens, and at least as importantly, how to make it stop!



Model: R7000|AC1900 Smart WIFI Router
Message 1 of 3
Sr. NETGEAR Moderator

Re: Nighthawk R7000 automatically assigns wrong IP

Have you checked to see if some other random device is getting assigned the IP address that you want the server to have that then causes the server to get a random IP?



Message 2 of 3

Re: Nighthawk R7000 automatically assigns wrong IP

 Nothing's taking the IP of the server (or any of the other IPs of any of the other devices that are randomly assigned a new IP).


Someone else suggested that maybe the EX7300 (in AP mode) somehow had DHCP re-enabled. The only thing in the config I could find that could potentially have anything to do with that was under [Settings->Wireless->IP Addresses], where I now set it to "Use static IP address". I'm testing to see if that is the issue (but I'm honestly only ~50% sure if this is even DHCP in the EX7300?).


So far so good, but even before, it could go for a few days before making this weird switch.

Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 0 kudos
  • 2 in conversation

Orbi WiFi 6E