Reply

Nighthawk X6 R8000 is the worst experience from a router i have ever had.. PLEASE FIX Netgear!!!!

32edge
Star

Nighthawk X6 R8000 is the worst experience from a router i have ever had.. PLEASE FIX Netgear!!!!

I have owned many routers and modems over the years and when I first got my Nighthawk X6 R8000 it was AMAZING. I hooked up over 20 devices around my home upstairs and down and everything connected and was working the best it ever had. At some point a firmware update happens and that's when everything went downhill and from looking over the forums here A LOT of other have similar issues.  I have worked with your support and we swapped out hardware (Modem and Router) to rule out any hardware related issues but nothing changed, i was sent some beta FW V1.0.4.15_10.1.47-beta and that seemed to work a lot better but eventually had to update to official version and all my issues came back. When i first started having these issues it was that my router just randomly rebooted anywhere from once to 5 times a day, things would reboot come back up and re-connect my devices but  now i get re-boots out of the blue and devices just not wanting to connect anymore and telling me the password is wrong. This router was over $300 and initially i was happy to pay that as it was one of the best i had used and worked very well but now i feel like Netgear just doesn't care anymore they have my $, and Yes they did make an effort to fix things but with so many people posting and having the same issues this is ridiculous for these issues to not be corrected or getting an upgrade to a new model at no cost to make things right. At this point if someone asked me what router to buy i would not recommend Netgear at all, I as im sure many others are SUPER frustrated with this product and lack of what seems caring about fixing this product or making things right.  I really don't know what to do anymore other than go buy a non netgear router, i don't and shouldn't  need to do this but i don't think these issues will be addressed.

My wish would be for netgear to replace my router with the latest model and not just RMA my device with the same model that many people have issues with, i feel like this router would make a better paper weight than a functioning reliable router.

 

Model: R8000|Nighthawk X6 AC3200 Smart WIFI Router
Message 1 of 5
grumpa43
Apprentice

Re: Nighthawk X6 R8000 is the worst experience from a router i have ever had.. PLEASE FIX Netgear!!!

Firmware v1.0.3.54_1.1.37 is stable, and what I have used without problem for over 7 months. I became tired of all the problems with the newer firmware releases.

Model: R8000|Nighthawk X6 AC3200 Smart WIFI Router
Message 2 of 5
IrvSp
Master

Re: Nighthawk X6 R8000 is the worst experience from a router i have ever had.. PLEASE FIX Netgear!!!

Don't know what to tell you, other than I got my R8000 last March and during install it did the update to F/W V1.0.4.18_10.1.49 .

 

Worked fine from the outset. Never needed to re-boot, well, I did do it occasionally due to power loss or vacations, but it never did reboot on my by itself.

 

One problem I did have, and easily worked around is the implementation of Smart Connect. My prior router was an R7000 and it had Smart Connect control both SSID's, the 2.4 and 5Ghz bands. The R8000 Smart Connect supports the 2 5Ghz bands. Slower devices to the 5-1 band and faster to the 5-2 band. Didn't always happen. Occasionally I saw a mix of N and AC devices on both bands. Suspect it was the way it was implemented, load leveling was done first and then the speed determination. So I've used fixed SSID's on my devices, problem solved.

 

These routers, and it seems to be across the model line, have some settings that don't play well with others or the router itself, manifesting itself in different ways. That includes:

  • QoS
  • Traffic Meter
  • USB functions
  • VPN usage
  • UPnP
  • Parental Controls

and possibly others.

 

Some routers require a RESET and clearing the NVRAM and manually re-entering all settings. In some cases that doesn't clear it and fix the problem though. Some users might just re-load saved configurations, and that may not be the same as manually re-entering them. NG does a bad job in this respect. Save Configurations should be a file that can be read and handled by the router as if one was entering the settings, but it seems this isn't the case.

 

Only way to determine why and why others don't see this is testing the configuration. Starting 'small' and then building up in steps and testing (giving enough time to ensure if there was a problem it could happen).

 

As for the RMA process. Not a fan of that. First of all, it seems to be the first line of defense for NG when they can't determine the problem. I had a DLNA problem with the R7000. I had a corrupt database and I proved it to NG support. They claimed they could NOT recreate it and I had a defective router. Cost me $'s to send it back to them and they replaced it, with a refurbished unit!!! Of course the problem wasn't fixed. So then they remote accessed my PC and saw what happened with me leading them through adding files and showing them the database itself (SQL reader worked here) both before and after. Only then did they start working the problem and it took some time to basically fix. When I had a USB drive problem on the R8000 almost the same stuff, we'll RMA the router. I resisted, and dug deeper into the problem. Eventually I discovered the drive was going bad. Replaced the drive, problem solved. Bottom line, if NG support doesn't have an answer or has not recreated the problem, the answer is RMA the router. Sure, in some cases this is the correct thing to do, but it isn't guaranteed to fix the problem.

 

RMA with a newer model? Why? Then every one would claim wild problems or dead routers?

 

My suggestion to you is make sure via the Browser Genie on the Backup Settings tab on the left of Advanced, Administration tab on top, use the botton ERASE button and manually re-enter all settings. See if it works. If not, do it again, and then only connect all devices and see if that works. Doesn't? Might have a bad router. Does, well then start adding back settings and test as you go. Might be one or a combination causing you problems.

Message 3 of 5
32edge
Star

Re: Nighthawk X6 R8000 is the worst experience from a router i have ever had.. PLEASE FIX Netgear!!!

Im not saying just give everyone the latest router when they run into issues but after working with them for months and having all my equipment RMA and testing beta firmwares im about done with Netgear, i used to be able to connect a router get all my devices connected to is and forget about it. At this point its a daily struggle, it will work fine and then all of a sudden half my devices will stop connecting and indicate the password is incorrect, i have to switch the wireless channel or reboot the router and disturb everyone else in my home who might be working at that moment. I feel the best option at this point since NetGear just doesnt really care is to stop buying/using netgear all together. I have reset this router multiple times with my original router and the RMA brand new one they sent me. I never had these issues when i 1st got this router it seemed to start with a firmware update, when i was working with NG they even admitted it was a bug and they had the engineers working on fixing it but that obviously faild.

 

Model: R8000|Nighthawk X6 AC3200 Smart WIFI Router
Message 4 of 5
IrvSp
Master

Re: Nighthawk X6 R8000 is the worst experience from a router i have ever had.. PLEASE FIX Netgear!!!

I don't know if NG changed support people or company doing the support, but in the past they've been slow to fix problems, and in some cases regressed firmware. Now though it seems they are less capable of fixing things. I have an OPEN case since 3/31/18 with NO resolution but finger pointing to it being a Windows problem. Over 6 month with them closing it and me sending more info and they look at it for weeks and again try to close it. Last time a live connection late at night with me and the actual support group in China (no phone capability, all done via an open NOTEPAD window we types back and forth) and at one time 3 different ID's connected to my PC at the same time. At that end they are going to again research the problem. I don't hold much confidence in the problem being fixed either...

Message 5 of 5
Top Contributors
Discussion stats
  • 4 replies
  • 1929 views
  • 0 kudos
  • 3 in conversation
Announcements

Orbi WiFi 6E