Reply
Highlighted
Aspirant

Nighthawk X8 2.4 Ghz Not Broadcasting

We recently purchased the Nighthawk X8 R8500 wireless router. Everything seemed to be working OK until we did a firmware upgrade to the latest update last week. I do not know if it worked after the firmware upgrade or not so I don't know if that is what caused it for sure but the 2.4Ghz is not broadcasting at all and it either happened when we did the upgrade or very shortly after. Even if I enable the 2.4 Ghz Guest network, that does not broadcast.

 

Here is what I have tried so far:

- Change the channel for the 2.4 Ghz

- Removed the password on 2.4 Ghz network

- Changed the SSID of the 2.4 Ghz network

- Pressed the wireless button on the router to turn off and then back on

- Reset the router by pressing the reset button on the back and re-configuring the router

- Tried on multiple devices and none see the 2.4 Ghz network

 

Nothing at all has helped. Any help would be greatly appreciated because some of the devices on our network do not have the ability to join 5 Ghz networks.

 

Thanks!

 

Bryan

Model: R8500|Nighthawk X8 Tri-Band AC5300 WiFi Router
Message 1 of 8
Highlighted
NETGEAR Employee Retired

Re: Nighthawk X8 2.4 Ghz Not Broadcasting

Hi @BryanF526


Welcome to the community!

 

Is the 2.4GHz light on? Can you still access the admin page of the router and verify the exact firmware version uploaded?

Anyhow, try the reset instructions below and see if it will fix that 2.4GHz signal broadcast.

 

1. With the unit powered on, press and hold the reset button on the back of unit for 30seconds.
2. Without releasing the reset button, unplug the unit and hold reset for another 30 seconds.
3. Power on the unit while STILL pushing the reset button and count for another 30 seconds before letting it go.

 

Let us know what happens.

ElaineM
NETGEAR Community Team
Message 2 of 8
Highlighted
Aspirant

Re: Nighthawk X8 2.4 Ghz Not Broadcasting

Sorry for the late response but this did not fix it either. Any other ideas or should I put in for an RMA?

 

Firmware is 1.0.2.54_1.0.56

 

 

Model: R8500|Nighthawk X8 Tri-Band AC5300 WiFi Router
Message 3 of 8
Highlighted
Master

Re: Nighthawk X8 2.4 Ghz Not Broadcasting

You mean 2.4GHz radio is dead? Are you using inSSIDer or Acrylic to survey WiFi signal in your neighborhood including your? You mean

you can't detect your signal? Tried with different WiFi device you have?

Message 4 of 8
Highlighted
Aspirant

Re: Nighthawk X8 2.4 Ghz Not Broadcasting

Yeah it seems that it is dead. I have tried on every device and none of them pick up the 2.4 Ghz broadcast even though the router has "Broadcast" enabled. The 5 Ghz is fine but nothing from the 2.4 Ghz.

Message 5 of 8
Highlighted
NETGEAR Employee Retired

Re: Nighthawk X8 2.4 Ghz Not Broadcasting

@BryanF526 Kindly contact our support for a replacement.

ElaineM
NETGEAR Community Team
Message 6 of 8
Highlighted
Tutor

Re: Nighthawk X8 2.4 Ghz Not Broadcasting

My 2.4Ghz has just ghosted, no clue what happened, on router it is solid white light and the 5ghz is blinking white and works fine even though iphone drops it every 1 or 2 minutes.

 

but 2.4ghz is gone, can anyone help as ive reset the router and nothing has worked, firmware updatedd as of today but 2.4 ghz problem has been about 4-5 days now

Model: R8500|Nighthawk X8 Tri-Band AC5300 WiFi Router
Message 7 of 8
Master

Re: Nighthawk X8 2.4 Ghz Not Broadcasting

Hi cjzielie,

 

1. How many wireless devices are unable to detect the 2.4Ghz?

2. Have you check the SSID broadcast in the routers UI if it is checked?

 

JamesGL

Community Team

Message 8 of 8
Top Contributors
Discussion stats
  • 7 replies
  • 3151 views
  • 0 kudos
  • 5 in conversation
Announcements