Reply

Nighthawk X8 R8500 - AC Problems - Clicking On & Off

MDN-SENSORIUM
Follower

Nighthawk X8 R8500 - AC Problems - Clicking On & Off

I've been using my Nighthawk X8 R8500 WiFi Router in an art installation for just four computers. In the middle of the installation, the router suddenly turned off. It was set up in a safe staging area away from the floor. Now, when I plug in the router, it only makes a clicking noise with the lights turning on and off. See the attached video. I think a fuse might be blown? Or the AC adaptor plugin is loose? Not totally sure.

 

My Netgear warranty is currently out, but I have a SquareTrade insurance that has approved getting it fixed. I would try to fix it myself, but I think this needs to be done by a pro. Is there anywhere to pay to get these fixed? Or other suggestions? I cannot seem to find anything about repairs for on the NetGear website as it currently thinks it's out.

 

Model: R8500|Nighthawk X8 Tri-Band AC5300 WiFi Router
Message 1 of 2
FURRYe38
Guru

Re: Nighthawk X8 R8500 - AC Problems - Clicking On & Off

Please post this here in this forum for NH routers:

https://community.netgear.com/t5/Nighthawk-WiFi-Routers/bd-p/home-wifi-routers-nighthawk

 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM2000 Modem | Wifi Router RAXE50 and R8500(v.158) Router Mode | Switches NG GS105/8 | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700, GS308v3

Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 713 views
  • 0 kudos
  • 2 in conversation
Announcements

Orbi WiFi 6E