Reply
almedicu
Tutor

Nighthawk r7000 wifi drops SOLUTION

Hi guys, I provide tech support to end users and companies, one of my customers gave me the NETGEAR AC1900 / R7000, I discovered the router has 2 main issues, ( Wifi dropping connection and reboots ), I spent more than 2 months trying to find a posible solution in different forums and nothing worked.

 

I installed many stock firmware and problem persists, tried different versions of DDWRT firmware ( I run DDWRT FW on my Asus AC66U Router ) and connection kept dropping, that was very frustating.

 

When I thought everything was lost and there was nothing else left to do I decided to give it one last chance before I through it away to the garbage, that's when I found a discution on the DDWRT forum that helped me a lot with the firmware needed.

https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1141752

 

I hope my solution can help others with this device issue.

 

1- If you are on stock firmware do a hard reset.

a. Find the Restore/Reset button on your router(usually located in a pinhole on the back of the router).b. Use a paperclip or ballpoint pen tip to press and hold the button until the Power light starts to blink. It usually takes between 7 and 9 seconds.

 

2- Download to your computer the following version of DDWRT for R7000 router.

https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2018/03-26-2018-r35531/netgear-r7000/

there will be 2 files

 

factory-to-dd-wrt.chk
netgear-r7000-webflash.bin

 

3- Access via brower let's access 192.168.1.1 proceed with known steps to access your router settings and let's do a firmware upgrade from Stock firmware to DDWRT version R35531, IMPORTANT: use an ethernet cable from the computer to the router.

 

4- Once when you're in the router settings do the firmware upgrade by going to ADVANCED tab / ROUTER UPDATE / click on BROWSE and upload the ( factory-to-dd-wrt.chk ) file and wait until router reboots.

After router reboots with DDWRT firmware go to ADMINISTRATION / FIRMWARE UPGRADE and upload the ( netgear-r7000-webflash.bin ) and wait 'till it finishes.

 

5- Last step is to change the MTU on DDWRT, go to SETUP / BASIC SETUP / from default MTU is 1500 let's select MANUAL and change it to 1450 and reboot the router, since a applied those changes router it's been running without any problem in the last 2 days and counting.

 

r7000 wifi drops
netgear r7000 wifi drops
nighthawk r7000 wifi drops
netgear nighthawk r7000 wifi problems

Model: R7000|AC1900 Smart WIFI Router
Message 1 of 7
MrMatt2019
Aspirant

Re: Nighthawk r7000 wifi drops SOLUTION

Thank you for posting this, I've about had it with my R7000 and am considering trying an open firmware before just ditching it and getting something else, maybe an ASUS, I don't know...

 

My question is if you remember what firmware you started from? What version you were on when you flashed to the dd-wrt? I haven't tried yet, but other posts have suggested that the latest firmware (1.0.9.88_10.2.88) won't allow you to flash anything other than forward with Netgear firmware. It won't allow flashing back to a previous release, and it won't allow flashing to an open source firmware either.

 

Just curious, and again, thank you for posting.

 

Matt

Model: R7000|AC1900 Smart WIFI Router
Message 2 of 7
almedicu
Tutor

Re: Nighthawk r7000 wifi drops SOLUTION

Hi MrMatt2019, I used too many firmwares, the ones that I could save are the following;

 

R7000-V1.0.9.60_10.2.60.chk
R7000-V1.0.9.88_10.2.88.chk
R7000-V1.0.8.34_1.2.15.chk ========> With this one you can upgrade to DDWRT
R7000-V1.0.4.30_1.1.67.chk ========> With this one you can upgrade to DDWRT

Attached there is a picture with the uptime of the router without any issue.

 

 

Message 3 of 7
MrMatt2019
Aspirant

Re: Nighthawk r7000 wifi drops SOLUTION

I thought I would give an update to anyone else reading this thread...

 

My router is the R7000 NightHawk. It was on firmware 1.0.9.88_10.2.88 which as of this writing is the newest one. In my opinion it is not a stable release, the router couldn't go 4 hours without completly losing all internet connectivity, wireless or hardwired, didn't matter. Sometimes the connection would re-establish after a few minutes, and other times you would have to do a hard boot on the router.

 

This is why I was interested in trying this open source firmware solution, before I bought a different router.

 

Before I tried this open source firmware, I took the advice from another thread and regressed the firmware to version V1.0.9.42_10.2.44 and that was two days ago and the connection hasn't failed yet. It is much more stable for me.

 

Version V1.0.9.42_10.2.44 isn't perfect, I've noticed that on your first attempt to connect to a website it will, about 25% of the time, not find the site. You'll get some type of "host unreachable" type message, but then almost immediately recover and bring it up properly. So it isn't perfect, but it is much more stable than the newer 1.0.9.88 I was using.

 

So many thanks to @almedicu for posting this solution, but I'm going to run this older version 1.0.9.42 for a while and see how it goes.

 

Either way, I'm very gunshy now to updating the firmware on this device.

 

 

 

 

Model: R7000|AC1900 Smart WIFI Router
Message 4 of 7
drocks27
Aspirant

Re: Nighthawk r7000 wifi drops SOLUTION

I was wondering if you know if the lastest firmware update 4/2020 took care of this issue?  I had to go back to my ISP router which doesn't get the same range as my nighthawk and is not working for the home office set up. I would like to go back the nighthawk as it was fast and reached the whole house but before i mess witht the settings, I wonder if they actually fixed it. 

Message 5 of 7
MrMatt2019
Aspirant

Re: Nighthawk r7000 wifi drops SOLUTION

@drocks27 ,

 

No, I had rolled back to firmware V1.0.9.42_10.2.44 and I haven't touched it since. If you end up buying a new router,

 

I agree with what you're saying too, the router has good strength and range. It just hasn't been very stable. I reboot it once a day as a pre-emptive strike...

 

Matt

Message 6 of 7
chrishansen
Aspirant

Re: Nighthawk r7000 wifi drops SOLUTION

I tried following this procedure because I was getting the same problems reported.  But I ran into a snag at this step:

 

"After router reboots with DDWRT firmware go to ADMINISTRATION / FIRMWARE UPGRADE and upload the ( netgear-r7000-webflash.bin ) and wait 'till it finishes."

 

When I try to do so, I get a page saying that 'the site can't be reached. The connection was reset.'  Am I missing a step?

 

I am connected to the router via Cat5.  I was even able to change the MTU setting to 1450.  But I can't seem to upload the .bin file. 

 

Any guidance on this would be appreciated.  I'm ready to throw my router out my window.  Thanks!

Message 7 of 7
Top Contributors
Discussion stats
  • 6 replies
  • 6532 views
  • 0 kudos
  • 4 in conversation
Announcements