Nighthawk router not allowing certain websites to load

I have had the Nighthawk R7500 for many years.  Last night, when attemting to visit some websites from my PC, I would get error messages that the page could not be reached.  However, many of my typically visited sites worked and streamed just fine.  All of the devices connected to the router still worked and received a strong signal.  I logged into the router admin page and updated the firmware.  After completing this, I was unable to reach any websites at all saying that my connection was not private.  I connected my modem directly to the PC and all sites works just fine, with no issues, or loss of speed or connection.  I did a factory reset on the router, which allowed me to get back to most websites but still wouldn't allow access the same sites I was unable to prior, like, or, etc.  Thinking the router was dead, I went and bought a brand new one.  Set it up, and the exact same issue persisted.  The basic tab of the router admin page would say the internet connection was not connected, even though some connectivity could be seen.  Refreshing the admin page would change the status to good, yet some websites were not available.  My subsequent call with tech support lasted 94 minutes.  Too many options to list were adjusted, which allowed some of the previously unvisitable sites to work however not all were available.  Mobile devices could visit when using the phone data, but when connected to the wifi router, they wouldn't be able to connect to that specific site yet others worked just fine.  I have never experience such intermittant connectivity issues that were based on different websites.  And even stranger is that the router would give a connection to mobile devices but somehow unallow them to visit some sites.  My tv, phone, and PC while connected to either router can not reach  However, turning off the wifi and the phone pulls it up in less than a second.  I have an Arris surfboard modem purchased with cox ISP.  My call to cox led to no detectable issues with the modem, and the direct connection from the modem to the PC with everything working just fine leads to me to believe this is a router only issue.  What am I missing?

Model: R7500|Nighthawk X4 AC2350 Smart WiFi Router, R8000P|Nighthawk X6S AC4000 Tri Band WiFi Router
Message 1 of 2

Re: Nighthawk router not allowing certain websites to load

What modem is it? You put that you visit att and if you use them for your isp provider, that coud be the issue right there. Att is known for providing modem/router combo devices. And their combo devices aren't known for working properly in passthrough modem. 

If your in pass through mode-many att devices don't function properly in this mode.

If your not in passthrough mode and the netgear router in is router mode-your in a double nat. which can cause this issue too.

What I'd try if you're on att is to make sure the att modem/router is in router mode. Disable its wifi, setup the netgear in AP (Access point) mode. this leaves a single device controlling dhcp. 

If this isn't the case, let me know what provider you're using and what modem model number it is and we can move on from this setup. 

CM2000-> Arris AX11000 W31-> GS716v2-> WAX***-AP
Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 0 kudos
  • 2 in conversation