Reply

R6120 no internet router set up - netgear account login problem serial number already registered

39cj
Aspirant

R6120 no internet router set up - netgear account login problem serial number already registered

After unbricking my R6120 after a firmware update via app failed, I can connect to the wifi but am unable to access the internet. It seems the issue is the set up of the router. I can login to the router using the admin account without any problems. However, when I am asked to login to my netgear account to complete the set up process, after I have entered the verification details I get an error saying 'serial number already registered' which prevents me from being able to login to my netgear account and complete the router set up process. The router was of course registered to my account when I purchased and set it up initially, but the system doesn't seem to recognise it is registered to the same person/account trying to log in.

Please help!
Model: R6120|AC1200 Dual Band WiFi Router
Message 1 of 3

Accepted Solutions
plemans
Guru

Re: R6120 no internet router set up - netgear account login problem serial number already registered

You shouldn't need to register it (if its already been done) to setup and connect to the internet. 

Try using the browser method of setup. 

Also, what modem/gateway are you connecting to? 

 

Try powering both modem and router off and disconnecting everything (including coax) from both. 

then connect coax to modem and power it on. give it a couple minutes. 

Then connect router to modem and power router on. give it a couple minutes. 

Then try setup using the browser method. again, you shouldn't need to register it. 

Current Setup: CM2000-> SXK30-> GS716v2-> Arris W31 x2-> Pi-hole->

View solution in original post

Message 2 of 3

All Replies
plemans
Guru

Re: R6120 no internet router set up - netgear account login problem serial number already registered

You shouldn't need to register it (if its already been done) to setup and connect to the internet. 

Try using the browser method of setup. 

Also, what modem/gateway are you connecting to? 

 

Try powering both modem and router off and disconnecting everything (including coax) from both. 

then connect coax to modem and power it on. give it a couple minutes. 

Then connect router to modem and power router on. give it a couple minutes. 

Then try setup using the browser method. again, you shouldn't need to register it. 

Current Setup: CM2000-> SXK30-> GS716v2-> Arris W31 x2-> Pi-hole->

View solution in original post

Message 2 of 3
39cj
Aspirant

Re: R6120 no internet router set up - netgear account login problem serial number already registered

Thanks for your reply.

I followed your advice and the nighthawk app didn't get stuck where I was having problems earlier. In addition to unplugging and waiting a few minutes like you suggested, I used an ethernet connection to reset the TCP/IPV4 settings to detect IP address automatically. I followed the instructions on this very helpful YouTube video at the 2 minute mark to unbrick the router (https://youtu.be/R9DLrLQrpaw) but until just now I hadn't done the steps in reverse, which may have contributed to the connection problems.
Many thanks for your help.
Model: R6120|AC1200 Dual Band WiFi Router
Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 730 views
  • 1 kudo
  • 2 in conversation
Announcements