Reply
Highlighted
Aspirant

R6120 "403 Forbidden" error when trying to set static DNS address

Firmware Version: V1.0.0.68

 

I've been searching through all variations of 403 Forbidden posts on this forum, but I can't find anything relatable. Although I did try those answers as well, going through IE, Edge and Firefox to make sure it wasnt a browser issue. I've also done a factory reset without any change. It has been used for ~3 weeks and havent been touched at all after initial setup. Other people with a 403 error seem to get them more frequently, but Im only getting them when trying to change to a static DNS address.

 

Im at a loss as to what else I can try. Any help or guidance will be greatly appreciated!

 

Just in case it's related, or if someone know what the issue might be, Im also having a problem with my router detecting a MAC address from my PC that I can't find when checking ipconfig /all. The IP address is matching, and before factory reset I had 2 different MAC addresses from the same PC, even though Ive only used WIFI. One on 5GHz and one on 2.4GHz, but different MAC address. AFAIK the MAC address should be the same though, no?

 

The only settings Ive tried to change so far is Address Reservation and static DNS Address.

Model: R6120|AC1200 Dual Band WiFi Router
Message 1 of 6
Guru

Re: R6120 "403 Forbidden" error when trying to set static DNS address

> R6120 "403 Forbidden" error when trying to set static DNS address

 

   "trying to set" what, exactly, to what, exactly?  BASIC > Internet :
Domain Name Server (DNS) Address, or something else?  What, exactly are
you specifying there?

 

   Generally, any HTTP 4xx error would be the result of a firmware
defect.  (Or corrupt settings which trigger a latent firmware defect, if
you want to count that case separately.)

 

> [...] I've also done a factory reset without any change. [...]

 

   That should cover the "corrupt settings" case.

 

> [...] detecting a MAC address from my PC [...]

 

   I know nothing about the hardware configuration of your (unspecified)
"my PC".


> The only settings Ive tried to change so far is Address Reservation
> and static DNS Address.

 

   Address Reservation worked as expected?

 

   Are we (cryptically) discussing a Pi-hole?  If so, then some other
discussions might be interesting.  For example:

      https://community.netgear.com/t5/x/x/td-p/1942286

 

   Other than trying different/older firmware, I have no clever
suggestions.  And, if you're trying to specify a DNS server with a
LAN-subnet address, then I wouldn't bet on finding more cooperative

firmware.

Message 2 of 6
Highlighted
Aspirant

Re: R6120 "403 Forbidden" error when trying to set static DNS address

Sorry for missing some details here

 


   "trying to set" what, exactly, to what, exactly?  BASIC > Internet :
Domain Name Server (DNS) Address, or something else?  What, exactly are
you specifying there?

 Yeah exactly that.(edit: changing from dynamic to in this case, OpenDNS or Google, not Pi-hole yet) I went to Advanced Setup > IPv6 as well and changed the DNS address there without a problem, so I dont know why IPv4 is an issue.

 


> [...] detecting a MAC address from my PC [...]

 

   I know nothing about the hardware configuration of your (unspecified)
"my PC".

 Im not sure whats relevant here, but Im on WIndows 10 Pro (v.1909). Please elaborate if Im missing something though.

 


   Address Reservation worked as expected?


Well Im not completely sure, but I assume so. After setting IP reservation for my Win PC, ipconfig says "192.1.... (preferred)".

 


   Are we (cryptically) discussing a Pi-hole?  If so, then some other
discussions might be interesting.  For example:

      https://community.netgear.com/t5/x/x/td-p/1942286


Yes, the reason I want to change the DNS address on my router is for Pi-Hole. I checked the post you linked and tried removing the COAX cable from the modem before doing another factory reset. After finishing and trying to set Google's DNS, Im still getting "403 Forbidden".. I checked with my ISP to see if they even block me from changing DNS and they say they don't.

 


   Other than trying different/older firmware, I have no clever
suggestions.  And, if you're trying to specify a DNS server with a
LAN-subnet address, then I wouldn't bet on finding more cooperative

firmware.


Does that mean that even if I was able to change DNS, I wouldnt be able to set it to Pi-hole's DNS anyways, since that would be a LAN-subnet address? Im not fully sure what this means.

 

If there's nothing more to do, I'll just manually set each device to my RPi's DNS. Kind of surprised it would be this hard though.

Message 3 of 6
Highlighted
Guru

Re: R6120 "403 Forbidden" error when trying to set static DNS address

> [...] I dont know why IPv4 is an issue.

 

   A firmware bug would be the obvious explanation.

 

> Generally, any HTTP 4xx error would be the result of a firmware
> defect. [...]

 

   Still my claim.

 

> [...] After setting IP reservation for my Win PC, ipconfig says
> "192.1.... (preferred)".

 

   There's no need to hide your (private) LAN addresses.  If that hidden
value is what you specified under Address Reservation, then I'd say that
it's doing that much right.

 

> [...] Im still getting "403 Forbidden".. I checked with my ISP to see
> if they even block me from changing DNS and they say they don't.


   When you're dealing with the router's management web site, a 4xx HTML
error is the router's fault; I'd guess that you'd still get it if you
weren't connected to your ISP.

 

> Does that mean [...]

 

   That'd be my expectation.  People with (some? all?) models which
don't return "403" errors still report problems.

 

> [...] Kind of surprised it would be this hard though.

 

   Welcome to Netgear router firmware/support.

Message 4 of 6
Highlighted
Tutor

Re: R6120 "403 Forbidden" error when trying to set static DNS address

I can confirm that I have the same issue. (Firmware V1.0.0.68)

Model: R6120|AC1200 Dual Band WiFi Router
Message 5 of 6
Highlighted
Tutor

Re: R6120 "403 Forbidden" error when trying to set static DNS address

I managed to find the workaround.

To make changes in the "Internet setup" section, i.e. set static DNS servers:

1. Disable internet access on the router (disconnect it from modem)

2. Make desired changes

3. Connect router to modem again.

Model: R6120|AC1200 Dual Band WiFi Router
Message 6 of 6
Top Contributors
Discussion stats
  • 5 replies
  • 950 views
  • 2 kudos
  • 3 in conversation
Announcements