Reply

R6400v2 Speed issue

Allah
Aspirant

R6400v2 Speed issue

hi i created a topic about this back in 2019 and the issue still isnt resolved . my internet speed is 500/500 mbps , im able to get those speeds on the V1.0.3.66_10.0.50 software , but when i update the firmware my speeds drop to 200 mbps or less . i tried rebooting and factory resetting . i went back to the previous V1.0.3.66_10.0.50 firmware and speeds are back to normal. is this going to be fixed?

Message 1 of 19
plemans
Guru

Re: R6400v2 Speed issue

We're not netgear. this is the community support forum where members of the public help out. so we dont' know firmware plans or what netgear is working on. 

Current Setup: CM2000-> RBK750-> GS716v2-> RAXE500-> Pi-hole->
Message 2 of 19

Re: R6400v2 Speed issue


@Allah wrote:

hi i created a topic about this back in 2019 and the issue still isnt resolved


Is this it?

 

Speeds decreased in latest firmware update ( R640... - NETGEAR Communities

 

There is far too little information there to allow anyone to begin to suggest what might be going on.

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 3 of 19
Allah
Aspirant

Re: R6400v2 Speed issue

with the latest firmware V1.0.4.118_10.0.90 my speeds have dropped from 500/500 to around 200/150 , on firmware version 1.0.3.66 i was getting 500 down and up , but ever since i updated the firmware im getting no more than 200 mbps . i've been having this issue for a while now. i tried rebooting and factory resetting the router .

Message 4 of 19

Re: R6400v2 Speed issue

It might also help if you told people what the modem is in front of this router, if there is one. The model number could be useful. Is it, by any chance, also a router, with a set of LAN ports on the back?

The reason for asking is that a lot of people turn up here trying to put a router behind a modem that is also a router. That can complicate troubleshooting.

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 5 of 19
Allah
Aspirant

Re: R6400v2 Speed issue

im using a modem/ont provided to me by verizon fios

Message 6 of 19

Re: R6400v2 Speed issue


@Allah wrote:

im using a modem/ont provided to me by verizon fios


That just says you have a box on the wall. It tells us nothing about what it is and what it can do.

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 7 of 19
Allah
Aspirant

Re: R6400v2 Speed issue

well assuming you know what a modem is and what it does , i have the verizon fios modem connected to the nighthawk router with a cat 5e ethernet cable. i don't know what else what you want me to include on here. 

Message 8 of 19

Re: R6400v2 Speed issue


@Allah wrote:

well assuming you know what a modem is and what it does


I sure do. I have owned many over the years.

 

But modems come in different flavours with a whole raft of possible features. Some do wifi, some do phones, some do handstands.

 

This will give you some idea of what we are up against:

 

verizon fios modem - Google Search

 

If you can find your modem, it probably has a label on the bottom that has a brand name and a model number. Without that information it is impossible to rule out some of the issues that can affect any router you attach to it.

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 9 of 19
Allah
Aspirant

Re: R6400v2 Speed issue

oh i see , well i cant flip the modem at the moment over to see if it has a model number since its on the wall , but the brand of the modem is verizon . if you search for verizon ont , you'll see it there . im just going to attach a photo i got off the internet , it looks exactly like the equipment i have.

 

 

Desktop Screenshot 2021.08.26 - 11.37.13.72.png

Message 10 of 19

Re: R6400v2 Speed issue


@Allah wrote:

oh i see , well i cant flip the modem at the moment over to see if it has a model number since its on the wall , but the brand of the modem is verizon . if you search for verizon ont , you'll see it there .

 


Verizon doesn't make modems. Like all ISPs it buys in and installs stuff like that.

 

It looks like a plain vanilla ONT. So it shouldn't get in the way of your router.

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 11 of 19
Allah
Aspirant

Re: R6400v2 Speed issue

oh thought they did since it has a verizon logo on it , and when i had spectrum their equipment didnt have a spectrum logo on it , it just had the logo of the manufacturer on the router/modem . but yeah anyways im just trying to figure out why the speeds have decreased ever since the more recent firmware updates.

Message 12 of 19
Allah
Aspirant

Re: R6400v2 Speed issue

so am i going to get help?

Message 13 of 19

Re: R6400v2 Speed issue

Possibly not, given that this one seems to be unique to you. That usually points back to stuff at your end.

 

I assume that you have tried all this input:

 

Search - NETGEAR Communities – R6400V2

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 14 of 19
Allah
Aspirant

Re: R6400v2 Speed issue

This isn't an issue on my end though . This has to be a issue with the newer firmwares of the router . The problem only occurs on the newer firmware , if i were to go back to the older firmware the speeds would go back to how it should be .

Message 15 of 19
plemans
Guru

Re: R6400v2 Speed issue

Have you tried just downgrading? I've seen multiple issues on the newer firmware. 

Current Setup: CM2000-> RBK750-> GS716v2-> RAXE500-> Pi-hole->
Message 16 of 19
Allah
Aspirant

Re: R6400v2 Speed issue

Yes and the speeds were good but theres security flaws on the older firmware.

Message 17 of 19
plemans
Guru

Re: R6400v2 Speed issue

So you have a choice. 

Keep the current firmware and speed and hope there will be a firmware that comes out quickly to fix the issue. 

Or downgrade and hope the "security fixes" aren't that significant since netgear doesn't release what the actual fixes are. 

 

In my experience, I'd downgrade. I've had routers that didn't get a single update and didn't have anyone penetrate my equipmen/system. 

but it is a risk you take. 

Current Setup: CM2000-> RBK750-> GS716v2-> RAXE500-> Pi-hole->
Message 18 of 19

Re: R6400v2 Speed issue


@plemans wrote:

 

Or downgrade and hope the "security fixes" aren't that significant since netgear doesn't release what the actual fixes are. 

 

Netgear will not, and should not, explain what security fixes are designed to mend. To do so would tell the evil people out there that there are unplugged holes in the dyke.

 

But a cursory glance at the long list oif security issues that Netgear warns about will quickly reveal that most of them are hypothetical. Something uncovered in one of those security labs somewhere but that have never been seen in the wild.

 

 

Security Advisory | About Us | NETGEAR

 

 

Some people go for years without firmware updated for security fixes. (One recent visitor here is using a router that hasn't had an update in near on-five years, with no seeming damage to their security.)

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 19 of 19
Top Contributors
Discussion stats
  • 18 replies
  • 354 views
  • 0 kudos
  • 3 in conversation
Announcements

Orbi WiFi 6E