Reply
Highlighted
Tutor

R700 port forwarding not working - With working server

I have a camera setup which, according to the instructions, requires port 88 open:

 Capture.JPG

 

 

I am ble to access the camera through 192.168.1.8:88 and view the live stream. Why is it I can't see the port open on sites like canyouseeme.org using that port.

 

Reason for me asking that is to setup access to the camera outside my LAN, I need to setup a DDNS from the camera's internal site. However, it's showing as the DDNS is failing, one of the reasons for that is the port isn't forwarded.

 

Is there something I am missing? I also did the check for the other port forward labled PS-* and with the PS4 on, the ports are being reported as closed per canyouseeme.org

 

 

Additional router info:

Hardware Version R7000
 
Firmware Version V1.0.9.60_10.2.60
 
GUI Language Version V1.0.9.60_2.1.38.1
Model: R7000|Nighthawk AC1900 Dual Band WiFi Router
Message 1 of 4
Highlighted
Sage

Re: R700 port forwarding not working - With working server

> I have a camera setup which, according to the instructions, requires
> port 88 open: [...]

   Not a very detailed description of anything, but your port-forwarding
rule looks reasonable.

> I am ble to access the camera through 192.168.1.8:88 [...]

   Ok.  What happens if, still from your LAN, you specify your router's
WAN/Internet IP address with that external port number?  If the "NAT
loopback" feature of your router works, then that should, too.

> [...] Why is it I can't see the port open on sites like
> canyouseeme.org using that port.

   "using that port" at _which_ IP address?

> [...] I need to setup a DDNS from the camera's internal site. [...]

   Eh?  From the outside world, you'll be talking to the router, not
directly to the "a camera".  You'll probably want some kind of DDNS
service to provide a DNS name for your router's WAN/Internet IP address,
but who maintains that should matter little.  (I have a static IP
address, so I don't deal with these things, but I gather that an R7000
should be able to do it without involving your "a camera".)

> [...] it's showing as the DDNS is failing, [...]

   What, exactly, is showing what, exactly?

> [...] one of the reasons for that is the port isn't forwarded.

   Port forwarding is independent of DDNS working.  Without DDNS, you'd
simply need to specify your router's WAN/Internet IP address instead of
some DNS name.  What is your router's WAN/Internet IP address?

   The usual problems with this stuff are:

   1. Wrong external IP address (different from the port-forwarding
router's WAN/Internet IP address).  (An intermediate NAT router, for
example, could cause this.)

   2. Bad port-forwarding rule (wrong port(s), wrong target address --
including a wandering target).

   3. Server not listening on the port-forwarding target system.

   4. External influences: ISP blocking, other firewalls, ...

And, of course, bad router firmware.

Message 2 of 4
Highlighted
Tutor

Re: R700 port forwarding not working - With working server

@antinode wrote:

> I have a camera setup which, according to the instructions, requires
> port 88 open: [...]

   Not a very detailed description of anything, but your port-forwarding
rule looks reasonable.

 

-- Following the instructions of Foscam FI9900EP. Nothing fancy here

> I am ble to access the camera through 192.168.1.8:88 [...]

   Ok.  What happens if, still from your LAN, you specify your router's
WAN/Internet IP address with that external port number?  If the "NAT
loopback" feature of your router works, then that should, too.

 

-- I didn't test that prior to my post, but using my IP http://97.x.x.x:88/ from my LAN does indeed work. So what does that mean?

> [...] Why is it I can't see the port open on sites like
> canyouseeme.org using that port.

   "using that port" at _which_ IP address?

 

-- The WAN IP address 97.x.x.x provides the following error: Error: I could not see your service on 97.x.x.xon port (88)

> [...] I need to setup a DDNS from the camera's internal site. [...]

   Eh?  From the outside world, you'll be talking to the router, not
directly to the "a camera".  You'll probably want some kind of DDNS
service to provide a DNS name for your router's WAN/Internet IP address,
but who maintains that should matter little.  (I have a static IP
address, so I don't deal with these things, but I gather that an R7000
should be able to do it without involving your "a camera".)

 

-- From my understanding, the camera DDNS service is being provided by the Manufacturer, Foscam, and I'm able to use that in order to view the camera from outside my LAN.

> [...] it's showing as the DDNS is failing, [...]

   What, exactly, is showing what, exactly?

 

-- Accessing the camera from 192.168.1.8:88, within the Setting Tab, the page displays DDNS: Failed, UPnP: Success.

> [...] one of the reasons for that is the port isn't forwarded.

   Port forwarding is independent of DDNS working.  Without DDNS, you'd
simply need to specify your router's WAN/Internet IP address instead of
some DNS name.  What is your router's WAN/Internet IP address?

 

-- That conclusion isn't from me. According to Foscam's documentation, the DDNS shows "Failed" in the camera's setting webpage is due to the port not being forwarded. Which seems to contradict what you said, but your statement sounds more correct than theirs.

   The usual problems with this stuff are:

   1. Wrong external IP address (different from the port-forwarding
router's WAN/Internet IP address).  (An intermediate NAT router, for
example, could cause this.)

 

-- Could the possibility of a switch cause this?

   2. Bad port-forwarding rule (wrong port(s), wrong target address --
including a wandering target).

 

-- It's working from within the LAN

   3. Server not listening on the port-forwarding target system.

 

-- Camera is up and running

   4. External influences: ISP blocking, other firewalls, ...

 

-- I checked with Spectrum, and no other firewalls

And, of course, bad router firmware.

 

Message 3 of 4
Highlighted
Sage

Re: R700 port forwarding not working - With working server

> -- From my understanding, the camera DDNS service is being provided by
> the Manufacturer, Foscam, and I'm able to use that in order to view the
> camera from outside my LAN.

   As I said, I don't need/use DDNS, but, on my "FI9821W V2", I see
Settings > Network > DDNS, where I get a choice of "myfoscam.org" or
various "Third Party DDNS" options.  No matter what, it will (must)
still deal with the router's public (WAN) address.  The camera itself
doesn't have a public (WAN) address.

> -- Accessing the camera from 192.168.1.8:88, within the Setting Tab,
> [...]

   You mean Settings > Status > Device Status?  (Many things are "within
the Setting Tab".)  I don't know how you configured your DDNS.  But you
should be able to investigate that without involving the camera.  No
matter what, it's the router's WAN address that's involved.  (And/or,
configure DDNS on the router.)

> [...] According to Foscam's documentation, the DDNS shows "Failed" in
> the camera's setting webpage is due to the port not being forwarded.
> [...]

   Many things are possible.  The camera could phone home, where some
Foscam-operated computer could try to contact your camera from the
outside world.  As with much of this stuff the details tend to be hidden
inside the black box.

> -- Could the possibility of a switch cause this?

   A _router_, yes.  I don't see how a switch could.

> [...] using my IP http://97.x.x.x:88/ from my LAN does indeed work.

   That's a good sigh nor port forwarding on the router.  And that
address looks legit.  (Some folks have invisible routers, hidden behind
dormitory or apartment walls.)

> -- I checked with Spectrum, and no other firewalls

   Not that I trust no one, but you might try this stuff using an
external port other than the popular web-server ones (80, 88, 8080,
...).  The only cases I've seen reported here where LAN access to the
public address works, but actual WAN access failed, were explained by

the ISP blocking popular server ports.  (I'd pick something 1024 or

higher.)

   Another test would be to enable Remote Management on the router, and
see if _that_ port works from the outside world.

   If you get desperate enough to send me a private message with your
actual IP address (and port), then I could try it from here.

Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 607 views
  • 0 kudos
  • 2 in conversation
Announcements