Reply

R7000 Can't connect to OpenVPN, Firmware 1.0.4.30

rldoose
Aspirant

R7000 Can't connect to OpenVPN, Firmware 1.0.4.30

Not sure why, but the drop down does not have my model # which is R7000 not R6900.

 

I have been thoure the OpenVPN setup instrutions to use OpenVPN on the R7000 multipe times.  It seems really straight forward.....

 

However, I can't connect.  Firmware is latest as of 4/7/2016 (1.0.4.30), and I have tried rebooting the router.  

 

Final messare in the log is:  MANAGEMENT: >STATE:1460134043,WAIT,,,

 

Congig and Logfile below.

 

Any guidance would be very appreciated!

 

Config:

client
dev tap
proto udp
dev-node NETGEAR-VPN
remote ***************** (Blacked out for security)
resolv-retry infinite
nobind
persist-key
persist-tun
ca ca.crt
cert client.crt
key client.key
cipher AES-128-CBC
comp-lzo
verb 5

 

Logfile:

Fri Apr 08 10:47:17 2016 pkcs11_protected_authentication = DISABLED
Fri Apr 08 10:47:17 2016 pkcs11_protected_authentication = DISABLED
Fri Apr 08 10:47:17 2016 pkcs11_private_mode = 00000000
Fri Apr 08 10:47:17 2016 pkcs11_cert_private = DISABLED
Fri Apr 08 10:47:17 2016 pkcs11_pin_cache_period = -1
Fri Apr 08 10:47:17 2016 pkcs11_id = '[UNDEF]'
Fri Apr 08 10:47:17 2016 pkcs11_id_management = DISABLED
Fri Apr 08 10:47:17 2016 server_network = 0.0.0.0
Fri Apr 08 10:47:17 2016 server_netmask = 0.0.0.0
Fri Apr 08 10:47:17 2016 server_network_ipv6 = ::
Fri Apr 08 10:47:17 2016 server_netbits_ipv6 = 0
Fri Apr 08 10:47:17 2016 server_bridge_ip = 0.0.0.0
Fri Apr 08 10:47:17 2016 server_bridge_netmask = 0.0.0.0
Fri Apr 08 10:47:17 2016 server_bridge_pool_start = 0.0.0.0
Fri Apr 08 10:47:17 2016 server_bridge_pool_end = 0.0.0.0
Fri Apr 08 10:47:17 2016 ifconfig_pool_defined = DISABLED
Fri Apr 08 10:47:17 2016 ifconfig_pool_start = 0.0.0.0
Fri Apr 08 10:47:17 2016 ifconfig_pool_end = 0.0.0.0
Fri Apr 08 10:47:17 2016 ifconfig_pool_netmask = 0.0.0.0
Fri Apr 08 10:47:17 2016 ifconfig_pool_persist_filename = '[UNDEF]'
Fri Apr 08 10:47:17 2016 ifconfig_pool_persist_refresh_freq = 600
Fri Apr 08 10:47:17 2016 ifconfig_ipv6_pool_defined = DISABLED
Fri Apr 08 10:47:17 2016 ifconfig_ipv6_pool_base = ::
Fri Apr 08 10:47:17 2016 ifconfig_ipv6_pool_netbits = 0
Fri Apr 08 10:47:17 2016 n_bcast_buf = 256
Fri Apr 08 10:47:17 2016 tcp_queue_limit = 64
Fri Apr 08 10:47:17 2016 real_hash_size = 256
Fri Apr 08 10:47:17 2016 virtual_hash_size = 256
Fri Apr 08 10:47:17 2016 client_connect_script = '[UNDEF]'
Fri Apr 08 10:47:17 2016 learn_address_script = '[UNDEF]'
Fri Apr 08 10:47:17 2016 client_disconnect_script = '[UNDEF]'
Fri Apr 08 10:47:17 2016 client_config_dir = '[UNDEF]'
Fri Apr 08 10:47:17 2016 ccd_exclusive = DISABLED
Fri Apr 08 10:47:17 2016 tmp_dir = 'C:\Users\REAGAN~1.DOO\AppData\Local\Temp\'
Fri Apr 08 10:47:17 2016 push_ifconfig_defined = DISABLED
Fri Apr 08 10:47:17 2016 push_ifconfig_local = 0.0.0.0
Fri Apr 08 10:47:17 2016 push_ifconfig_remote_netmask = 0.0.0.0
Fri Apr 08 10:47:17 2016 push_ifconfig_ipv6_defined = DISABLED
Fri Apr 08 10:47:17 2016 push_ifconfig_ipv6_local = ::/0
Fri Apr 08 10:47:17 2016 push_ifconfig_ipv6_remote = ::
Fri Apr 08 10:47:17 2016 enable_c2c = DISABLED
Fri Apr 08 10:47:17 2016 duplicate_cn = DISABLED
Fri Apr 08 10:47:17 2016 cf_max = 0
Fri Apr 08 10:47:17 2016 cf_per = 0
Fri Apr 08 10:47:17 2016 max_clients = 1024
Fri Apr 08 10:47:17 2016 max_routes_per_client = 256
Fri Apr 08 10:47:17 2016 auth_user_pass_verify_script = '[UNDEF]'
Fri Apr 08 10:47:17 2016 auth_user_pass_verify_script_via_file = DISABLED
Fri Apr 08 10:47:17 2016 client = ENABLED
Fri Apr 08 10:47:17 2016 pull = ENABLED
Fri Apr 08 10:47:17 2016 auth_user_pass_file = '[UNDEF]'
Fri Apr 08 10:47:17 2016 show_net_up = DISABLED
Fri Apr 08 10:47:17 2016 route_method = 0
Fri Apr 08 10:47:17 2016 block_outside_dns = DISABLED
Fri Apr 08 10:47:17 2016 ip_win32_defined = DISABLED
Fri Apr 08 10:47:17 2016 ip_win32_type = 3
Fri Apr 08 10:47:17 2016 dhcp_masq_offset = 0
Fri Apr 08 10:47:17 2016 dhcp_lease_time = 31536000
Fri Apr 08 10:47:17 2016 tap_sleep = 0
Fri Apr 08 10:47:17 2016 dhcp_options = DISABLED
Fri Apr 08 10:47:17 2016 dhcp_renew = DISABLED
Fri Apr 08 10:47:17 2016 dhcp_pre_release = DISABLED
Fri Apr 08 10:47:17 2016 dhcp_release = DISABLED
Fri Apr 08 10:47:17 2016 domain = '[UNDEF]'
Fri Apr 08 10:47:17 2016 netbios_scope = '[UNDEF]'
Fri Apr 08 10:47:17 2016 netbios_node_type = 0
Fri Apr 08 10:47:17 2016 disable_nbt = DISABLED
Fri Apr 08 10:47:17 2016 OpenVPN 2.3.10 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [PKCS11] [IPv6] built on Mar 10 2016
Fri Apr 08 10:47:17 2016 Windows version 6.2 (Windows 8 or greater)
Fri Apr 08 10:47:17 2016 library versions: OpenSSL 1.0.1s 1 Mar 2016, LZO 2.09
Fri Apr 08 10:47:17 2016 MANAGEMENT: TCP Socket listening on [AF_INET]127.0.0.1:25340
Fri Apr 08 10:47:17 2016 Need hold release from management interface, waiting...
Fri Apr 08 10:47:17 2016 MANAGEMENT: Client connected from [AF_INET]127.0.0.1:25340
Fri Apr 08 10:47:18 2016 MANAGEMENT: CMD 'state on'
Fri Apr 08 10:47:18 2016 MANAGEMENT: CMD 'log all on'
Fri Apr 08 10:47:18 2016 MANAGEMENT: CMD 'hold off'
Fri Apr 08 10:47:18 2016 MANAGEMENT: CMD 'hold release'
Fri Apr 08 10:47:18 2016 WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.
Fri Apr 08 10:47:23 2016 MANAGEMENT: CMD 'password [...]'
Fri Apr 08 10:47:23 2016 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Fri Apr 08 10:47:23 2016 LZO compression initialized
Fri Apr 08 10:47:23 2016 Control Channel MTU parms [ L:1590 D:1212 EF:38 EB:0 ET:0 EL:3 ]
Fri Apr 08 10:47:23 2016 Socket Buffers: R=[65536->65536] S=[65536->65536]
Fri Apr 08 10:47:23 2016 MANAGEMENT: >STATE:1460134043,RESOLVE,,,
Fri Apr 08 10:47:23 2016 Data Channel MTU parms [ L:1590 D:1450 EF:58 EB:143 ET:32 EL:3 AF:3/1 ]
Fri Apr 08 10:47:23 2016 Local Options String: 'V4,dev-type tap,link-mtu 1590,tun-mtu 1532,proto UDPv4,comp-lzo,cipher AES-128-CBC,auth SHA1,keysize 128,key-method 2,tls-client'
Fri Apr 08 10:47:23 2016 Expected Remote Options String: 'V4,dev-type tap,link-mtu 1590,tun-mtu 1532,proto UDPv4,comp-lzo,cipher AES-128-CBC,auth SHA1,keysize 128,key-method 2,tls-server'
Fri Apr 08 10:47:23 2016 Local Options hash (VER=V4): 'b498be7c'
Fri Apr 08 10:47:23 2016 Expected Remote Options hash (VER=V4): '26e19fc0'
Fri Apr 08 10:47:23 2016 UDPv4 link local: [undef]
Fri Apr 08 10:47:23 2016 UDPv4 link remote: [AF_INET]50.183.1.246:12974
Fri Apr 08 10:47:23 2016 MANAGEMENT: >STATE:1460134043,WAIT,,,

Model: R6900|Nighthawk AC1900 Smart WiFi Router
Message 1 of 4

Accepted Solutions
rldoose
Aspirant

Re: R7000 Can't connect to OpenVPN, Firmware 1.0.4.30

Thanks!  I got it working. With new router, whole house network upgrade, and FreeNAS installation, I don't even recall what solvered this issue, but it works great!

View solution in original post

Message 4 of 4

All Replies
doraemon
Prodigy

Re: R7000 Can't connect to OpenVPN, Firmware 1.0.4.30

Perhaps try the beta fw 1.0.5.60?

------------------------------
gimme dorayaki Smiley Very Happy
Message 2 of 4
johnsdagg
Guide

Re: R7000 Can't connect to OpenVPN, Firmware 1.0.4.30

I have R7000 firmware 1.0.4.30 and have been successfully using OpenVPN 2.3.8 x86_64-w64-mingw32 which can be found here:

 

http://swupdate.openvpn.org/community/releases/openvpn-install-2.3.8-I601-x86_64.exe

 

 

Message 3 of 4
rldoose
Aspirant

Re: R7000 Can't connect to OpenVPN, Firmware 1.0.4.30

Thanks!  I got it working. With new router, whole house network upgrade, and FreeNAS installation, I don't even recall what solvered this issue, but it works great!

View solution in original post

Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 2583 views
  • 0 kudos
  • 3 in conversation
Announcements