Reply

R7000 Download speed is less than expected

Jarcher1
Follower

R7000 Download speed is less than expected

I have the AC1900 R7000 router and my download speed when I plug directly into my modem is over 260 mbps but when I plug into the router it is only 36 mbps and less when connecting wirelessly. Any suggestions on how to improve the router stopped or is this normal?.

Model: R7000|Nighthawk AC1900 Dual Band WiFi Router
Message 1 of 3
LeeH
Prodigy

Re: R7000 Download speed is less than expected

When run with the default configuration my R7000 gives me a full 350Mbps on a 300Mbps connection wired or 5G wireless.  They are giving me a little bit more than I pay for.

 

Have you made any configuration changes to the router?  You might need to start over by resetting the router and just change the admin password and leave everything else configured as default.

Message 2 of 3
IrvSp
Master

Re: R7000 Download speed is less than expected

Not normal at all...

 

Assuming you've used the same cable from the modem to the router and modem to PC then there is a possibility the the router to PC cable is bad. First thing I'd do is test modem to PC using both cables to rule out cable problems.

 

Next try ALL the ports in the router, do they all have the same speed down? If it is only one that is slow you have a bad router.

 

Next ensure the WMM is ON... turning it off can slow you down.

 

Last one has to do with the firmware.

 

A couple of things to try...

 

  • The 30-30-30 reset.
    1. With the unit powered on, press and hold the reset button on back of unit for 30 seconds
    2. Without releasing the reset button, unplug the unit and hold reset for another 30 seconds
    3. Plug the unit back in STILL holding the reset button a final 30 seconds.
  • Reset the Router to DEFAULT settings. You can find this under ADVANCED --> BACKUP SETTINGS, the last item.
  • Make sure you are on the latest Firmware. If you are, try flashing it again. If not, get it, flash the router, reset it, and then MANUALLY re-enter your changes to the settings. DO NOT use an old saved configuration.

Try these steps one at a time and test again after each. Hopefully one will fix you.

Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 2704 views
  • 0 kudos
  • 3 in conversation
Announcements

Orbi WiFi 6E