Reply

R7000 Enabling Downstream QOS kills VOIP

NightHawk
Aspirant

R7000 Enabling Downstream QOS kills VOIP

I would like Netgear Engineers take a look at this issue and comment. Customer service was of no use. I added Vonage(VOIP) MAC address to downstream QOS list and enabled downstream QOS. This killed my Vonage downstream connection everytime I ran speedtest on other device. Disabling downstream QOS resolved the issue with VOIP. But that defeats the purpose of buying R7000 which claims to have this unique feature over competition for smooth downstream video playbacks.

Other settings:
Disabled SIP ALG.
Enabled WMM on both 2 and 5 GHz.
Enabled upstream QOS and added Vonage MAC address with Highest Priority.
Added Vonage VOIP Mac rule to downstream QOS database list.

In this scenario:
Enable Downstream QOS = Kills VOIP downstream (Vonage)
Disable Downstream QOS = Okay VOIP.

Netgear Engineers Please look into this and provide firmware update to fix this issue. The reason I bought R7000 was to enable downstream QOS for video. It should not kill my VOIP downstream.
Message 1 of 33
Retired_Member
Not applicable

Re: R7000 Enabling Downstream QOS kills VOIP

I would expect any reasonable ISP package other than dial up would be able to supply Vonage and a speed test without disrupting VOIP.


What is your Up and Down speed test results?
Message 2 of 33
theoak
Luminary

Re: R7000 Enabling Downstream QOS kills VOIP

NightHawk wrote:

...
Netgear Engineers Please look into this and provide firmware update to fix this issue. The reason I bought R7000 was to enable downstream QOS for video. It should not kill my VOIP downstream.


The only way NETGEAR support is going to see this is if you take the time to create an account via my.netgear.com, then create a ticket with all of your details.
RBK53 v2
Router Firmware: 2.7.2.104
Satellite Firmware: 2.7.2.104 (Satellite1: Wired, Satetellite2: WiFi)
Setup: DSL Modem (Bridge Mode) - Personal Router - Orbi (Access Point mode)
Message 3 of 33
NightHawk
Aspirant

Re: R7000 Enabling Downstream QOS kills VOIP

@Searay - I agree. I have Comcast Blast with 50MB down and 10 MB up using Motorola docsis 3.0 modem. No issues with ISP. I always get consistent speed 57MB down and 11 MB up without jitter and packet. But with downstream QOS enabled, it leaves no downstream bandwidth for Vonage. My speedtest while on phone still gives me 50MB/10MB + results. Disabling downstream QOS, I notice that my Vonage calls are much better and my speedtest while on the phone shows lower results. For now I have disabled downstream QOS but very disappointed with Netgear's half baked feature.
Message 4 of 33
NightHawk
Aspirant

Re: R7000 Enabling Downstream QOS kills VOIP

@theoak - Good suggestion to create a ticket online. Already have an account and a case open. The case was created over phone. I have spent hours on hold and rehashing the details to various customer service reps. They fail to understand the problem and also don't make notes. So every time I have to explain this all again. So far I am not able to get through them. I want to go past these untrained and unskilled support guys and reach the reach engineers who can work on the firmware fix.
Message 5 of 33
Retired_Member
Not applicable

Re: R7000 Enabling Downstream QOS kills VOIP

NightHawk,

The amount of bandwidth used by Vonage is minuscule (compared to what is available ) and just because your speed test doesn't show a drop does not mean anything. Speed test results vary more than Vonage uses. Speed test along with ping test are meant to run while network is idle, test ran when not idle are useless. There is no reason why you should have to use any QOS with that ISP package as there is no reason to disable SIG. In fact you may be making your own problem by adding multiple rules for same device.
I have identical service for past several months after downgrading from 105 20 with Comcast. I use several MagicJacks and Download from NewsGroups while wife is on company VPN and I try collapse, overload my service and stress test it which I cannot.

I'm not a Vonage user, but doesn't Vonage suggest placing their box between modem and router? Problem solved! If the reason you bought this 7000 was to enable downstream QOS, Then I suggest you should consider returning it.


My Rant!
My 2 cents on QOS leave it alone! I cannot believe the amount of QOS post recently. People think it's a magic bullet that will make things better that are already working fine. Then after they jack their settings they come back and post things like, Hey I did this now it works. Default settings will work 98% of the time IMOP.
Message 6 of 33
NightHawk
Aspirant

Re: R7000 Enabling Downstream QOS kills VOIP

More testing and observations, each test was performed multiple times to rule out outliers:

Hard rest Router to factory defaults. No QOS enabled. All default settings. When both Vonage and Laptop are connected to Ethernet ports. They play nicely. VOIP quality acceptable, Speedtest on laptop steady.

Next connect laptop via wifi and repeat the test. Laptop wifi speedy until you start using VOIP connected to Ethernet. This was tested several times with different combinations. Conclusion: VOIP on Ethernet and Wifi streaming don't play nice.

Next: Dont worry about Vonage, run wifi streaming Video via Netflix on one device, Run speedtest on wifi connected Laptop. Both streams of wifi trip each other off. At times speedtest is choppy, at times Netfilx stutters.

Next just for giggle turn on R7000's unique downstream QOS feature on. Test Vonage and some wifi Speedtests. speedtest is fast (57MB down) but it leaves no bandwidth for Vonage. Other party cannot be heard. its blank out.

Now here is a kicker: I went back to my 3 year old Cisco/Linksys E3000. In all of the above situation, no stutter or lag on any devices. On this device I have been using QOS to allocate small upstream bandwidth for Vonage. It works beautifully. When multiple devices are sharing the internect connections. ie. Vonage, Speedtest, wifi stream etc. nobody suffers.

To conclude, R7000 wifi connections aggressively take away bandwidth from other devices. They dont play fair with other connections leaving poor experience. The only exception is when they are sharing ethernet connection.

Talked to Netgear support multiple times to explain this. They wanted to help but did not want to hear that this is possible. Per Netgear (inspite of all these VOIP complaints) they claim VOIP works fine with it.

Netgear support walked me through putting Vonage in a DMZ. They suggest disabling SIP ALG and disabling secure mode for the same. The results unchanged. Now they want me to open ports for Vonage. Talked to Vonage support and they said, if you have already put VOnage in DMZ then port forwarding/opening will not do anything more.

Comment on misconception of using Vonage between router and modem: This would work if we are in 90s DOCSIS 1.0 days. Unfortunately Vonage devices have not kept up with networking advances. They still use DOCSIS 1.0. So in this configuration your internet will be severely downgraded. My observation is that Vonage will simply assume uplink of 1.5MB and reserve a small QOS for Vonage. The downlink will also be capped to DOCSIS 1.0 speeds. So this is not a solution for 2013 (perhaps for 1999 it was fine).

Bottom Line: I have 50mb/10mb internet link. Vonage is using merely 300k of bandwidth. So when talking on phone, I should be able to do basic web surfing on wifi connected laptop without slowdowns. R7000 fails this simple test. Going back to my Cisco E3000, everything works like heaven. Only bright spot of R7000 is its range and throughput if you are using only single device. I am done being Beta tester for Netgear. Going back to old router or may upgrade to Linksys EA6900
Message 7 of 33
Retired_Member
Not applicable

Re: R7000 Enabling Downstream QOS kills VOIP

I appreciate the education regarding Vonage, I have magjicjack for 3 years and didn't realize vonage was a choke point.
Message 8 of 33
NightHawk
Aspirant

Re: R7000 Enabling Downstream QOS kills VOIP

Interesting Update: I may be getting closer to finding the root cause of my issues.....

I returned and replaced my router to rule out any hardware issues with the unit. Upgraded firmware and did hard reset. Zero changes made to settings. Started running my tests again.

Vonage on Ethernet. Sound quality is okay using default settings. When phone is in use and I ran speedtest over wifi the results were still miserable. Then I accidentally discovered some more details. The wifi is slow to crowl only on 5GHz band. 2G band is fine.

So this is where I am:-

Problem Description: When actively using internet on Ethernet device there is a severe degradation of 5G band. Both range and throughput. As soon as Vonage call is over the performance is back to normal. 2G band is not affected. This is a good news/bad news for me. This means I have a workaround to use 2G. Bad news, I am at the mercy of Netgear to release a firmware fix.
Message 9 of 33
CaliLife17
Aspirant

Re: R7000 Enabling Downstream QOS kills VOIP

I will be upgrading my 3 R700 routers tonight.

Quick Question: Is it recommended to Upgrade and then do a Factory reset on the router? Or Factory Reset then do the upgrade on the Router?

Thanks
Message 10 of 33
RogerSC
Virtuoso

Re: R7000 Enabling Downstream QOS kills VOIP

CaliLife17,

If you're going to reset, do the reset after upgrading, before you manually reconfigure it on the new firmware. I also power-cycle my router after resetting it, but that's my own preference and it doesn't take very long *smile*.
Message 11 of 33
Retired_Member
Not applicable

Re: R7000 Enabling Downstream QOS kills VOIP

Nighthawk




Are you using a cordless phone? I ask because my 5g AC client causes my phone to cut out where 5g n client does not.
Message 12 of 33
NightHawk
Aspirant

Re: R7000 Enabling Downstream QOS kills VOIP

I am not sure why factory reset is needed. But Netgear support will ask you "did you factory reset after upgrade?" so I guess it needs to be done after upgrade. But wont hurt if you reset before and after upgrade. It does not take too much time anyway. Before you reset, you can optionally backup your settings so that you can restore them on new firmware if needed.
Message 13 of 33
Retired_Member
Not applicable

Re: R7000 Enabling Downstream QOS kills VOIP

Using a backup would be a bad idea. Manually enter the configs.
Message 14 of 33
NightHawk
Aspirant

Re: R7000 Enabling Downstream QOS kills VOIP

@Searay - You rock! You are absolutely right. - I have 5.8G Uniden cordless phone. That was the culprit of my 5G degradation. Using just the base station (no handset) my 5G range is normal. I played with all available 5G channels on the router. Channels 36-48 do not receive interference from my cordless phone. Channels 149-161 do. I would have never thought of this because my old Linksys E3000 did not have this issue on 149-161 channels. In netgear when I change channel to 36-48, the router warns me to use 149-161 for better performance. Wonder what I am going to miss by using lower channels. Anybody has any idea? Perhaps beamforming?

Until I get DECT 6.0 cordless phones I have a good workaround to use lower 5G channels.

Now back to my original problem thread: "Enabling downstream QOS kills VOIP". This is still true. By now I have isolated all other condition that affected wifi and vonage performance. But this remains the problem statement.

Netgear please fix this to make this good router great !
Message 15 of 33
Retired_Member
Not applicable

Re: R7000 Enabling Downstream QOS kills VOIP

Using the lower channels in my case is about 3 db lower. I stumbled on the phone causing a problem after I installed Intel AC 7260 clients. At first I was cussing out Comcast thinking more Node problems, then I noticed it only effected Voice when I surfed, I'm on the phone quite a bit with laptop on lap. According to my routers R6300v2 status page 1300 uses 4 channels so changing between the higher channels and expecting a change is pointless. I'm guessing it's the modulation scheme and addition bandwidth of 80 MHz is over powering my handset.


I'm glad your making progress. Can you see the leds on the nighthawk from a distance? I'm one of those who want's to see at a glance my network status. I have 2 v2's but seem to be missing out on a brain tease, so I might visit Tiger Direct a pick one up.
Message 16 of 33
Retired_Member
Not applicable

Re: R7000 Enabling Downstream QOS kills VOIP

Dual Line power max 5.8 Uniden 6 handsets.
Message 17 of 33
mozerd
Guide

Re: R7000 Enabling Downstream QOS kills VOIP

NightHawk wrote:
Until I get DECT 6.0 cordless phones I have a good workaround to use lower 5G channels.

Now back to my original problem thread: "Enabling downstream QOS kills VOIP". This is still true. By now I have isolated all other condition that affected wifi and vonage performance. But this remains the problem statement.
That was a good catch by searay.

Netgear have chosen to prioritizes wireless [versus wired] voice and video traffic over the WiFi link using (WMM QoS) -- this does make sense since most people will be buying this model for its wireless capabilities -- and apparently one has very little control in this area --- so I suggest that you go back to Netgear Support and request further clarification on defining a SIP/RTP priority class especially with ATA devices that may not have built-in support for WMM which may be the reason that Enabling downstream QOS kills VOIP --- obviously a conflict.

Many people are using Skype or other softphones and they all have built-in support for WMM which is why the will work well --- but its not clear to me if ATA devices provide support for WMM. So for the time being Downstream QoS seems to be in conflict .... I may be on the wrong track .... certainly would be interesting to get Netgear Support position on this.
David Mozer
Message 18 of 33
NightHawk
Aspirant

Re: R7000 Enabling Downstream QOS kills VOIP

searay wrote:
Can you see the leds on the nighthawk from a distance? I'm one of those who want's to see at a glance my network status. I have 2 v2's but seem to be missing out on a brain tease, so I might visit Tiger Direct a pick one up.


Yes there are 10 LEDs in a row which I can easily glance from 20 feet away. Two rightmost LEDs are also buttons. Depending on various status the lights go from white/amber solid/blinking/off. The labels are very hard to read even from 1 foot. I wish instead of plain light they had cutouts/symbols lit from underneath. I like the aesthetics of linksys E3000 in that regards.
Message 19 of 33
Lexist2112
Luminary

Re: R7000 Enabling Downstream QOS kills VOIP

CaliLife17,

The Ideal way to upgrade:
1) Download latest FW
2) push reset button on back of router, to default settings
3) Clear cache in web browser
4) connect router to LAN device to port 1 of router
5) Access router GUI interface and locate Upgrade FW
6) Let the router do its thingSmiley Very Happy
7) Once done, check to verify that the NEW FW is installed
8) Push reset button for 15 sec, let router come back up.
9) MANUALLY RECONFIG router from scratch.

The lazy method/dirty upgrade:
1) save you current config
2) Upgrade via router, let it do its thing
3) enjoy Smiley Tongue


I have done both, usually the manual reconfig. This last round I decided to do the dirty upgrade...lazySmiley Tongue, router has been rock solid with my old settings and has been performing well. After the upgrade, I made 2 adjustments, reduce my wireless mode form 1300 to 600 on the 5ghz and as of yesterday, use different primary and secondary DNS....way snappier with the new DNS. Oh, just upgraded on MON, my speed from 15/1 to 50/5 and bought the Motorola SB6141 modem...love this modem. Using this modem has yielded 56/5.3 on the speedtest and my wireless is smokin fast.

BF4 on XBOX1 over the 5ghz is sublime Smiley Very Happy
Message 20 of 33
dalupus
Aspirant

Re: R7000 Enabling Downstream QOS kills VOIP

NightHawk,

I wonder if simply hooking up the vonage box to a wireless bridge would help. so that it accessing the R7000 via wireless.

I turned on QOS and had the same issue with vonage. Turned off QOS and it went right to normal.
Message 21 of 33
Retired_Member
Not applicable

Re: R7000 Enabling Downstream QOS kills VOIP

Honestly guys, I agree with searay - don't mess with QoS.

The problem with the Netgear implementation is that they allow you to classify traffic but they don't allow you to modify the queues. So you have no control over congestion once a situation occurs, so you have no control over what gets discarded or when.

I have a 32/4 ethernet connection with an R7000. I have a laptop connected to the 2.4Ghz guest network - on it I use an SSL VPN to connect to Cisco Call Manager with a Cisco IPC client. I have a Sony BluRay player running Amazon Instant Video connected to the private 2.4Ghz network on the same R7000.

With downstream QoS disabled, video runs flawlessly and Cisco IP phone runs flawlessly. With downstream QoS enabled, video runs flawlessly and Cisco IP phone is garbled and choppy.

Now I have one key difference from you guys running Vonage. I'm fairly certain my router has NO IDEA that I'm running VoIP because it's running in a VPN tunnel. The only thing I can think of is that the router is reserving way too much bandwidth for the video stream. It really doesn't make any sense.
Message 22 of 33
Retired_Member
Not applicable

Re: R7000 Enabling Downstream QOS kills VOIP

Actually, I'm 100% sure the router has no idea I'm running VoIP. I just checked my VPN client and confirmed that it's running in ESP mode. The VoIP packets are encapsulated.
Message 23 of 33
NightHawk
Aspirant

Re: R7000 Enabling Downstream QOS kills VOIP

Wireless Bridge option does not solve the issue. I used my old E3000 in bridge mode and connected vonage device to it and had the same issue.
Message 24 of 33
NightHawk
Aspirant

Re: R7000 Enabling Downstream QOS kills VOIP

Good News! - Netgear support has provided a beta trail build for me to test. It has fixed the issue. So I am hoping that fix makes its way to the official firmware soon.
Message 25 of 33
Top Contributors
Discussion stats
  • 32 replies
  • 29330 views
  • 0 kudos
  • 14 in conversation
Announcements