Re: R7000 Intermittent Life


R7000 Intermittent Life

Hi team,


I have been working with an R7000 for a half year or so with very little issues until recently. Today, just out of the blue, my network dropped and I noticed the lights on the router not as bright as they normally are. I have attached a pic and you will notice that the light to the far RIGHT is much brighter than the other lights. 


I did do a firmware upgrade yesterday and am not sure if that is related to the issue, but I cannot get this router to do anything! (apologies, do not recall the FW ver #. believe it was something like


  • I have tried power cycling with the power button
  • I have tried power cycling by pulling the power cord
  • I have tried power cycling by holding the power button down while pulling the power cord
  • I have tried resetting the d@mn thing by holding the reset key button down for 10 - 30 secs
  • I have tried connecting straight to my laptop
  • I have tried power cycling without any other connections
  • I have left it unpluged for over an hour.... NOTHING

STILL NOTHING. I cannot connect to it to try and revert the firmware or upgrade to different firmware. Nothing else has changed. Same ISP, same modem, yes - I have paid my bill, no electrical issues (lightning or such that I can recall), no I haven't dropped it or water damage.


Any ideas or thoughts before I just use this thing as a paper weight?

Model: R7000|Nighthawk AC1900 Dual Band WiFi Router
Message 1 of 10

Re: R7000 Intermittent Life

The pic I spoke about is too large to share. I can tell you that the light beside the WPS button on the top is bright white, just as ALL other lights would be with running correctly. The power light is very dim red, 5G light is very dim white and the USB 2 light is very dim white. Nothing else is lighting up. 

Message 2 of 10
Not applicable

Re: R7000 Intermittent Life

try holding reset for 30secs then pull power while holding reset for another 30secs then continue to hold while applying power for another 30 secs


search for how to un brick r7000 and or contact support if less than a year old

Message 3 of 10

Re: R7000 Intermittent Life

I tried the above reset sequence but no change.


I have also tried the TFTP suggestion from this page;


I used the following command - (cd to desktop and yes I setup my network correctly) tftp PUT R7000-V1.0.5.70_1.1.91.chk


Nothing.... "Timeout occurred - Connect request failed"


Not sure I want to go this route, but not sure what else to do:


Any other thoughts?

Message 4 of 10

Re: R7000 Intermittent Life

If you are connected at Gigabit speed it will give you bright white light and if its (10/100) mbps supported devices it will give you dim amber light.

try differnet devices means laptop or desktop and see if light changes to white or not but it should be (10/100/1000)gigabit network card not your internet speed to clarify.

if it still remains amber then it must fused the gigabit ports may be due to power cut or something like that. so now it only supports max 100mbps speed.

Message 5 of 10
Not applicable

Re: R7000 Intermittent Life

What about the power led being orange and dim? This usually means corrupted FW and or hardware failure.

Message 6 of 10

Re: R7000 Intermittent Life

I did try this and nothing! 


The only thing I can think that has changed in the past couple days in the FW update. I'm in Florida and besides being freaking HOT we have had no storms or electrical issues to cause a malfunction. Yes, I have paid my Comcast bill...


I also tried to reinstall the FW through TFTP but that did not work. Command used: TFTP PUT "FW FILE NAME"


I have tried connecting my older router to it to see if I could pull an IP address, didn't work.


The lights do not blink, except when I put Cat5 into LAN port1. Power light is a little orangish/red very faint. LAN port 1 is a bright pinkish.

Message 7 of 10

Re: R7000 Intermittent Life

I can't connect to the router in any fashion, so I don't think it matters the type of device I use. I have tried three different setups; 2 laptops and one router via LAN port (Linksys E4200) and none were able to see the router on the network. I cannot TFTP to the router because the port is not listening or the router is not going through the initial BIOS or setup phases that it normally would to start connection.


I was able to resize the router photo. I currently have the LAN port1 connected to my Linksys, so you can see that port light is bright white. 


The lights from Left to Right are: POWER - faint orangish/red / 5G - faint white / USB2 - faint white / LAN port1 - bright pinkish / Wireless - Bright white


 0708161004a (800x800).jpg

Message 8 of 10
Not applicable

Re: R7000 Intermittent Life

Routers fail every day for various reasons. If this was mine and less than 1 year old I would contact support and tell them it won't power up That's it NOTHING else. Ask for RMA


I've used EVERY FW version officially released and 3 times as many Beta's test versions too in the past 3 years My r7000 is working fine. So I doubt it's FW related.



I believe red power led indicates hardware failure


Message 9 of 10

Re: R7000 Intermittent Life

Amber power button means the router is starting (initializing). See


I assume the flash had a problem installing. Maybe a power fluctuation during flash or a wireless connection was used to do the flash?


Basically I guess it means the router is bricked?


I know you tried TFTP, but here are other links to look at that could help:


Last one was updated 2 months ago and uses TFTP2 and a fixed wired IP Address, I'd try that one first but from reading it it seems to be with the router working OK? Still, it might be worth a try with TFTP2 like you used TFTP?



Message 10 of 10
Top Contributors
Discussion stats
  • 9 replies
  • 0 kudos
  • 4 in conversation

Orbi WiFi 6E