Reply

Re: R7000 VPN Won't Pass Internet Traffic At All

mustangcobra44
Aspirant

R7000 VPN Won't Pass Internet Traffic At All

I'm using the latest firmware on my R7000 and trying to get VPN to work as expected.  If I select to option to only tunnel home network stuff then all works as expected - private internal IPs are reachable across the tunnel and everything else just goes out the connection like normal.  However, if I select for it to tunnel everything "All Sites on the Internet and Home" it doesn't work right.  I can still get to internal devices but if I try to get to anything else it fails.  Doing an nslookup on any site always returns the same IP which is the internal IP on my router (in my case it's 10.16.10.1).  Since everything is being resolved to 10.16.10.1 then everything fails that I try to reach.  And if I try to just ping something by IP (like 8.8.8.8) it fails as well.  I hope this makes sense.  I've seen others post about having issues but they seem to have a different problem wherein internet sites don't get tunneled.  In my case it looks like it it's forcing everything down the tunnel but no traffic is making it out once it hits the router across the tunnel.  I've tried on Win7 64 bit and 32bit machines on two different connections (cable modem and 4G data card) and same results on all tests.

Message 1 of 7
doraemon
Prodigy

Re: R7000 VPN Won't Pass Internet Traffic At All

How about if you use the "Auto" setting? Same result? 

------------------------------
gimme dorayaki Smiley Very Happy
Message 2 of 7
mustangcobra44
Aspirant

Re: R7000 VPN Won't Pass Internet Traffic At All

I've always been leary of "auto" settings so I hadn't tried it previously.  I gave it a shot this morning and it kinda ends up as the worsts of both worlds.  With it on "Auto" I can still get the my internal stuff which has never been an issue but it still translates any name to my internal router IP and no traffic goes out (ie ping www.google.com fails because it ends up pinging the router).  I can ping stuff outside by ip, for example 8.8.8.8, but that traffic does not go across the tunnel.   It ends up working pretty much like I've chose the "Home Only" setting but without being able to do successful DNS lookups which pretty much negates getting out to anything on the web unless you know the IP addy of the sites you're looking to get to.

Message 3 of 7
doraemon
Prodigy

Re: R7000 VPN Won't Pass Internet Traffic At All

Try downgrading your fw and see if that would make a difference.
------------------------------
gimme dorayaki Smiley Very Happy
Message 4 of 7
mustangcobra44
Aspirant

Re: R7000 VPN Won't Pass Internet Traffic At All

Tried downgrading to two different versions and still the same results.  Seems like it's got to be a setting somewhere else that's not letting the traffic go back out but no idea where to look.

Message 5 of 7
JamesGL
Master

Re: R7000 VPN Won't Pass Internet Traffic At All

Hi @mustangcobra44,

 

Have you uploaded a new VPN config after the firmware update?

 

Regards,

 

JamesGL

Community Team

Message 6 of 7
johnsdagg
Guide

Re: R7000 VPN Won't Pass Internet Traffic At All

I was having the same problem on Win 10 until I remembered what the OpenVPN README file says:

 

IMPORTANT NOTE FOR WINDOWS VISTA/7 USERS

Note that on Windows Vista, you will need to run the OpenVPN
GUI with administrator privileges, so that it can add routes
to the routing table that are pulled from the OpenVPN server.
You can do this by right-clicking on the OpenVPN GUI
desktop icon, and selecting "Run as administrator".

 

Rather than always right-clicking on my icon I right-clicked it, chose Properties, then the Compatibility Tab, and then put a check mark next to Run as Administrator so that it would always do so. I'm kicking myself for the amount of time I wasted debugging this before I remembered what the README file said.

 

When running OpenVPN as Administrator, all my internet traffic goes through my home router.

 

Message 7 of 7
Discussion stats
  • 6 replies
  • 2948 views
  • 0 kudos
  • 4 in conversation
Announcements