Reply

R7000 and Surface Book Marvell AVASTAR Network Issues

R7000 and Surface Book Marvell AVASTAR Network Issues

I have a Surface Book 2 purchased last year. When trying to connect to my Wi-Fi at a family member's house the connection is constantly timing out, resulting in almost every other page load getting a "no connection" error. Troubleshooting often returns a "DNS Server Not Responding" message. I have tried setting the DNS manually and that doesn't work. I've rolled back, reinstalled, rebooted, and rewired (j/k) the driver to no avail. It is infuriating and makes any kind of computer work impossible. The most frustrating part of this is that when connected to a Mobile Hotspot, the computer works fine. And the network itself is fine because I can connect other computers/laptops/phones/tablets to it with no issues. So I imagine it's a combo of the Netgear (R7000) and the Marvell AVASTAR Wireless-AC Network Controller. Can anybody help me?

Model: R7000|AC1900 Smart WIFI Router
Message 1 of 6
DarrenM
Sr. NETGEAR Moderator

Re: R7000 and Surface Book Marvell AVASTAR Network Issues

Did you set the DNS server to googles in the PC or the routers DNS? 

 

DarrenM

Message 2 of 6
myersw
Master

Re: R7000 and Surface Book Marvell AVASTAR Network Issues

A google search shows issues with the Marvell AVASTAR. May be a driver issue and nothing to do with the router. 

--Bill
ISP Comcast, Modem-Netgear CM1150V, Router-Unifi Security Gateway-Pro4, AP-2 Unifi AP-LR
Tesla > Edison
Message 3 of 6

Re: R7000 and Surface Book Marvell AVASTAR Network Issues

DarrenM, 

I tried both ways, first one at a time, and then both at the same time.  Rebooted and flushed DNS each time.  None of that worked.

Message 4 of 6

Re: R7000 and Surface Book Marvell AVASTAR Network Issues

myersw,

Yes, but I have zero other issues with any other routers.  I'm not saying it's not a Marvell AVASTAR issue, but why would it work for literally dozens of other routers and not the R7000?  

Message 5 of 6
myersw
Master

Re: R7000 and Surface Book Marvell AVASTAR Network Issues

I assume you have tried to do a forget of the wireless connection, what ever the surface calls it and redid? That forces a rebuild of connection information. Sounds like you have already done the upgrade of the drivers. 

 

If those things have not gotten things working then yes Netgear has been putting out firmware with various wireless issues. Really a shame in the case of the r7000 as that was a solid router when I ran mine. Several years ago now, but newer firmware seems to have broken it. 

--Bill
ISP Comcast, Modem-Netgear CM1150V, Router-Unifi Security Gateway-Pro4, AP-2 Unifi AP-LR
Tesla > Edison
Message 6 of 6
Top Contributors
Discussion stats
  • 5 replies
  • 990 views
  • 3 kudos
  • 3 in conversation
Announcements

Orbi WiFi 6E