Reply

R7000 doesn't allow full internet speed

zpete
Aspirant

R7000 doesn't allow full internet speed

I just bought my R7000 and CM700 to replace my old setup a couple weeks ago. I installed both last week and also upgraded my internet service to 100Mbps on the same day after the install. After hooking everything up and setting the router up with the genie service I was getting the full 100Mbps down and around 11Mbps up for a few hours then it dropped to 5Mbps down and 11Mbps up with around 200ms jitter on my ping. Power cycling the setup can bring me back to 100Mbps but the same thing happens after a couple of hours. I have tried a couple of different cat 5e cables connecting the modem to the router and I have also tried a wired connection between my router and my computer, which both give the same results. I have also connected my computer to the modem and get the full 100Mbps. I have left all the genie settings as default and there can be up 9 devices spread across the 2.5Ghz and 5Ghz networks when eveybody is home. The firmware version is the latest which is 1.0.9.32. My ISP is Time Warner-Spectrum.

Model: R7000|Nighthawk AC1900 Dual Band WiFi Router
Message 1 of 4
IrvSp
Master

Re: R7000 doesn't allow full internet speed

Only 2 things I can think of is

  • QoS is on, disable it.
  • A device that is slow connects and uses the band and that drops the speed of the band and it does not return to full speed when that device is not in use.

Did this speed drop happen across both bands or only one? Does it drop on a wired connection?

Message 2 of 4
zpete
Aspirant

Re: R7000 doesn't allow full internet speed

QoS id disabled by default and both bands had dropped after a few hours. Same goes with a wired connection. I have power cycled when noone is home and power cycled when everyone is home and got the same result. I will also add that at the end of the genie setup where it updates the firmware for the router it was stuck in a "Attempting to connect to Netgear server" loop so I hit cancel and flashed the 1.0.9.32 version onto the router.

Message 3 of 4
IrvSp
Master

Re: R7000 doesn't allow full internet speed

At this point it might be advisable to reset the router, then re-install the firmware and manually set up the router. I'll assume you never used it with the prior flash either, so you don't know if it worked before or not?

 

To reset, easiest way is to go to the ADVANCED tab on top, Administration on the left, and then Backup Settings. Last button is ERASE, click on that, but before that make not of all the settings you changed from default so you can reenter them after loading the flash again.

Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 311 views
  • 0 kudos
  • 2 in conversation
Announcements

Orbi WiFi 6E