Reply

R7000 keep losing connectivity

leong163
Novice

R7000 keep losing connectivity

Firmware version V1.0.3.80_1.1.38

Everyday, the router is dropping connection to all my devices (e.g. computer, NAS, TV, mobile, etc.) regardless it is wired or wireless connection. Someday, it keeps on dropping every 5-10mins. Some other times, it stays connected for a few hours. However, the problem is happening everyday.

I have updated to the latest firmware, the problem does not go away. Please help.

Regards,

Leo
Message 1 of 29

Accepted Solutions
leong163
Novice

Re: R7000 keep losing connectivity

Netgear support has sent me a beta firmware to test. It has been running for over 24 hours without connectivity problem. Initially, it was not working until I first did hardware factory reset. Directly applying the beta firmware did not work.

Thank you for all the people who have been given me the support and help. You are the best.

View solution in original post

Message 20 of 29

All Replies
Mars Mug
Virtuoso

Re: R7000 keep losing connectivity

Perhaps you have a power supply issue, is the router PSU plugged into an anti-surge / anti-interference socket strip?
Message 2 of 29
jrmxrf
Novice

Re: R7000 keep losing connectivity

I have this router for a few months and this issue drives me mad.

It's properly grounded. It happens both on original firmware and dd-wrt. I'm clueless. I tried every possible option. I understand wireless is complicated but it happens with cable connection to.

TCP disconnections are hard to debug but I've been playing with ping. I have consistent 2% packet loss rate. But...

My configuration is [clients] -> [R7000] -> [another router/modem call it X] -> WAN



    Obvious conclusion would be that I have a ****ty ISP, or router X sucks. But when connected directly to X I have no packets lost. When using different router (tried a few) in place of R7000 everything also works like a charm.

    I really am clueless. Played with many options and it gave me no improvement. This connection loss is extremely annoying. It seems like it just hangs for few, maybe up to 20s. Web panel works smooth during that time, just outside connections die. Any hints much appreciated.
Message 3 of 29
leong163
Novice

Re: R7000 keep losing connectivity

All my computer equipments are surge protected. I have replaced the surge protected power bar twice already. I think the power supply issue is slim in my case. During the time of losing connectivity, all lights on the router look normal. Usually, after a minutes or so, it reconnects. The losing connectivity problem is happening randomly any time of the day. Any suggestion?
Message 4 of 29
RogerSC
Virtuoso

Re: R7000 keep losing connectivity

leong163 wrote:
During the time of losing connectivity, all lights on the router look normal. Usually, after a minutes or so, it reconnects. The losing connectivity problem is happening randomly any time of the day. Any suggestion?


Is this all your clients? Just wired or just wireless? If it was one client or two clients, you could look at updating the wireless or wired interface driver. And some Intel wireless cards have a bad reputation for problems like this. Can you please amplify some on what you're seeing?

Thanks.
Message 5 of 29
stenopete
Tutor

Re: R7000 keep losing connectivity

@leong163.. check your pm.. 🙂
Netgear R7000@FW_DD-WRT v24-sp2 (12/11/14) kongac - build 25628

LinksysCisco EA6500HD@FW_ DD-WRT v24-sp2 (12/11/14) kongac - build 25628



-AP > CLIENT WRLS BRDIGE MODE-

http://testmy.net/UGkPWzTv.png



MotoX Android@5ghz Band

MotoG Android@2.4ghz Band

Sprint Viper 4GLTE@2.4ghz Band

MS Surface Pro Tablet@5ghz Band

MS Xbox360@2.4ghz Band



MainPC.i7.4820K@4.9GHZ.X79.32GB-2400HMZ-DDR3.RD0@12TB.RD0@2x256GB.SSD.BLURAY.BDRE-XL.3xR9-290X.CorsairCase750D.

IBM.Ideapad.Lenovo.i7.Haswell-E.Z710.
Message 6 of 29
Fairytail
Virtuoso

Re: R7000 keep losing connectivity

 It would be best to contact support for assistance.

Message 7 of 29
leong163
Novice

Re: R7000 keep losing connectivity

RogerSC wrote:
Is this all your clients? Just wired or just wireless? If it was one client or two clients, you could look at updating the wireless or wired interface driver. And some Intel wireless cards have a bad reputation for problems like this. Can you please amplify some on what you're seeing?

Thanks.


I work at home. (Telco ADSL router <=> R7000 <=> My LAN) I am using R7000 in between Telco ADSL router and my home network consisting NAS, TV, computer, cell phones and etc. My computer is wired directly to R7000 and the problem is happening more than a few times per day. I would like to solve the wired problem first.

You suggest to check on the NIC update. My laptop is using Realtek PCIe GBE Family Controller for wired connection. Some people is reporting similar but not identical problem. However, I will try to reload the driver and change the parameters as suggested. I will see how it goes.

(i.e. I think the problem may not be related to NIC since when I wired my labtop directly to Telco ADSL modem, I don't have connectivity problem.)

Thanks.
Message 8 of 29
leong163
Novice

Re: R7000 keep losing connectivity

stenopete wrote:
@leong163.. check your pm.. 🙂


I am not aware R7000 will support DD-WRT. I will consider this as last solution when no other easy way out.

Thank you very much.
Message 9 of 29
leong163
Novice

Re: R7000 keep losing connectivity



Thanks. May be it is time to contact Negear and see what they will suggest.

Message 10 of 29
stenopete
Tutor

Re: R7000 keep losing connectivity

@leong163.. Check PM - again. 🙂
Netgear R7000@FW_DD-WRT v24-sp2 (12/11/14) kongac - build 25628

LinksysCisco EA6500HD@FW_ DD-WRT v24-sp2 (12/11/14) kongac - build 25628



-AP > CLIENT WRLS BRDIGE MODE-

http://testmy.net/UGkPWzTv.png



MotoX Android@5ghz Band

MotoG Android@2.4ghz Band

Sprint Viper 4GLTE@2.4ghz Band

MS Surface Pro Tablet@5ghz Band

MS Xbox360@2.4ghz Band



MainPC.i7.4820K@4.9GHZ.X79.32GB-2400HMZ-DDR3.RD0@12TB.RD0@2x256GB.SSD.BLURAY.BDRE-XL.3xR9-290X.CorsairCase750D.

IBM.Ideapad.Lenovo.i7.Haswell-E.Z710.
Message 11 of 29
Mars Mug
Virtuoso

Re: R7000 keep losing connectivity

Leong163, many ADSL modems are also routers, if yours is maybe it needs to be put into Bridged Mode.
Message 12 of 29
leong163
Novice

Re: R7000 keep losing connectivity

The telco ADSL modem has been set up in "bridge mode" during the installation of R7000. The telco router uses IP "192.168.1.1" and my R7000 uses "10.0.0.1" and the DHCP is done by R7000. I believe this IP setup arrangement should not cause problem, right?
Message 13 of 29
Mars Mug
Virtuoso

Re: R7000 keep losing connectivity

If your Bridged modem is allocating Private IP addresses rather than the Public IP address then it’s most likely not correctly set to Bridged Mode.

In the R7000 status page what do you see for the IP address of the Internet Port, just post the first two numbers, not the full IP address?
Message 14 of 29
bill1228
Guide

Re: R7000 keep losing connectivity

leong163 wrote:
I am not aware R7000 will support DD-WRT. I will consider this as last solution when no other easy way out.

Thank you very much.

Yes DD-WRT does support the R7000. Am running it on my R7000. There are issues with DD-WRT on the R7000, biggest is reboots if using "new driver" builds. Builds with the old driver, such as Kong 24345OLDD do not have the reboot issue. This is the build I run.
--bill
R7000 Firmware XVortex Merlin Port.

Everyone has a right to be stupid once in awhile. Yet some just abuse the privilege.
Message 15 of 29
Anti_Ultimate
Aspirant

Re: R7000 keep losing connectivity

The biggest problem with DD-WRT (besides random reboots, but those can be taken care off) is the NAS transfer speed. 2.5MB/s compared to Stock 16MB/s makes me wonder what is happening when using DD-WRT. These guys are doing an excellent job on that firmware however, but for people that bought the router for it's NAS function, it's a no-go.
Message 16 of 29
slidermike
Aspirant

Re: R7000 keep losing connectivity

just to be clear.
Bill is mostly right.
SOME r7000 are having a random reboot issue on the newer firmware but not all.

The only way to know is to try it. If you don't like it, flash one of the older with the oldd in the name or back to stock.
Message 17 of 29
msabadish
Novice

Re: R7000 keep losing connectivity

I have the exact same issue. I have Comcast cable and a Motorola cable modem. My R7000 reboots probably 200x daily. Have opened a service ticket with Netgear, which has generated zero assistance. Can't believe what a POS this router has been. Went Netgear as my old WNR3500L was so reliable, I never ever had a single hang up with it over years.
Will be returning the R7000 unless the good folks at Netgear deem this one to be a lemon and send another my way.
The DD-WRT idea seems crazy to me. Can't understand why I should have to replace the device software to make it function like it should out of the box.

Mike
Message 18 of 29
RogerSC
Virtuoso

Re: R7000 keep losing connectivity

msabadish wrote:

Will be returning the R7000 unless the good folks at Netgear deem this one to be a lemon and send another my way.
Mike


Sounds like you should be able to get an RMA out of them. As long as you're following best practices (resetting to factory defaults after flashing firmware, and then manually entering your settings), you shouldn't be seeing spotaneous reboots with the stock firmware.
Message 19 of 29
leong163
Novice

Re: R7000 keep losing connectivity

Netgear support has sent me a beta firmware to test. It has been running for over 24 hours without connectivity problem. Initially, it was not working until I first did hardware factory reset. Directly applying the beta firmware did not work.

Thank you for all the people who have been given me the support and help. You are the best.
Message 20 of 29
stenopete
Tutor

Re: R7000 keep losing connectivity

msabadish, WOW. I can see and 'feel' your frustration. I recall when I had my wndr3700 and boy was it 'screwey' and lets not touch on the firmware issues on that. With that said - R700 is a terrific router - I own it and speak from experience. On both sides of the firmware, DDWRT and NETGEAR FW. From what you wrote it sounds like bad fw. Check your PM. 🙂
Netgear R7000@FW_DD-WRT v24-sp2 (12/11/14) kongac - build 25628

LinksysCisco EA6500HD@FW_ DD-WRT v24-sp2 (12/11/14) kongac - build 25628



-AP > CLIENT WRLS BRDIGE MODE-

http://testmy.net/UGkPWzTv.png



MotoX Android@5ghz Band

MotoG Android@2.4ghz Band

Sprint Viper 4GLTE@2.4ghz Band

MS Surface Pro Tablet@5ghz Band

MS Xbox360@2.4ghz Band



MainPC.i7.4820K@4.9GHZ.X79.32GB-2400HMZ-DDR3.RD0@12TB.RD0@2x256GB.SSD.BLURAY.BDRE-XL.3xR9-290X.CorsairCase750D.

IBM.Ideapad.Lenovo.i7.Haswell-E.Z710.
Message 21 of 29
maclan13
Aspirant

Re: R7000 keep losing connectivity

Hello leong,

I've had the same issue for months and procrastinated returning the box. Interesting that the updated firmware resolved the issue.

Regards,
Richard
Message 22 of 29
fibercarbon
Tutor

Re: R7000 keep losing connectivity

msabadish wrote:
I have the exact same issue. I have Comcast cable and a Motorola cable modem. My R7000 reboots probably 200x daily. Have opened a service ticket with Netgear, which has generated zero assistance. Can't believe what a POS this router has been. Went Netgear as my old WNR3500L was so reliable, I never ever had a single hang up with it over years.
Will be returning the R7000 unless the good folks at Netgear deem this one to be a lemon and send another my way.
The DD-WRT idea seems crazy to me. Can't understand why I should have to replace the device software to make it function like it should out of the box.

Mike


I feel ya on this.. Had to return the first one I bought to best buy because it was not displaying webpages properly on several devices. The second one still has some latency at times have tried hard reset and latest firmware as well.. Not sure what netgear is doing with the R7000 but they need to get it together... :confused:
Message 23 of 29
kuesjr
Novice

Re: R7000 keep losing connectivity

My R7000 is 6 months old. It worked perfectly for 5 months and then started dropping wireless connectivity. I could get it to reconnect by resetting the router for a while but now even that doesn't work. I've tried changing channels without success. I've lowered the speed to 289 and that didn't work. I have the latest firmware. I do not have this problem with wired connections. The signal seems to be strong and it's a problem on all wireless devices, regardless of their distance from the router. I have the problem at 2.4G and 5G.
Message 24 of 29
EJM39
Novice

Re: R7000 keep losing connectivity

I had one wired connection drop several times a day. On advice of Customer Service person I reduced the MTU from default 1500 to 1450. The disconnecting has stopped. MTU setting is in Advance, Setup, WAN

EJM39
Message 25 of 29
Top Contributors
Discussion stats
Announcements

Orbi WiFi 6E